# Fleet Agent on Windows goes 'Unhealthy' after 7.11 upgrade

**URL:** <https://discuss.elastic.co/t/fleet-agent-on-windows-goes-unhealthy-after-7-11-upgrade/264286>\
**Category:** Kibana\
**Tags:** fleet\
**Created:** [February 15, 2021, 8:43am UTC](https://discuss.elastic.co/t/fleet-agent-on-windows-goes-unhealthy-after-7-11-upgrade/264286 "2021-02-15T08:43:19Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![hermlam](https://avatars.discourse-cdn.com/v4/letter/h/8797f3/32.png) [@hermlam](https://discuss.elastic.co/u/hermlam)\
**Post date:** [February 15, 2021, 8:43am UTC](https://discuss.elastic.co/t/fleet-agent-on-windows-goes-unhealthy-after-7-11-upgrade/264286/1 "2021-02-15T08:43:19Z")

</div>

After upgrading Elastic-Agent to 7.11 Windows machines get a 'Unhealty' state in Fleet.  
Even installing Elastic-Agent on a clean installed Windows machine will get this issue.

 ![Capture](https://us1.discourse-cdn.com/elastic/original/3X/8/d/8d6a09541c304c97d2bfe533f7e740c97e520798.jpeg)

The 4 Ubuntu servers are doing well.

Thanks,  
Herman

---

<div class="post-metadata">

**Author:** ![skh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/skh/32/38637_2.png) [@skh](https://discuss.elastic.co/u/skh)\
**Post date:** [February 15, 2021, 9:48am UTC](https://discuss.elastic.co/t/fleet-agent-on-windows-goes-unhealthy-after-7-11-upgrade/264286/2 "2021-02-15T09:48:01Z")

</div>

Is there anything in the agent logs that might point at the problem?

(For the installation layout and location of the logs see [Install Elastic Agent | Fleet User Guide [7.11] | Elastic](https://www.elastic.co/guide/en/fleet/7.11/elastic-agent-installation.html) at the bottom.)

---

<div class="post-metadata">

**Author:** ![craigothy](https://avatars.discourse-cdn.com/v4/letter/c/258eb7/32.png) [@craigothy](https://discuss.elastic.co/u/craigothy)\
**Post date:** [February 15, 2021, 4:48pm UTC](https://discuss.elastic.co/t/fleet-agent-on-windows-goes-unhealthy-after-7-11-upgrade/264286/3 "2021-02-15T16:48:24Z")

</div>

I am also noticing the same thing after upgrading. Seeing the following in the logs:

```auto
10:44:55.472

elastic_agent

[elastic_agent][info] 2021-02-15T10:44:54-06:00: type: 'STATE': sub_type: 'STARTING' message: Application: metricbeat--7.11.0[dfb0599a-9eb1-452f-8ede-3006e65996f6]: State changed to STARTING: Starting

10:44:55.472

elastic_agent

[elastic_agent][info] 2021-02-15T10:44:54-06:00: type: 'STATE': sub_type: 'STARTING' message: Application: metricbeat--7.11.0[dfb0599a-9eb1-452f-8ede-3006e65996f6]: State changed to RESTARTING: Restarting

10:44:56.491

elastic_agent

[elastic_agent][info] 2021-02-15T10:44:56-06:00: type: 'STATE': sub_type: 'STARTING' message: Application: metricbeat--7.11.0[dfb0599a-9eb1-452f-8ede-3006e65996f6]: State changed to STARTING: Starting

10:44:57.496

elastic_agent

[elastic_agent][error] 2021-02-15T10:44:56-06:00: type: 'ERROR': sub_type: 'FAILED' message: Application: metricbeat--7.11.0[dfb0599a-9eb1-452f-8ede-3006e65996f6]: State changed to FAILED: 1 error: 1 error: Error creating runner from config: 1 error: metricset 'system/load' not found

10:44:57.496

elastic_agent

[elastic_agent][info] 2021-02-15T10:44:56-06:00: type: 'STATE': sub_type: 'STARTING' message: Application: metricbeat--7.11.0[dfb0599a-9eb1-452f-8ede-3006e65996f6]: State changed to STARTING: Starting

10:44:57.496

elastic_agent

[elastic_agent][info] 2021-02-15T10:44:56-06:00: type: 'STATE': sub_type: 'STARTING' message: Application: metricbeat--7.11.0[dfb0599a-9eb1-452f-8ede-3006e65996f6]: State changed to RESTARTING: Restarting

10:45:00.527

elastic_agent

[elastic_agent][info] 2021-02-15T10:44:58-06:00: type: 'STATE': sub_type: 'STARTING' message: Application: metricbeat--7.11.0[dfb0599a-9eb1-452f-8ede-3006e65996f6]: State changed to STARTING: Starting

10:45:00.527

elastic_agent

[elastic_agent][error] 2021-02-15T10:44:59-06:00: type: 'ERROR': sub_type: 'FAILED' message: Application: metricbeat--7.11.0[dfb0599a-9eb1-452f-8ede-3006e65996f6]: State changed to FAILED: 1 error: 1 error: Error creating runner from config: 1 error: metricset 'system/load' not found

10:45:00.528

elastic_agent

[elastic_agent][info] 2021-02-15T10:44:59-06:00: type: 'STATE': sub_type: 'STARTING' message: Application: metricbeat--7.11.0[dfb0599a-9eb1-452f-8ede-3006e65996f6]: State changed to STARTING: Starting

10:45:00.528

elastic_agent

[elastic_agent][info] 2021-02-15T10:44:59-06:00: type: 'STATE': sub_type: 'STARTING' message: Application: metricbeat--7.11.0[dfb0599a-9eb1-452f-8ede-3006e65996f6]: State changed to RESTARTING: Restarting

10:45:01.531

elastic_agent

[elastic_agent][info] 2021-02-15T10:45:01-06:00: type: 'STATE': sub_type: 'STARTING' message: Application: metricbeat--7.11.0[dfb0599a-9eb1-452f-8ede-3006e65996f6]: State changed to STARTING: Starting

```

---

<div class="post-metadata">

**Author:** ![hermlam](https://avatars.discourse-cdn.com/v4/letter/h/8797f3/32.png) [@hermlam](https://discuss.elastic.co/u/hermlam)\
**Post date:** [February 15, 2021, 5:01pm UTC](https://discuss.elastic.co/t/fleet-agent-on-windows-goes-unhealthy-after-7-11-upgrade/264286/4 "2021-02-15T17:01:09Z")

</div>

Hi, Yes you were quicker than me. That’s the same error I am having.

Thanks,

Herman

---

<div class="post-metadata">

**Author:** ![craigothy](https://avatars.discourse-cdn.com/v4/letter/c/258eb7/32.png) [@craigothy](https://discuss.elastic.co/u/craigothy)\
**Post date:** [February 15, 2021, 7:20pm UTC](https://discuss.elastic.co/t/fleet-agent-on-windows-goes-unhealthy-after-7-11-upgrade/264286/5 "2021-02-15T19:20:29Z")

</div>

For what its worth, I was able to get back to a "healthy" state on my fleet windows 10 workstations by disabling the system load metrics on the policy and then restarting the elastic agent. Not sure what's wrong with the load collection on Windows but this does appear to fix the issue.

---

<div class="post-metadata">

**Author:** ![Michal\_Pristas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/michal_pristas/32/46639_2.png) [@Michal\_Pristas](https://discuss.elastic.co/u/Michal_Pristas)\
**Post date:** [February 16, 2021, 8:44am UTC](https://discuss.elastic.co/t/fleet-agent-on-windows-goes-unhealthy-after-7-11-upgrade/264286/6 "2021-02-16T08:44:41Z")

</div>

@craigothy i would say this is the correct approach here, issue was worked on and i fix will be present in next release,  
`system/load` is not supported on windows. nothing changed here but agent is just more sensitive to failures of metricbeat from this version on. so before it was failing and agent was ok with it, now it's not ok and complains.

from next version on, system/load will not be applied on windows agents

---

<div class="post-metadata">

**Author:** ![hermlam](https://avatars.discourse-cdn.com/v4/letter/h/8797f3/32.png) [@hermlam](https://discuss.elastic.co/u/hermlam)\
**Post date:** [February 16, 2021, 10:14am UTC](https://discuss.elastic.co/t/fleet-agent-on-windows-goes-unhealthy-after-7-11-upgrade/264286/7 "2021-02-16T10:14:19Z")

</div>

Hi,

Thanks both for the investigation.

Herman

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 16, 2021, 10:14am UTC](https://discuss.elastic.co/t/fleet-agent-on-windows-goes-unhealthy-after-7-11-upgrade/264286/8 "2021-03-16T10:14:36Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
