# Fleet agent

**URL:** <https://discuss.elastic.co/t/fleet-agent/296349>\
**Category:** Logs\
**Tags:** fleet\
**Created:** [February 4, 2022, 11:17pm UTC](https://discuss.elastic.co/t/fleet-agent/296349 "2022-02-04T23:17:57Z")\
**Posts on this page:** 1\
**Showing post:** 7

<div class="post-metadata">

**Author:** ![trudyc](https://avatars.discourse-cdn.com/v4/letter/t/f04885/32.png) [@trudyc](https://discuss.elastic.co/u/trudyc)\
**Post date:** [March 16, 2022, 8:36pm UTC](https://discuss.elastic.co/t/fleet-agent/296349/7 "2022-03-16T20:36:36Z")

</div>

@mostlyjason  
I was encountering similar problems on my RHEL8 hosts. I found a way to get the filebeat and metricbeat data to come through, and documented that in my post here:

> [@Beats in elastic-agent reporting "failed to connect to backoff"](https://discuss.elastic.co/t/beats-in-elastic-agent-reporting-failed-to-connect-to-backoff/299506/3):
>
> I found a work around, but still am working to find out why this was necessary. As noted earlier in the Elastic/Agent/data/elastic-agent-\*/logs/default/filebeat-json.log file (and the metricbeat-json.log file) I was seeing this message repeating. {"log.level":"error","@timestamp":"2022-03-15T17:03:41.086Z","log.logger":"publisher\_pipeline\_output","log.origin":{"file.name":"pipeline/output.go","file.line":154},"message":"Failed to connect to backoff(elasticsearch(http://localhost:9200)): Get \"…

I plan to open a support ticket with Elastic to try to get an explanation for why this would be necessary.

---

_[View the full topic](https://discuss.elastic.co/t/fleet-agent/296349)._
