# Fleet apm integration

**URL:** <https://discuss.elastic.co/t/fleet-apm-integration/307269>\
**Category:** APM\
**Tags:** fleet, server\
**Created:** [June 15, 2022, 12:19pm UTC](https://discuss.elastic.co/t/fleet-apm-integration/307269 "2022-06-15T12:19:10Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![antoteo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/antoteo/32/88393_2.png) [@antoteo](https://discuss.elastic.co/u/antoteo)\
**Post date:** [June 15, 2022, 12:19pm UTC](https://discuss.elastic.co/t/fleet-apm-integration/307269/1 "2022-06-15T12:19:10Z")

</div>

hello

i have elastic stack and runnning fleet all 7.17 version  
i want to intergrade apm elastic without having a dedicated apm -server

so the elastic-agent status says healthy on the servers that run fleet server

but on all the other servers (same subnet) the status is stack on (CONFIGURING) Updating configuration

and logs are

[elastic\_agent.apm\_server][error] listen tcp ....:8200: bind: cannot assign requested address  
[elastic\_agent.apm\_server][info] Applying settings for output  
[elastic\_agent.apm\_server][info] Falling back to Elasticsearch output for sourcemap storage  
[elastic\_agent.apm\_server][info] apm-server.sampling.keep\_unsampled is deprecated and will default to `false` in 8.0. It will be removed in a subsequent version.  
[elastic\_agent.apm\_server][error] listen tcp ....:8200: bind: cannot assign requested address  
[elastic\_agent.apm\_server][error] failed applying config blocks: nil

but filebeat and metrics works fine

can you help please?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2022, 8:19am UTC](https://discuss.elastic.co/t/fleet-apm-integration/307269/2 "2022-07-06T08:19:49Z")

</div>

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.
