# Fleet initial error

**URL:** https://discuss.elastic.co/t/fleet-initial-error/347225
**Category:** Elastic Agent
**Tags:** fleet
**Created:** [November 15, 2023, 12:53pm UTC](https://discuss.elastic.co/t/fleet-initial-error/347225 "2023-11-15T12:53:00Z")
**Posts on this page:** 19
**Page:** 1

<div class="post-metadata">

### Author: ![mohd\_sa](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mohd_sa/32/124547_2.png) [@mohd\_sa](https://discuss.elastic.co/u/mohd_sa)
#### Post date: [November 15, 2023, 12:53pm UTC](https://discuss.elastic.co/t/fleet-initial-error/347225/1 "2023-11-15T12:53:00Z")

</div>

Hi  
after upgrade from 8.9.1 to 8.11.1 , I have error on fleet page "unable to initialize fleet, uninstall token is missing the token"

---

<div class="post-metadata">

### Author: ![amarnath](https://avatars.discourse-cdn.com/v4/letter/a/ecccb3/32.png) [@amarnath](https://discuss.elastic.co/u/amarnath)
#### Post date: [November 18, 2023, 1:07pm UTC](https://discuss.elastic.co/t/fleet-initial-error/347225/2 "2023-11-18T13:07:03Z")

</div>

Hi @mohd_sa im also facing same issue, any luck?

---

<div class="post-metadata">

### Author: ![mohd\_sa](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mohd_sa/32/124547_2.png) [@mohd\_sa](https://discuss.elastic.co/u/mohd_sa)
#### Post date: [November 18, 2023, 2:38pm UTC](https://discuss.elastic.co/t/fleet-initial-error/347225/3 "2023-11-18T14:38:54Z")

</div>

i did not find any solution

---

<div class="post-metadata">

### Author: ![amarnath](https://avatars.discourse-cdn.com/v4/letter/a/ecccb3/32.png) [@amarnath](https://discuss.elastic.co/u/amarnath)
#### Post date: [November 18, 2023, 4:43pm UTC](https://discuss.elastic.co/t/fleet-initial-error/347225/4 "2023-11-18T16:43:18Z")

</div>

so whtas the next move? just asking. We got this error because kibana instance got replaced as a part of autoscaling group health check and it resulted with the error uninstall token missing when clicked on fleet tab in kibana interface. sad part is elk documentation also doesnt have any clue of this.

---

<div class="post-metadata">

### Author: ![kpollich](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kpollich/32/93788_2.png) [@kpollich](https://discuss.elastic.co/u/kpollich)
#### Post date: [November 20, 2023, 8:05pm UTC](https://discuss.elastic.co/t/fleet-initial-error/347225/5 "2023-11-20T20:05:45Z")

</div>

Hi folks, We've seen this reported in a few places so far on the 8.11.1 release and we're taking a look. Once we have a public issue or know a little bit more about the root cause I'll post an update here.

One thing that'd be helpful to know: does anyone encountering this issue make use of [Kibana's saved objects encryption feature](https://www.elastic.co/guide/en/kibana/current/xpack-security-secure-saved-objects.html)? The errors message we're seeing here is related to saved object encryption, and we're trying to track down the root cause.

Many thanks, and I hope to have an update for you all soon.

---

<div class="post-metadata">

### Author: ![HansPeterSloot](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hanspetersloot/32/51132_2.png) [@HansPeterSloot](https://discuss.elastic.co/u/HansPeterSloot)
#### Post date: [November 21, 2023, 9:23am UTC](https://discuss.elastic.co/t/fleet-initial-error/347225/6 "2023-11-21T09:23:09Z")

</div>

Hello  
All my rules (under Alerts and Insights) were generating api key errors  
I disabled them and did Update Api Key for all of them.  
After that I did not have any api key errors anymore.

But fleet is still is still giving

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/c/c/cc436e4cd7a7c9ab2caa05b04db307933872d256.png)

My environment is on Openshift  
The kibana.yml is stored in a secret and has

xpack:  
encryptedSavedObjects:  
encryptionKey: ................

---

<div class="post-metadata">

### Author: ![HansPeterSloot](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hanspetersloot/32/51132_2.png) [@HansPeterSloot](https://discuss.elastic.co/u/HansPeterSloot)
#### Post date: [November 21, 2023, 11:11am UTC](https://discuss.elastic.co/t/fleet-initial-error/347225/7 "2023-11-21T11:11:07Z")

</div>

We just discovered that we do have issues with Rules:

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/c/3/c37af2732edb3d159738ab1c316ee4d717bafa22.png)

---

<div class="post-metadata">

### Author: ![kpollich](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kpollich/32/93788_2.png) [@kpollich](https://discuss.elastic.co/u/kpollich)
#### Post date: [November 21, 2023, 11:17am UTC](https://discuss.elastic.co/t/fleet-initial-error/347225/8 "2023-11-21T11:17:32Z")

</div>

Thanks @HansPeterSloot - this is very helpful as it appears to confirm this is a broader issue with encrypted saved objects that isn't limited to Fleet. We've got a few teams looking at this internally today.

---

<div class="post-metadata">

### Author: ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)
#### Post date: [November 21, 2023, 12:03pm UTC](https://discuss.elastic.co/t/fleet-initial-error/347225/9 "2023-11-21T12:03:57Z")

</div>

@kpollich is there any public issue on github about this?

We were planning to upgrade to 8.11, but after seeing that this can cause issues with Alert Rules, which is our main use case we can not upgrade anymore and risk any impacts to our operations.

Would like to follow some issue to know when it is safe to Upgrade.

---

<div class="post-metadata">

### Author: ![kpollich](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kpollich/32/93788_2.png) [@kpollich](https://discuss.elastic.co/u/kpollich)
#### Post date: [November 21, 2023, 12:17pm UTC](https://discuss.elastic.co/t/fleet-initial-error/347225/10 "2023-11-21T12:17:38Z")

</div>

@leandrojmp - I've just created [[Encrypted Saved Objects] Multiple plugins experiencing errors with encrypted saved objects in 8.11.1 · Issue #171630 · elastic/kibana · GitHub](https://github.com/elastic/kibana/issues/171630) to track this publicly. I'll keep this updated with our findings as we work, so please feel free to follow along there 🙏

---

<div class="post-metadata">

### Author: ![kpollich](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kpollich/32/93788_2.png) [@kpollich](https://discuss.elastic.co/u/kpollich)
#### Post date: [November 21, 2023, 2:43pm UTC](https://discuss.elastic.co/t/fleet-initial-error/347225/11 "2023-11-21T14:43:05Z")

</div>

Question for folks here: is anyone using Elastic Cloud on Kubernetes ([Overview | Elastic Cloud on Kubernetes [2.10] | Elastic](https://www.elastic.co/guide/en/cloud-on-k8s/current/k8s-overview.html)), or are these all self-hosted clusters?

We've seen this reported in support cases internally on ECK, and I see Hans's example above is on OpenShift (so similar K8's concerns), and I'm trying to determine whether these are related.

Many thanks. We have 3-4 engineering teams all looking at this urgently today and I will continue to provide updates here and on the public issue.

---

<div class="post-metadata">

### Author: ![raymond74](https://avatars.discourse-cdn.com/v4/letter/r/58f4c7/32.png) [@raymond74](https://discuss.elastic.co/u/raymond74)
#### Post date: [November 22, 2023, 11:06am UTC](https://discuss.elastic.co/t/fleet-initial-error/347225/12 "2023-11-22T11:06:37Z")

</div>

If we want to proceed to normal operations isnt reverting back (from a restore) to 8.10 a possible way forward until this is resolved. As it does not look like this is an easy problem (wrong encryption key in a new software release?)

---

<div class="post-metadata">

### Author: ![kpollich](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kpollich/32/93788_2.png) [@kpollich](https://discuss.elastic.co/u/kpollich)
#### Post date: [November 22, 2023, 2:15pm UTC](https://discuss.elastic.co/t/fleet-initial-error/347225/13 "2023-11-22T14:15:10Z")

</div>

It's not clear to me whether rolling back to a previous version would fix the issue, but it's certainly worth a try. I'd be curious to know if you're running on ECK, and if you could provide any Kibana logs from before and after the upgrade.

I've posted a lot of findings and details over on [[Encrypted Saved Objects] Multiple plugins experiencing errors with encrypted saved objects in 8.11.1 · Issue #171630 · elastic/kibana · GitHub](https://github.com/elastic/kibana/issues/171630) today, for anyone following along.

---

<div class="post-metadata">

### Author: ![raymond74](https://avatars.discourse-cdn.com/v4/letter/r/58f4c7/32.png) [@raymond74](https://discuss.elastic.co/u/raymond74)
#### Post date: [November 22, 2023, 2:20pm UTC](https://discuss.elastic.co/t/fleet-initial-error/347225/14 "2023-11-22T14:20:52Z")

</div>

@HansPeterSloot could you provide these ?

---

<div class="post-metadata">

### Author: ![HansPeterSloot](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hanspetersloot/32/51132_2.png) [@HansPeterSloot](https://discuss.elastic.co/u/HansPeterSloot)
#### Post date: [November 22, 2023, 3:09pm UTC](https://discuss.elastic.co/t/fleet-initial-error/347225/15 "2023-11-22T15:09:31Z")

</div>

We are running on Openshift.  
I do not have any logs from before.

---

<div class="post-metadata">

### Author: ![HansPeterSloot](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hanspetersloot/32/51132_2.png) [@HansPeterSloot](https://discuss.elastic.co/u/HansPeterSloot)
#### Post date: [November 22, 2023, 3:29pm UTC](https://discuss.elastic.co/t/fleet-initial-error/347225/16 "2023-11-22T15:29:36Z")

</div>

> [@kpollich](#):
>
> worth a try. I'd be curious to know if you're running on ECK, and if you could provide any Kibana logs from before and after the upgrade.
> 
> I've posted a lot of findings and details over on [[Encrypted Saved Objects] Multiple plugins experiencing errors with encrypted saved objects in 8.11.1 · Issue #171630 · elastic/kibana · GitHub ](https://github.com/elastic/kibana/issues/171630) today, for anyone following along.

I am now restoring a snapshot from before the upgrade on a separate cluster.

---

<div class="post-metadata">

### Author: ![kpollich](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kpollich/32/93788_2.png) [@kpollich](https://discuss.elastic.co/u/kpollich)
#### Post date: [November 27, 2023, 5:48pm UTC](https://discuss.elastic.co/t/fleet-initial-error/347225/17 "2023-11-27T17:48:22Z")

</div>

Hi all, I've posted a workaround to unblock Fleet in the instance of this error here: [[Encrypted Saved Objects] Multiple plugins experiencing errors with encrypted saved objects in 8.11.1 · Issue #171630 · elastic/kibana · GitHub](https://github.com/elastic/kibana/issues/171630#issuecomment-1828328685).

We've validated this workaround internally and in production for a few users, but please let me know if you run into any issues with it.

As far as a root cause goes, I'm afraid I don't have much news there. We're still working with a few teams at trying to track down the root cause here and why this happened specifically during the 8.11 release cycle. I will post an update as soon as I have one.

Thanks for your patience 🙏

---

<div class="post-metadata">

### Author: ![amarnath](https://avatars.discourse-cdn.com/v4/letter/a/ecccb3/32.png) [@amarnath](https://discuss.elastic.co/u/amarnath)
#### Post date: [December 13, 2023, 8:12am UTC](https://discuss.elastic.co/t/fleet-initial-error/347225/18 "2023-12-13T08:12:49Z")

</div>

im using self-hosted fleet in aws ec2. im facing below errors

1. im getting unable to intilaise fleet error in an intermittent way, means after around two minutes im logged out from my account and when i re-login i can see the fleet option back again.
2. im unable to download the policy or view the policy which is created while adding a fleet server. as a result of this when i run the commands to add fleet server the response im getting is waiting for fleet-server policy.

can you help on this? please. i have attached the screenshot.

Thanks.

 ![Screenshot 2023-12-13 135133](https://us1.discourse-cdn.com/elastic/original/3X/a/b/abeb366bd819c5d7feeb6d70de35b06c6f375daf.png)

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [January 10, 2024, 8:12am UTC](https://discuss.elastic.co/t/fleet-initial-error/347225/19 "2024-01-10T08:12:56Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
