# Fleet integrations page failing to load

**URL:** <https://discuss.elastic.co/t/fleet-integrations-page-failing-to-load/345473>\
**Category:** Elasticsearch\
**Tags:** fleet\
**Created:** [October 20, 2023, 3:17pm UTC](https://discuss.elastic.co/t/fleet-integrations-page-failing-to-load/345473 "2023-10-20T15:17:55Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![tdanno](https://avatars.discourse-cdn.com/v4/letter/t/f0a364/32.png) [@tdanno](https://discuss.elastic.co/u/tdanno)\
**Post date:** [October 20, 2023, 3:17pm UTC](https://discuss.elastic.co/t/fleet-integrations-page-failing-to-load/345473/1 "2023-10-20T15:17:55Z")

</div>

On three separate clusters in three different parts of the world everything is functioning fine except the ability to fully load the integrations page- it seems like whatever it needs to do to reach out to the central repo is failing.

Is the central repo down right now?

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [October 21, 2023, 6:45am UTC](https://discuss.elastic.co/t/fleet-integrations-page-failing-to-load/345473/2 "2023-10-21T06:45:57Z")

</div>

Can you curl the endpoint?

`https://epr.elastic.co/`

Looks up to me

---

<div class="post-metadata">

**Author:** ![A\_Abdellah](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/a_abdellah/32/100734_2.png) [@A\_Abdellah](https://discuss.elastic.co/u/A_Abdellah)\
**Post date:** [October 22, 2023, 11:18am UTC](https://discuss.elastic.co/t/fleet-integrations-page-failing-to-load/345473/3 "2023-10-22T11:18:47Z")

</div>

Hello,  
It seems to be a new issue, I would like to inform you that this error meant usually no access to package registry. I used to resolve this using the air gapped configuration.

but now with version 8.10.2 its not working for me, I noticed that **security \> alerts \> manage rules** is failling to load also.

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [October 22, 2023, 4:11pm UTC](https://discuss.elastic.co/t/fleet-integrations-page-failing-to-load/345473/4 "2023-10-22T16:11:34Z")

</div>

Hi @A_Abdellah

Apologies, but there is not enough information to help with.

Perhaps upgrade to 8.10.4?

Or open a detailed issue against the repo, with the detailed steps / screenshots etc.

> **[Issues · elastic/kibana](https://github.com/elastic/kibana/issues?q=is%3Aissue%2Bis%3Aopen%2Bintegration%2Bpage%2Bfails%2Bto%2Bload)**
>
> Your window into the Elastic Stack. Contribute to elastic/kibana development by creating an account on GitHub.

---

<div class="post-metadata">

**Author:** ![tdanno](https://avatars.discourse-cdn.com/v4/letter/t/f0a364/32.png) [@tdanno](https://discuss.elastic.co/u/tdanno)\
**Post date:** [October 25, 2023, 7:19pm UTC](https://discuss.elastic.co/t/fleet-integrations-page-failing-to-load/345473/5 "2023-10-25T19:19:32Z")

</div>

Hello,

I was able to trace the problem and learn about Elasticsearch.

The Integrations loaded on said page are done directly from your computer to the elastic repo, NOT from Kibana or the Elasticsearch cluster, etc.

As it turns out, I was having corporate VPN issues, and when not using that source, all three clusters loaded their respective Integrations pages properly.

I hope this helps others that run into a similar conundrum.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 22, 2023, 7:19pm UTC](https://discuss.elastic.co/t/fleet-integrations-page-failing-to-load/345473/6 "2023-11-22T19:19:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
