# Fleet Server Docker Failing to Start no Error message

**URL:** <https://discuss.elastic.co/t/fleet-server-docker-failing-to-start-no-error-message/311294>\
**Category:** Elastic Agent\
**Tags:** fleet\
**Created:** [August 3, 2022, 11:00am UTC](https://discuss.elastic.co/t/fleet-server-docker-failing-to-start-no-error-message/311294 "2022-08-03T11:00:12Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![maehue](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/maehue/32/57036_2.png) [@maehue](https://discuss.elastic.co/u/maehue)\
**Post date:** [August 3, 2022, 11:00am UTC](https://discuss.elastic.co/t/fleet-server-docker-failing-to-start-no-error-message/311294/1 "2022-08-03T11:00:12Z")

</div>

I am having a hard time getting the Elastic Agent running as Server for Fleet in docker. I apologize I have to retype my environment here on my personal account as I am not yet on the enterprise support so its difficult for me to include entire configurations and logs as the work is being done on prem - which I'm aware Fleet at least in the past was not a friendly install in a 'traditional' enterprise where servers can't directly access the internet (this is not a new thing)

From docker-compose:

```nohighlight
environment:
  - FLEET_SERVER_ENABLE=1
  - FLEET_SERVER_INSECURE_HTTP=0
  - FLEET_SERVER_SERVICE_TOKEN=token here
  - FLEET_SERVER_ELASTICSEARCH_HOST=https....
  - FLEET_SERVER_ELASTICSEARCH_CA=/usr/share/elastic-agent/ca.pem
  - FLEET_INSECURE=1
  - FLEET_POLICY_ID=the guid here not the friendly 'name'
volumes:
- ./ca.pem:/usr/share/elastic-agent/ca.pem:ro

```

When I attempt to start fleet with these settings

```auto
State Changed to STARTING 
State Changed to RESTARTING
State changed to STARTING
State Changed to RESTARTING
State Changed to DEGRADED Missed last check-in sub_type 'RUNNING'
State Changed to FAILED Missed two check-ins - type ERROR 

```

There is no error message that I see it basically just quits from here and no other logs.

I should note on the host the owner:group of the ca.pem is a service account not root. So I attempted both with root:root and root:service account group and permission denied on the ca.pem at start.

Any suggestions greatly appreciated. I suspect its related to the cert - but I don't really have a log I can find to begin troubleshooting.

All I want to do is setup the APM tool and in the past I've done that without Fleet but maybe that documentation has been scrubbed from the internet - if that is out there somewhere for 7x installs please share.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 31, 2022, 11:00am UTC](https://discuss.elastic.co/t/fleet-server-docker-failing-to-start-no-error-message/311294/2 "2022-08-31T11:00:27Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
