# Fleet-server installation error

**URL:** <https://discuss.elastic.co/t/fleet-server-installation-error/288033>\
**Category:** Beats\
**Tags:** fleet\
**Created:** [October 29, 2021, 7:37pm UTC](https://discuss.elastic.co/t/fleet-server-installation-error/288033 "2021-10-29T19:37:17Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Duane\_Wylie](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/duane_wylie/32/81969_2.png) [@Duane\_Wylie](https://discuss.elastic.co/u/Duane_Wylie)\
**Post date:** [October 29, 2021, 7:37pm UTC](https://discuss.elastic.co/t/fleet-server-installation-error/288033/1 "2021-10-29T19:37:17Z")

</div>

I'm trying to stand up an on-prem Elasticstack deployment (Ubuntu 20.04 and Elastic 7.15). I have Elasticsearch and Kibana setup and working. I'm in the process of setting up the Fleet-server.

I'm getting this message repeatedly in the fleet-server-json.log:  
{"log.level":"info","service.name":"fleet-server","status":"DEGRADED","@timestamp":"2021-10-29T19:31:19.005Z","message":"Running on policy with Fleet Server integration: 596b4890-38d7-11ec-8ebd-bb2d4b3d4410; missing config fleet.agent.id (expected during bootstrap process)"}

This is the very first elastic-agent and fleet-server I'm setting up. I didn't see reference to this anywhere in the Kibana Fleet section.

Where can I set this information? Since none of the docs talk about this setting, I assume this would be autoconfigured. Is this error an indication of a deeper problem?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 26, 2021, 11:52pm UTC](https://discuss.elastic.co/t/fleet-server-installation-error/288033/4 "2021-11-26T23:52:11Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
