# Fleet Server Problems

**URL:** <https://discuss.elastic.co/t/fleet-server-problems/299204>\
**Category:** Elastic Security\
**Tags:** fleet\
**Created:** [March 9, 2022, 11:37am UTC](https://discuss.elastic.co/t/fleet-server-problems/299204 "2022-03-09T11:37:31Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![janis.cimins](https://avatars.discourse-cdn.com/v4/letter/j/d2c977/32.png) [@janis.cimins](https://discuss.elastic.co/u/janis.cimins)\
**Post date:** [March 9, 2022, 11:37am UTC](https://discuss.elastic.co/t/fleet-server-problems/299204/1 "2022-03-09T11:37:32Z")

</div>

Hello,

I just installed newest Elastic SIEM on my system. All seems fine at this moment. I have filebeat set up on the server etc.

But when I try endpoint security then I run into a problem and I get an error that I can not find how to solve:

```auto
siem@siem:~/elastic-agent-8.1.0-linux-x86_64$ sudo ./elastic-agent install \
> --fleet-server-es=http://172.23.27.98:9200 \
> --fleet-server-service-token=AAEAAWVsYXN0aWMvZmxlZXQtc2VydmVyL3Rva2VuLTE2NDY4MjU0NTQ2NzU6V09RbURVak9RMy0tUG0yeVZ2b3ZtUQ \
> --fleet-server-policy=34da2970-9f9c-11ec-83d5-65e20cafef36 \
> --fleet-server-insecure-http
Elastic Agent will be installed at /opt/Elastic/Agent and will run as a service. Do you want to continue? [Y/n]:y
{"log.level":"info","@timestamp":"2022-03-09T11:31:10.254Z","log.origin":{"file.name":"cmd/enroll_cmd.go","file.line":744},"message":"Waiting for Elastic Agent to start Fleet Server","ecs.version":"1.6.0"}
{"log.level":"info","@timestamp":"2022-03-09T11:31:12.256Z","log.origin":{"file.name":"cmd/enroll_cmd.go","file.line":777},"message":"Fleet Server - Starting","ecs.version":"1.6.0"}
{"log.level":"info","@timestamp":"2022-03-09T11:31:16.260Z","log.origin":{"file.name":"cmd/enroll_cmd.go","file.line":777},"message":"Fleet Server - Error - failed version compatibility check with elasticsearch: unsupported version","ecs.version":"1.6.0"}
Error: fleet-server failed: context canceled
For help, please see our troubleshooting guide at https://www.elastic.co/guide/en/fleet/8.1/fleet-troubleshooting.html
Error: enroll command failed with exit code: 1
For help, please see our troubleshooting guide at https://www.elastic.co/guide/en/fleet/8.1/fleet-troubleshooting.html
siem@siem:~/elastic-agent-8.1.0-linux-x86_64$

```

What is " **Fleet Server - Error - failed version compatibility check with Elasticsearch: unsupported version","ecs.version":"1.6.0"**" error I do not know.

I have gone through same installation a lot of times and never I have received this error once.

Please help me how to fix it.

---

<div class="post-metadata">

**Author:** ![ruflin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ruflin/32/3116_2.png) [@ruflin](https://discuss.elastic.co/u/ruflin)\
**Post date:** [March 10, 2022, 7:27am UTC](https://discuss.elastic.co/t/fleet-server-problems/299204/2 "2022-03-10T07:27:24Z")

</div>

Debugging currently happens in this issue: [Elastic Fleet Server problem · Issue #1210 · elastic/fleet-server · GitHub](https://github.com/elastic/fleet-server/issues/1210) Lets keep the conversation in a single place.

---

<div class="post-metadata">

**Author:** ![janis.cimins](https://avatars.discourse-cdn.com/v4/letter/j/d2c977/32.png) [@janis.cimins](https://discuss.elastic.co/u/janis.cimins)\
**Post date:** [March 15, 2022, 12:21pm UTC](https://discuss.elastic.co/t/fleet-server-problems/299204/3 "2022-03-15T12:21:56Z")

</div>

Hello.  
I have resolved this one. This was due to my shit knowledge and lack of work with Elastic products (just started to learn).

When installed new 8.1 version and connected with Kibana I did for some reason put http **S** \<\< in fleet server URL and then there was a problem with those versions and I guess certificates as well. Now it works for me at least. Thanks!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 12, 2022, 12:22pm UTC](https://discuss.elastic.co/t/fleet-server-problems/299204/4 "2022-04-12T12:22:54Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
