# Fleet Server won't start - certificate error

**URL:** <https://discuss.elastic.co/t/fleet-server-wont-start-certificate-error/274617>\
**Category:** Elastic Security\
**Tags:** fleet\
**Created:** [June 1, 2021, 10:48am UTC](https://discuss.elastic.co/t/fleet-server-wont-start-certificate-error/274617 "2021-06-01T10:48:23Z")\
**Posts on this page:** 1\
**Showing post:** 2

<div class="post-metadata">

**Author:** ![Koji\_Kawamura](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/koji_kawamura/32/93938_2.png) [@Koji\_Kawamura](https://discuss.elastic.co/u/Koji_Kawamura)\
**Post date:** [June 3, 2021, 2:12am UTC](https://discuss.elastic.co/t/fleet-server-wont-start-certificate-error/274617/2 "2021-06-03T02:12:31Z")

</div>

Hi John,

I encountered the same error and just found another discussion here.

> [@Cannot Install Fleet Server](https://discuss.elastic.co/t/cannot-install-fleet-server/274764):
>
> Hello there, Server info: 1 - I´m running ubuntu server 18.04 2 - Elk stack running on 7.13 version I´m trying to add a fleet server on a self managed host but no luck. Following the kibana instructions this is what I´m getting so far: 1 - From kibana screen, I´m trying to add the fleet server 2 - Downloaded the elastic agent to the same elk server (DEB x64 version) 3 - Generated the token 4 - Followed the instructions for the commands to be used Then, I receive a lot of X509 errors. So…

As written in the discussion, adding `--fleet-server-es-ca` addressed the error in my case, too:

```auto
sudo ./elastic-agent install -f --fleet-server-es=https://localhost:9200 --fleet-server-es-ca=/usr/local/etc/elastic/elasticsearch-ca.pem --fleet-server-service-token=AAEAA...Mdw

```

I hope this helps!

---

_[View the full topic](https://discuss.elastic.co/t/fleet-server-wont-start-certificate-error/274617)._
