# \[FORBIDDEN / 12 / index read - only / allow delete(api)\] Error with Elasticsearch.Net

**URL:** <https://discuss.elastic.co/t/forbidden-12-index-read-only-allow-delete-api-error-with-elasticsearch-net/148706>\
**Category:** Elasticsearch\
**Created:** [September 15, 2018, 2:01pm UTC](https://discuss.elastic.co/t/forbidden-12-index-read-only-allow-delete-api-error-with-elasticsearch-net/148706 "2018-09-15T14:01:06Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Rammohan91](https://avatars.discourse-cdn.com/v4/letter/r/d07c76/32.png) [@Rammohan91](https://discuss.elastic.co/u/Rammohan91)\
**Post date:** [September 15, 2018, 2:01pm UTC](https://discuss.elastic.co/t/forbidden-12-index-read-only-allow-delete-api-error-with-elasticsearch-net/148706/1 "2018-09-15T14:01:06Z")

</div>

Hi There,

I am having an issue while trying to perform PUT request from [ElasticSearch.Net](http://ElasticSearch.Net). First run successsfully inserts the document record, however when i update the data for another document and runs again, it just throws an error.

Here is the error the i get,

> {  
> "error": {  
> "root\_cause": [{  
> "type": "cluster\_block\_exception",  
> "reason": "blocked by: [FORBIDDEN / 12 / index read - only / allow delete(api)];  
> "}],"  
> type ":"  
> cluster\_block\_ex  
> ception ","  
> reason ":"  
> blocked by: [FORBIDDEN / 12 / index read - only / allow delete(api)];  
> "},"  
> status ":403  
> }

I again have to perform the below PUT Operation to make it work,

> ```
> PUT employees/_settings
> {
> "index": {
> "blocks": {
> "read_only_allow_delete": "false"
> }
> }
> }
> 
> ```

My Sample Test C# Snippet looks like this,

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/8/f/8fb2ab8047c6e80f95fc1acd035fc1977967fecc.png)

It would be great if someone could help to overcome this issue.

Thanks,  
Rammohan B.

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [September 15, 2018, 2:08pm UTC](https://discuss.elastic.co/t/forbidden-12-index-read-only-allow-delete-api-error-with-elasticsearch-net/148706/2 "2018-09-15T14:08:18Z")

</div>

That can be a sign that you are running out of disk space and have exceeded the [flood stage watermark](https://www.elastic.co/guide/en/elasticsearch/reference/6.4/disk-allocator.html). Have a look at how large percentage of your disk space that is still free.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 13, 2018, 2:08pm UTC](https://discuss.elastic.co/t/forbidden-12-index-read-only-allow-delete-api-error-with-elasticsearch-net/148706/3 "2018-10-13T14:08:31Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
