# Found strange problem on 0.19.4

**URL:** <https://discuss.elastic.co/t/found-strange-problem-on-0-19-4/7800>\
**Category:** Elasticsearch\
**Created:** [May 22, 2012, 5:49am UTC](https://discuss.elastic.co/t/found-strange-problem-on-0-19-4/7800 "2012-05-22T05:49:43Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![vreal](https://avatars.discourse-cdn.com/v4/letter/v/5f9b8f/32.png) [@vreal](https://discuss.elastic.co/u/vreal)\
**Post date:** [May 22, 2012, 5:49am UTC](https://discuss.elastic.co/t/found-strange-problem-on-0-19-4/7800/1 "2012-05-22T05:49:43Z")

</div>

I've just upgrade my elastic search to 0.19.4 on ec2 and aws plugin is 1.5.0. I ran two web apps in one tomcat and both of them started an elasticsearch client using same code.

After I started tomcat the first client has connected to the es cluster successfully but the second is always fail to connect to the client with such error:

05:44:07.227 INFO (Slf4jESLogger.java:94) - [Meld] failed to send join request to master [[Infamnia][aZoGhrLzSk6iSZIv2d\_PAA][inet[/10.223.23.106:9300]]], reason [org.elasticsearch.transport.RemoteTransportException: [Infamnia][inet[/10.223.23.106:9300]][discovery/zen/join]; org.elasticsearch.transport.ConnectTransportException: [Meld][inet[/10.195.83.112:9301]] connect\_timeout[30s]; org.elasticsearch.common.netty.channel.ChannelException: Failed to create a selector.]

I was using 0.19.0 and all works fine and I didn't change any code of connection but just rebuild the jar file.  
Can anyone give me some advices? Thanks

Regards,  
Bruce

---

<div class="post-metadata">

**Author:** ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)\
**Post date:** [May 22, 2012, 9:26am UTC](https://discuss.elastic.co/t/found-strange-problem-on-0-19-4/7800/2 "2012-05-22T09:26:42Z")

</div>

Do you see any more details in the logs? Which JVM version and OS are you  
using?

On Tue, May 22, 2012 at 7:49 AM, Ye Zhou [zhouy.vreal@gmail.com](mailto:zhouy.vreal@gmail.com) wrote:

> I've just upgrade my Elasticsearch to 0.19.4 on ec2 and aws plugin is  
> 1.5.0. I ran two web apps in one tomcat and both of them started an  
> elasticsearch client using same code.
> 
> After I started tomcat the first client has connected to the es cluster  
> successfully but the second is always fail to connect to the client with  
> such error:
> 
> 05:44:07.227 INFO (Slf4jESLogger.java:94) - [Meld] failed to send join  
> request to master  
> [[Infamnia][aZoGhrLzSk6iSZIv2d\_PAA][inet[/10.223.23.106:9300]]], reason  
> [org.elasticsearch.transport.RemoteTransportException:  
> [Infamnia][inet[/10.223.23.106:9300]][discovery/zen/join];  
> org.elasticsearch.transport.ConnectTransportException: [Meld][inet[/  
> 10.195.83.112:9301]] connect\_timeout[30s];  
> org.elasticsearch.common.netty.channel.ChannelException: Failed to create a  
> selector.]
> 
> I was using 0.19.0 and all works fine and I didn't change any code of  
> connection but just rebuild the jar file.  
> Can anyone give me some advices? Thanks
> 
> Regards,  
> Bruce

---

<div class="post-metadata">

**Author:** ![vreal](https://avatars.discourse-cdn.com/v4/letter/v/5f9b8f/32.png) [@vreal](https://discuss.elastic.co/u/vreal)\
**Post date:** [May 23, 2012, 12:49am UTC](https://discuss.elastic.co/t/found-strange-problem-on-0-19-4/7800/3 "2012-05-23T00:49:16Z")

</div>

Hi,  
The os is Amazon Linux 64 bit build on Mar 2012 on EC2 and the JVM is OpenJDK 64-bit Server VM (build 20.0-b11, mixed mode), Java version is 1.6.0\_22.  
The machine was freeze so I can't get any details. I finally solve it by upgrade the machine to a bigger instance(was using micro with 512M memory, now I'm using small with 1280M memory). Could that be the new version of elasticsearch requires more compute resources than 0.19.0 or because of the new version of Lucene?

Regards,  
Bruce

On 22/05/2012, at 5:26 PM, Shay Banon wrote:

> Do you see any more details in the logs? Which JVM version and OS are you using?
> 
> On Tue, May 22, 2012 at 7:49 AM, Ye Zhou [zhouy.vreal@gmail.com](mailto:zhouy.vreal@gmail.com) wrote:  
> I've just upgrade my Elasticsearch to 0.19.4 on ec2 and aws plugin is 1.5.0. I ran two web apps in one tomcat and both of them started an elasticsearch client using same code.
> 
> After I started tomcat the first client has connected to the es cluster successfully but the second is always fail to connect to the client with such error:
> 
> 05:44:07.227 INFO (Slf4jESLogger.java:94) - [Meld] failed to send join request to master [[Infamnia][aZoGhrLzSk6iSZIv2d\_PAA][inet[/10.223.23.106:9300]]], reason [org.elasticsearch.transport.RemoteTransportException: [Infamnia][inet[/10.223.23.106:9300]][discovery/zen/join]; org.elasticsearch.transport.ConnectTransportException: [Meld][inet[/10.195.83.112:9301]] connect\_timeout[30s]; org.elasticsearch.common.netty.channel.ChannelException: Failed to create a selector.]
> 
> I was using 0.19.0 and all works fine and I didn't change any code of connection but just rebuild the jar file.  
> Can anyone give me some advices? Thanks
> 
> Regards,  
> Bruce

---

<div class="post-metadata">

**Author:** ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)\
**Post date:** [May 23, 2012, 11:03pm UTC](https://discuss.elastic.co/t/found-strange-problem-on-0-19-4/7800/4 "2012-05-23T23:03:06Z")

</div>

No, not really..., it doesn't require more resources. The first thing that  
I would do though is use a newer JVM, the 1.6.0\_22 is about 2-3 years old.

On Wed, May 23, 2012 at 2:49 AM, Ye Zhou [zhouy.vreal@gmail.com](mailto:zhouy.vreal@gmail.com) wrote:

> Hi,  
> The os is Amazon Linux 64 bit build on Mar 2012 on EC2 and the JVM is  
> OpenJDK 64-bit Server VM (build 20.0-b11, mixed mode), Java version  
> is 1.6.0\_22.  
> The machine was freeze so I can't get any details. I finally solve it by  
> upgrade the machine to a bigger instance(was using micro with 512M memory,  
> now I'm using small with 1280M memory). Could that be the new version of  
> elasticsearch requires more compute resources than 0.19.0 or because of the  
> new version of Lucene?
> 
> Regards,  
> Bruce
> 
> On 22/05/2012, at 5:26 PM, Shay Banon wrote:
> 
> Do you see any more details in the logs? Which JVM version and OS are you  
> using?
> 
> On Tue, May 22, 2012 at 7:49 AM, Ye Zhou [zhouy.vreal@gmail.com](mailto:zhouy.vreal@gmail.com) wrote:
> 
> > I've just upgrade my Elasticsearch to 0.19.4 on ec2 and aws plugin is  
> > 1.5.0. I ran two web apps in one tomcat and both of them started an  
> > elasticsearch client using same code.
> > 
> > After I started tomcat the first client has connected to the es cluster  
> > successfully but the second is always fail to connect to the client with  
> > such error:
> > 
> > 05:44:07.227 INFO (Slf4jESLogger.java:94) - [Meld] failed to send join  
> > request to master  
> > [[Infamnia][aZoGhrLzSk6iSZIv2d\_PAA][inet[/10.223.23.106:9300]]], reason  
> > [org.elasticsearch.transport.RemoteTransportException:  
> > [Infamnia][inet[/10.223.23.106:9300]][discovery/zen/join];  
> > org.elasticsearch.transport.ConnectTransportException: [Meld][inet[/  
> > 10.195.83.112:9301]] connect\_timeout[30s];  
> > org.elasticsearch.common.netty.channel.ChannelException: Failed to create a  
> > selector.]
> > 
> > I was using 0.19.0 and all works fine and I didn't change any code of  
> > connection but just rebuild the jar file.  
> > Can anyone give me some advices? Thanks
> > 
> > Regards,  
> > Bruce

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 3:27am UTC](https://discuss.elastic.co/t/found-strange-problem-on-0-19-4/7800/5 "2017-07-06T03:27:23Z")

</div>


