# Frequent cluster\_block\_exception Kibana logstash

**URL:** <https://discuss.elastic.co/t/frequent-cluster-block-exception-kibana-logstash/240945>\
**Category:** Elasticsearch\
**Created:** [July 13, 2020, 10:26am UTC](https://discuss.elastic.co/t/frequent-cluster-block-exception-kibana-logstash/240945 "2020-07-13T10:26:01Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Sai\_Avinash\_Duddupud](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sai_avinash_duddupud/32/48265_2.png) [@Sai\_Avinash\_Duddupud](https://discuss.elastic.co/u/Sai_Avinash_Duddupud)\
**Post date:** [July 13, 2020, 10:26am UTC](https://discuss.elastic.co/t/frequent-cluster-block-exception-kibana-logstash/240945/1 "2020-07-13T10:26:01Z")

</div>

Hi all,

I am getting the following errors in my logstash logs.

```
[INFO] 2020-07-13 07:29:08.401 [[main]>worker0] elasticsearch - retrying failed action with response code: 429 ({"type"=>"cluster_block_exception", "reason"=>"index [blend] blocked by: [TOO_MANY_REQUESTS/12/index read-only / allow delete (api)];"})
[INFO] 2020-07-13 07:29:08.402 [[main]>worker0] elasticsearch - retrying failed action with response code: 429 ({"type"=>"cluster_block_exception", "reason"=>"index [blend] blocked by: [TOO_MANY_REQUESTS/12/index read-only / allow delete (api)];"})
[INFO] 2020-07-13 07:29:08.402 [[main]>worker0] elasticsearch - Retrying individual bulk actions that failed or were rejected by the previous bulk request. {:count=>2}

```

and after some searching, I found [this](https://discuss.elastic.co/t/solved-forbidden-to-create-index-pattern-in-kibana-7-2/190947) link and used the below command and it worked well

```
curl -XPUT -H "Content-Type: application/json" https://[YOUR_ELASTICSEARCH_ENDPOINT]:9200/_all/_settings -d '{"index.blocks.read_only_allow_delete": null}'

```

But again after **10 min or so** , I started getting above errors in logstash and I hit the curl command again. this is happening very frequently.

Is there **any permanent fix for this otherwise I had to hit the curl command many times** every 20 min or so

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [July 13, 2020, 10:28am UTC](https://discuss.elastic.co/t/frequent-cluster-block-exception-kibana-logstash/240945/2 "2020-07-13T10:28:47Z")

</div>

Have a look at [this blog post](https://www.elastic.co/blog/why-am-i-seeing-bulk-rejections-in-my-elasticsearch-cluster) which discusses this problem and what causes it.

---

<div class="post-metadata">

**Author:** ![Sai\_Avinash\_Duddupud](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sai_avinash_duddupud/32/48265_2.png) [@Sai\_Avinash\_Duddupud](https://discuss.elastic.co/u/Sai_Avinash_Duddupud)\
**Post date:** [July 13, 2020, 1:44pm UTC](https://discuss.elastic.co/t/frequent-cluster-block-exception-kibana-logstash/240945/3 "2020-07-13T13:44:38Z")

</div>

Came to know that there is low disk space....raised a request to increase the same....so hopefully no issues after that (but for now its running smooth)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 10, 2020, 1:44pm UTC](https://discuss.elastic.co/t/frequent-cluster-block-exception-kibana-logstash/240945/4 "2020-08-10T13:44:40Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
