# GCS repository backup issue

**URL:** <https://discuss.elastic.co/t/gcs-repository-backup-issue/154574>\
**Category:** Elasticsearch\
**Created:** [October 30, 2018, 7:30am UTC](https://discuss.elastic.co/t/gcs-repository-backup-issue/154574 "2018-10-30T07:30:25Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![ankur\_singla](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ankur_singla/32/45612_2.png) [@ankur\_singla](https://discuss.elastic.co/u/ankur_singla)\
**Post date:** [October 30, 2018, 7:30am UTC](https://discuss.elastic.co/t/gcs-repository-backup-issue/154574/1 "2018-10-30T07:30:25Z")

</div>

Hi

We have been using GCS repository for backing up our easlticsearch data from 7 months. But from last 1 week, we are getting **503 Service Unavailable** error while creating a snapshot.

**Error Stack Trace**

```
[gcs_repository_wall:snapshot_2018_10_29/fqOMR7njQumykOwTdHqZ5Q] failed to create snapshot
    at org.elasticsearch.repositories.blobstore.BlobStoreRepository.initializeSnapshot(BlobStoreRepository.java:335) ~[elasticsearch-6.0.0.jar:6.0.0]
    at org.elasticsearch.snapshots.SnapshotsService.beginSnapshot(SnapshotsService.java:364) ~[elasticsearch-6.0.0.jar:6.0.0]
    at org.elasticsearch.snapshots.SnapshotsService.access$700(SnapshotsService.java:105) ~[elasticsearch-6.0.0.jar:6.0.0]
    at org.elasticsearch.snapshots.SnapshotsService$1.lambda$clusterStateProcessed$1(SnapshotsService.java:282) ~[elasticsearch-6.0.0.jar:6.0.0]
    at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingRunnable.run(ThreadContext.java:569) [elasticsearch-6.0.0.jar:6.0.0]
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [?:1.8.0_111]
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [?:1.8.0_111]
    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_111]
Caused by: com.google.api.client.googleapis.json.GoogleJsonResponseException: 503 Service Unavailable
{
  "code" : 503,
  "errors" : [ {
"domain" : "global",
"message" : "Backend Error",
"reason" : "backendError"
  } ],
  "message" : "Backend Error"
}
    at com.google.api.client.googleapis.json.GoogleJsonResponseException.from(GoogleJsonResponseException.java:145) ~[?:?]
    at com.google.api.client.googleapis.services.json.AbstractGoogleJsonClientRequest.newExceptionOnError(AbstractGoogleJsonClientRequest.java:113) ~[?:?]
    at com.google.api.client.googleapis.services.json.AbstractGoogleJsonClientRequest.newExceptionOnError(AbstractGoogleJsonClientRequest.java:40) ~[?:?]
    at com.google.api.client.googleapis.services.AbstractGoogleClientRequest.executeUnparsed(AbstractGoogleClientRequest.java:432) ~[?:?]
    at com.google.api.client.googleapis.services.AbstractGoogleClientRequest.executeUnparsed(AbstractGoogleClientRequest.java:352) ~[?:?]
    at com.google.api.client.googleapis.services.AbstractGoogleClientRequest.execute(AbstractGoogleClientRequest.java:469)

```

Our ES is 6.0.0. Anyone, please suggest something. This is a very critical issue as it occurred 4 times in the last 8 days.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [October 30, 2018, 7:51am UTC](https://discuss.elastic.co/t/gcs-repository-backup-issue/154574/2 "2018-10-30T07:51:48Z")

</div>

It sounds like an error on google storage side.

Probably not related but I'd suggest anyway to upgrade your elasticsearch version to a more recent and stable version than 6.0.0.

---

<div class="post-metadata">

**Author:** ![ankur\_singla](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ankur_singla/32/45612_2.png) [@ankur\_singla](https://discuss.elastic.co/u/ankur_singla)\
**Post date:** [October 30, 2018, 12:06pm UTC](https://discuss.elastic.co/t/gcs-repository-backup-issue/154574/3 "2018-10-30T12:06:09Z")

</div>

thanks for the reply @dadoonet.

I am checking this issue from google storage side also. Please share if you know anything related to this issue.

We didn't plan yet to upgrade elasticsearch. But most probably will start in January next year.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 27, 2018, 12:18pm UTC](https://discuss.elastic.co/t/gcs-repository-backup-issue/154574/4 "2018-11-27T12:18:42Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
