# Geoip error while deploying elasticsearch

**URL:** <https://discuss.elastic.co/t/geoip-error-while-deploying-elasticsearch/284080>\
**Category:** Elasticsearch\
**Tags:** docker\
**Created:** [September 13, 2021, 1:45pm UTC](https://discuss.elastic.co/t/geoip-error-while-deploying-elasticsearch/284080 "2021-09-13T13:45:18Z")\
**Posts on this page:** 12\
**Page:** 1

<div class="post-metadata">

**Author:** ![ssen85](https://avatars.discourse-cdn.com/v4/letter/s/7ba0ec/32.png) [@ssen85](https://discuss.elastic.co/u/ssen85)\
**Post date:** [September 13, 2021, 1:45pm UTC](https://discuss.elastic.co/t/geoip-error-while-deploying-elasticsearch/284080/1 "2021-09-13T13:45:18Z")

</div>

Hi,

I'm trying to start a single node elasticsearch cluster using Docker. I get the following error in the startup logs

> "type": "server", "timestamp": "2021-09-13T13:41:29,255Z", "level": "ERROR", "component": "o.e.i.g.GeoIpDownloader", "cluster.name": "docker-cluster", "node.name": "e0f33c6f9ce4", "message": "exception during geoip databases update", "cluster.uuid": "Pt03VoTAT-OJfcHjonJBPw", "node.id": "83jOyCgFQQavshyezqeaOQ" ,  
> "stacktrace": ["java.net.SocketException: Network is unreachable"

I have the same error when using the helm charts as well. What should be done to mitigate this ?

Thank you  
Shubh

---

<div class="post-metadata">

**Author:** ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)\
**Post date:** [September 13, 2021, 2:18pm UTC](https://discuss.elastic.co/t/geoip-error-while-deploying-elasticsearch/284080/2 "2021-09-13T14:18:05Z")

</div>

Can you share a little more about your docker setup and the Elasticsearch version you tried to run? I suppose it's something 7.14?

---

<div class="post-metadata">

**Author:** ![ssen85](https://avatars.discourse-cdn.com/v4/letter/s/7ba0ec/32.png) [@ssen85](https://discuss.elastic.co/u/ssen85)\
**Post date:** [September 13, 2021, 2:20pm UTC](https://discuss.elastic.co/t/geoip-error-while-deploying-elasticsearch/284080/3 "2021-09-13T14:20:39Z")

</div>

Hi,

The Docker version is 20.10.8 and the Elasticsearch version is 7.14.0.

---

<div class="post-metadata">

**Author:** ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)\
**Post date:** [September 13, 2021, 2:37pm UTC](https://discuss.elastic.co/t/geoip-error-while-deploying-elasticsearch/284080/4 "2021-09-13T14:37:21Z")

</div>

how do you start Elasticsearch with docker/docker-compose? Is there a configuration file so one can reproduce?

---

<div class="post-metadata">

**Author:** ![ssen85](https://avatars.discourse-cdn.com/v4/letter/s/7ba0ec/32.png) [@ssen85](https://discuss.elastic.co/u/ssen85)\
**Post date:** [September 14, 2021, 6:58am UTC](https://discuss.elastic.co/t/geoip-error-while-deploying-elasticsearch/284080/5 "2021-09-14T06:58:21Z")

</div>

I am using this command

docker run -p 9200:9200 -p 9300:9300 -e "discovery.type=single-node" [docker.elastic.co/elasticsearch/elasticsearch:7.14.0](http://docker.elastic.co/elasticsearch/elasticsearch:7.14.0)

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [September 14, 2021, 7:13am UTC](https://discuss.elastic.co/t/geoip-error-while-deploying-elasticsearch/284080/6 "2021-09-14T07:13:53Z")

</div>

Can your node access internet? Is there any proxy which could prevent this?

---

<div class="post-metadata">

**Author:** ![ssen85](https://avatars.discourse-cdn.com/v4/letter/s/7ba0ec/32.png) [@ssen85](https://discuss.elastic.co/u/ssen85)\
**Post date:** [September 14, 2021, 8:49am UTC](https://discuss.elastic.co/t/geoip-error-while-deploying-elasticsearch/284080/7 "2021-09-14T08:49:54Z")

</div>

There is a proxy running but it is configured to allow Internet access. I have no problems pulling Docker images.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [September 14, 2021, 1:42pm UTC](https://discuss.elastic.co/t/geoip-error-while-deploying-elasticsearch/284080/8 "2021-09-14T13:42:50Z")

</div>

Sure. You are pulling the Docker images from your machine but can you connect to internet from the container?

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [September 14, 2021, 2:25pm UTC](https://discuss.elastic.co/t/geoip-error-while-deploying-elasticsearch/284080/9 "2021-09-14T14:25:21Z")

</div>

There was a bug fix in 7.14.1

You can set in 7.14.1+ to disable the downloading of the GeoIP Database.  
If you do not... elasticsearch will attempt to download the Latest GeoIP Database.  
`ingest.geoip.downloader.enabled: false`

You can test if you have connectivity by running (technically you would run this from inside your container)  
`curl https://geoip.elastic.co/v1/database?elastic_geoip_service_tos=agree`

If you have connectivity you should get a bunch of data back.

Also finally Elasticsearch should work file even with that error....

---

<div class="post-metadata">

**Author:** ![ssen85](https://avatars.discourse-cdn.com/v4/letter/s/7ba0ec/32.png) [@ssen85](https://discuss.elastic.co/u/ssen85)\
**Post date:** [September 15, 2021, 9:55am UTC](https://discuss.elastic.co/t/geoip-error-while-deploying-elasticsearch/284080/10 "2021-09-15T09:55:45Z")

</div>

Hi,

It is working now. I think there was some problem with my local Docker installation. I did a fresh install and there are no problems. Thank you everyone for the help.

---

<div class="post-metadata">

**Author:** ![jalonjia](https://avatars.discourse-cdn.com/v4/letter/j/f0a364/32.png) [@jalonjia](https://discuss.elastic.co/u/jalonjia)\
**Post date:** [September 26, 2021, 6:34am UTC](https://discuss.elastic.co/t/geoip-error-while-deploying-elasticsearch/284080/11 "2021-09-26T06:34:04Z")

</div>

I had the same problem, which I solved by restarting Docker

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 24, 2021, 6:34am UTC](https://discuss.elastic.co/t/geoip-error-while-deploying-elasticsearch/284080/12 "2021-10-24T06:34:24Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
