# Geoip "illegal latitude" after upgrading 1.5 -\> 2.1

**URL:** <https://discuss.elastic.co/t/geoip-illegal-latitude-after-upgrading-1-5-2-1/40083>\
**Category:** Logstash\
**Created:** [January 26, 2016, 4:47am UTC](https://discuss.elastic.co/t/geoip-illegal-latitude-after-upgrading-1-5-2-1/40083 "2016-01-26T04:47:53Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![ceekay](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ceekay/32/5687_2.png) [@ceekay](https://discuss.elastic.co/u/ceekay)\
**Post date:** [January 26, 2016, 4:47am UTC](https://discuss.elastic.co/t/geoip-illegal-latitude-after-upgrading-1-5-2-1/40083/1 "2016-01-26T04:47:53Z")

</div>

I've just upgraded some boxes from 1.5 to 2.1 and have been getting indexing errors for all messages containing geoip data ever since.

Messages that don't contain geoip info are indexing without errors.

As far as I can see there is no issue with any of the message fields and the geoip filter seems to be working fine: [http://pastebin.com/GQazrcBK](http://pastebin.com/GQazrcBK)

However the error message says otherwise: [http://pastebin.com/05WwHg9S](http://pastebin.com/05WwHg9S)

There are tens of thousands of these error messages, but the range of latitudes in the error message are _all_ between 264 and 269. As you can see from the error above it's complaining about `269.82421875` however the actual latitude in the message is `-41.0`, so I'm not sure where these values are even coming from.

Ubuntu 14.04.3  
Elasticsearch 2.1.1  
Logstash 2.1.1  
logstash-filter-geoip 2.0.4

I'm completely stumped here. Can anyone help?  
Thanks 🙂

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [January 26, 2016, 6:48am UTC](https://discuss.elastic.co/t/geoip-illegal-latitude-after-upgrading-1-5-2-1/40083/2 "2016-01-26T06:48:36Z")

</div>

What does your mapping look like for that index?

---

<div class="post-metadata">

**Author:** ![ceekay](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ceekay/32/5687_2.png) [@ceekay](https://discuss.elastic.co/u/ceekay)\
**Post date:** [January 26, 2016, 7:19am UTC](https://discuss.elastic.co/t/geoip-illegal-latitude-after-upgrading-1-5-2-1/40083/3 "2016-01-26T07:19:13Z")

</div>

@Christian_Dahlqvist I have a template mapping for [geoip][location] of "geo\_point". There's no actual mapping in that index for type:nginx-access - I guess as no records with a location field have been indexed yet.

Do you need to see the full mapping output?

---

<div class="post-metadata">

**Author:** ![ceekay](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ceekay/32/5687_2.png) [@ceekay](https://discuss.elastic.co/u/ceekay)\
**Post date:** [January 28, 2016, 12:34am UTC](https://discuss.elastic.co/t/geoip-illegal-latitude-after-upgrading-1-5-2-1/40083/4 "2016-01-28T00:34:54Z")

</div>

Any ideas what I can do here?

If I remove the mapping it gets indexed as a string, which is no use to me.

The only thing I can think do at this point to avoid message loss is to disable the geoip filter, which isn't ideal either.

---

<div class="post-metadata">

**Author:** ![Saiprasad\_Krishnamur](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/saiprasad_krishnamur/32/32290_2.png) [@Saiprasad\_Krishnamur](https://discuss.elastic.co/u/Saiprasad_Krishnamur)\
**Post date:** [January 23, 2017, 3:53am UTC](https://discuss.elastic.co/t/geoip-illegal-latitude-after-upgrading-1-5-2-1/40083/5 "2017-01-23T03:53:32Z")

</div>

I had the same issue. Realised that the issue was that I was passing the geo\_points as a String array ["12.947787499999999", "80.2352166"] in my document. I changed it to a double array [12.947787499999999, 80.2352166] and it worked fine. Yes, the error message is completely misleading.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 4:29am UTC](https://discuss.elastic.co/t/geoip-illegal-latitude-after-upgrading-1-5-2-1/40083/6 "2017-07-06T04:29:10Z")

</div>


