# Get error 'no such index \[pdf\_test\]' after use fscrawer to create index

**URL:** <https://discuss.elastic.co/t/get-error-no-such-index-pdf-test-after-use-fscrawer-to-create-index/267791>\
**Category:** Elasticsearch\
**Created:** [March 19, 2021, 10:05am UTC](https://discuss.elastic.co/t/get-error-no-such-index-pdf-test-after-use-fscrawer-to-create-index/267791 "2021-03-19T10:05:02Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![lxia](https://avatars.discourse-cdn.com/v4/letter/l/e495f1/32.png) [@lxia](https://discuss.elastic.co/u/lxia)\
**Post date:** [March 19, 2021, 10:05am UTC](https://discuss.elastic.co/t/get-error-no-such-index-pdf-test-after-use-fscrawer-to-create-index/267791/1 "2021-03-19T10:05:03Z")

</div>

FSCrawler verssion: 2.7

when I first run the command: `bin\fscrawler --config_dir ./DS pdf_test`,  
it showed info:

```auto
job [pdf_test] does not exist
Do you want to create it (Y/N)?
Y
Settings have been created in [.\DS\pdf_test\_settings.yaml]. Please review and edit before relaunch.

```

And it created dir `DS` and `pdf_test`. and then I changed the `settings.yaml`.  
after I run the `bin\fscrawler --config_dir ./DS pdf_test --loop 1`,

I got nothing on the cmd windows.  
there is no info or warning showing on the cmd windows.

and I search on the kibana, there is no index pdf\_test exist. how can I troubleshooting the issue?

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [March 19, 2021, 10:27am UTC](https://discuss.elastic.co/t/get-error-no-such-index-pdf-test-after-use-fscrawer-to-create-index/267791/2 "2021-03-19T10:27:09Z")

</div>

Could you check the `logs` dir?

---

<div class="post-metadata">

**Author:** ![lxia](https://avatars.discourse-cdn.com/v4/letter/l/e495f1/32.png) [@lxia](https://discuss.elastic.co/u/lxia)\
**Post date:** [March 22, 2021, 2:15am UTC](https://discuss.elastic.co/t/get-error-no-such-index-pdf-test-after-use-fscrawer-to-create-index/267791/4 "2021-03-22T02:15:50Z")

</div>

the log fscrawer.log showing:  
17:48:20,045 INFO [f.p.e.c.f.c.BootstrapChecks] Memory [Free/Total=Percent]: HEAP [109.3mb/1.9gb=5.43%], RAM [2.1gb/7.8gb=26.81%], Swap [1.4gb/14.2gb=10.4%].  
17:48:20,246 INFO [f.p.e.c.f.FsCrawlerImpl] Starting FS crawler  
17:48:20,761 WARN [f.p.e.c.f.c.v.ElasticsearchClientV7] failed to create elasticsearch client on Elasticsearch{nodes=[[http://10.22.1.201:9200](http://10.22.1.201:9200)], index='pdf\_test', indexFolder='pdf\_test\_folder', bulkSize=100, flushInterval=5s, byteSize=10mb, username='null', pipeline='null', pathPrefix='null', sslVerification='true'}, disabling crawler...  
17:48:20,762 FATAL [f.p.e.c.f.c.FsCrawlerCli] We can not start Elasticsearch Client. Exiting.  
org.elasticsearch.ElasticsearchStatusException: Elasticsearch exception [type=security\_exception, reason=missing authentication credentials for REST request [/]]  
at org.elasticsearch.rest.BytesRestResponse.errorFromXContent(BytesRestResponse.java:176) ~[elasticsearch-7.11.1.jar:7.11.1]  
at org.elasticsearch.client.RestHighLevelClient.parseEntity(RestHighLevelClient.java:1900) ~[elasticsearch-rest-high-level-client-7.11.1.jar:7.11.1]  
at org.elasticsearch.client.RestHighLevelClient.parseResponseException(RestHighLevelClient.java:1877) ~[elasticsearch-rest-high-level-client-7.11.1.jar:7.11.1]  
at org.elasticsearch.client.RestHighLevelClient.internalPerformRequest(RestHighLevelClient.java:1634) ~[elasticsearch-rest-high-level-client-7.11.1.jar:7.11.1]  
at org.elasticsearch.client.RestHighLevelClient.performRequest(RestHighLevelClient.java:1606) ~[elasticsearch-rest-high-level-client-7.11.1.jar:7.11.1]  
at org.elasticsearch.client.RestHighLevelClient.performRequestAndParseEntity(RestHighLevelClient.java:1573) ~[elasticsearch-rest-high-level-client-7.11.1.jar:7.11.1]  
at org.elasticsearch.client.RestHighLevelClient.info(RestHighLevelClient.java:774) ~[elasticsearch-rest-high-level-client-7.11.1.jar:7.11.1]  
at fr.pilato.elasticsearch.crawler.fs.client.v7.ElasticsearchClientV7.getVersion(ElasticsearchClientV7.java:179) ~[fscrawler-elasticsearch-client-v7-2.7-SNAPSHOT.jar:?]  
at fr.pilato.elasticsearch.crawler.fs.client.ElasticsearchClient.checkVersion(ElasticsearchClient.java:192) ~[fscrawler-elasticsearch-client-base-2.7-SNAPSHOT.jar:?]  
at fr.pilato.elasticsearch.crawler.fs.client.v7.ElasticsearchClientV7.start(ElasticsearchClientV7.java:152) ~[fscrawler-elasticsearch-client-v7-2.7-SNAPSHOT.jar:?]  
at fr.pilato.elasticsearch.crawler.fs.service.FsCrawlerManagementServiceElasticsearchImpl.start(FsCrawlerManagementServiceElasticsearchImpl.java:60) ~[fscrawler-core-2.7-SNAPSHOT.jar:?]  
at fr.pilato.elasticsearch.crawler.fs.FsCrawlerImpl.start(FsCrawlerImpl.java:116) ~[fscrawler-core-2.7-SNAPSHOT.jar:?]  
at fr.pilato.elasticsearch.crawler.fs.cli.FsCrawlerCli.startEsClient(FsCrawlerCli.java:307) [fscrawler-cli-2.7-SNAPSHOT.jar:?]  
at fr.pilato.elasticsearch.crawler.fs.cli.FsCrawlerCli.main(FsCrawlerCli.java:283) [fscrawler-cli-2.7-SNAPSHOT.jar:?]  
Suppressed: org.elasticsearch.client.ResponseException: method [GET], host [[http://10.22.1.201:9200](http://10.22.1.201:9200)], URI [/], status line [HTTP/1.1 401 Unauthorized]  
{"error":{"root\_cause":[{"type":"security\_exception","reason":"missing authentication credentials for REST request [/]","header":{"WWW-Authenticate":"Basic realm="security" charset="UTF-8""}}],"type":"security\_exception","reason":"missing authentication credentials for REST request [/]","header":{"WWW-Authenticate":"Basic realm="security" charset="UTF-8""}},"status":401}  
at org.elasticsearch.client.RestClient.convertResponse(RestClient.java:326) ~[elasticsearch-rest-client-7.11.1.jar:7.11.1]  
at org.elasticsearch.client.RestClient.performRequest(RestClient.java:296) ~[elasticsearch-rest-client-7.11.1.jar:7.11.1]  
at org.elasticsearch.client.RestClient.performRequest(RestClient.java:270) ~[elasticsearch-rest-client-7.11.1.jar:7.11.1]  
at org.elasticsearch.client.RestHighLevelClient.internalPerformRequest(RestHighLevelClient.java:1621) ~[elasticsearch-rest-high-level-client-7.11.1.jar:7.11.1]  
at org.elasticsearch.client.RestHighLevelClient.performRequest(RestHighLevelClient.java:1606) ~[elasticsearch-rest-high-level-client-7.11.1.jar:7.11.1]  
at org.elasticsearch.client.RestHighLevelClient.performRequestAndParseEntity(RestHighLevelClient.java:1573) ~[elasticsearch-rest-high-level-client-7.11.1.jar:7.11.1]  
at org.elasticsearch.client.RestHighLevelClient.info(RestHighLevelClient.java:774) ~[elasticsearch-rest-high-level-client-7.11.1.jar:7.11.1]  
at fr.pilato.elasticsearch.crawler.fs.client.v7.ElasticsearchClientV7.getVersion(ElasticsearchClientV7.java:179) ~[fscrawler-elasticsearch-client-v7-2.7-SNAPSHOT.jar:?]  
at fr.pilato.elasticsearch.crawler.fs.client.ElasticsearchClient.checkVersion(ElasticsearchClient.java:192) ~[fscrawler-elasticsearch-client-base-2.7-SNAPSHOT.jar:?]  
at fr.pilato.elasticsearch.crawler.fs.client.v7.ElasticsearchClientV7.start(ElasticsearchClientV7.java:152) ~[fscrawler-elasticsearch-client-v7-2.7-SNAPSHOT.jar:?]  
at fr.pilato.elasticsearch.crawler.fs.service.FsCrawlerManagementServiceElasticsearchImpl.start(FsCrawlerManagementServiceElasticsearchImpl.java:60) ~[fscrawler-core-2.7-SNAPSHOT.jar:?]  
at fr.pilato.elasticsearch.crawler.fs.FsCrawlerImpl.start(FsCrawlerImpl.java:116) ~[fscrawler-core-2.7-SNAPSHOT.jar:?]  
at fr.pilato.elasticsearch.crawler.fs.cli.FsCrawlerCli.startEsClient(FsCrawlerCli.java:307) [fscrawler-cli-2.7-SNAPSHOT.jar:?]  
at fr.pilato.elasticsearch.crawler.fs.cli.FsCrawlerCli.main(FsCrawlerCli.java:283) [fscrawler-cli-2.7-SNAPSHOT.jar:?]  
17:48:20,768 INFO [f.p.e.c.f.FsCrawlerImpl] FS crawler [pdf\_test] stopped  
17:48:20,769 INFO [f.p.e.c.f.FsCrawlerImpl] FS crawler [pdf\_test] stopped

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [March 22, 2021, 8:24am UTC](https://discuss.elastic.co/t/get-error-no-such-index-pdf-test-after-use-fscrawer-to-create-index/267791/5 "2021-03-22T08:24:32Z")

</div>

Please format your code, logs or configuration files using `</>` icon as explained in [this guide](https://discuss.elastic.co/t/about-the-elasticsearch-category/21) and not the citation button. It will make your post more readable.

Or use markdown style like:

````
```
CODE
```

````

This is the icon to use if you are not using markdown format:

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/7/e/7e6e239431ec2d71cbf1beef741f2e93e7cc762c.jpg)

There's a live preview panel for exactly this reasons.

Lots of people read these forums, and many of them will simply skip over a post that is difficult to read, because it's just too large an investment of their time to try and follow a wall of badly formatted text.  
If your goal is to get an answer to your questions, it's in your interest to make it as easy to read and understand as possible.  
Please update your post.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [March 22, 2021, 8:25am UTC](https://discuss.elastic.co/t/get-error-no-such-index-pdf-test-after-use-fscrawer-to-create-index/267791/6 "2021-03-22T08:25:49Z")

</div>

The problem seems to be a login/password not set:

> [@lxia](#):
>
> ```
> missing authentication credentials for REST request [/]]
> 
> ```

---

<div class="post-metadata">

**Author:** ![lxia](https://avatars.discourse-cdn.com/v4/letter/l/e495f1/32.png) [@lxia](https://discuss.elastic.co/u/lxia)\
**Post date:** [March 22, 2021, 8:51am UTC](https://discuss.elastic.co/t/get-error-no-such-index-pdf-test-after-use-fscrawer-to-create-index/267791/7 "2021-03-22T08:51:36Z")

</div>

where can I set the login/passward?

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [March 22, 2021, 9:40am UTC](https://discuss.elastic.co/t/get-error-no-such-index-pdf-test-after-use-fscrawer-to-create-index/267791/8 "2021-03-22T09:40:08Z")

</div>

Here: [Elasticsearch settings — FSCrawler 2.7-SNAPSHOT documentation](https://fscrawler.readthedocs.io/en/latest/admin/fs/elasticsearch.html#using-credentials-x-pack)

---

<div class="post-metadata">

**Author:** ![lxia](https://avatars.discourse-cdn.com/v4/letter/l/e495f1/32.png) [@lxia](https://discuss.elastic.co/u/lxia)\
**Post date:** [March 22, 2021, 10:06am UTC](https://discuss.elastic.co/t/get-error-no-such-index-pdf-test-after-use-fscrawer-to-create-index/267791/9 "2021-03-22T10:06:35Z")

</div>

Thanks a lot. it's resolved after following the steps.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 19, 2021, 10:06am UTC](https://discuss.elastic.co/t/get-error-no-such-index-pdf-test-after-use-fscrawer-to-create-index/267791/10 "2021-04-19T10:06:37Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
