# Get the warning received shard failed for certain replicas

**URL:** <https://discuss.elastic.co/t/get-the-warning-received-shard-failed-for-certain-replicas/1245>\
**Category:** Elasticsearch\
**Created:** [May 25, 2015, 7:43am UTC](https://discuss.elastic.co/t/get-the-warning-received-shard-failed-for-certain-replicas/1245 "2015-05-25T07:43:47Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Jacobus\_van\_heerden](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jacobus_van_heerden/32/44773_2.png) [@Jacobus\_van\_heerden](https://discuss.elastic.co/u/Jacobus_van_heerden)\
**Post date:** [May 25, 2015, 7:43am UTC](https://discuss.elastic.co/t/get-the-warning-received-shard-failed-for-certain-replicas/1245/1 "2015-05-25T07:43:47Z")

</div>

Good Day

I hope someone can possible help me. I have a 5 node ES cluster. The app writes data to our index. When there are no replicas on the index all is fine. As soon as i add replicas I get the following:  
Not sure where the issue is. Mappings maybe? (We only use long type on current\_time and that is less than 32 chars.)

[WARN][cluster.action.shard] [node3] [pandora][1] received shard failed for [pandora][1],  
node[b5d8phsxQUCoScLSiM194A], [R], s[STARTED], indexUUID [f5DW-cX0QuO3VsoF8cAPWQ], reason [Failed to perform [indices:data/write/index]  
on replica, message [RemoteTransportException[[Live-Elasticsearch-Node03][inet[/10.100.19.176:9300]][indices:data/write/index[r]]];  
nested: CreateFailedEngineException[[pandora][1]  
Create failed for [data#AU2J9E\_LacmaoOIy8gAI]]; nested: IOException[Cannot read numeric data larger than 32 chars]; ]]

[2015-05-25 07:23:16,507][WARN][indices.cluster] [Live-Elasticsearch-Node03] [[pandora][1]] marking and sending shard failed due to [engine failure, reason [indices:data/write/index failed on replica]]  
org.elasticsearch.index.engine.CreateFailedEngineException: [pandora][1] Create failed for [data#AU2J9E\_LacmaoOIy8gAI]  
at org.elasticsearch.index.engine.InternalEngine.create(InternalEngine.java:262)  
at org.elasticsearch.index.shard.IndexShard.create(IndexShard.java:470)  
at org.elasticsearch.action.index.TransportIndexAction.shardOperationOnReplica(TransportIndexAction.java:249)  
at org.elasticsearch.action.support.replication.TransportShardReplicationOperationAction$ReplicaOperationTransportHandler.messageReceived(TransportShardReplicationOperationAction.java:249)  
at org.elasticsearch.action.support.replication.TransportShardReplicationOperationAction$ReplicaOperationTransportHandler.messageReceived(TransportShardReplicationOperationAction.java:228)  
at org.elasticsearch.transport.netty.MessageChannelHandler$RequestHandler.doRun(MessageChannelHandler.java:277)  
at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:36)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)  
at java.lang.Thread.run(Thread.java:745)  
Caused by: java.io.IOException: Cannot read numeric data larger than 32 chars  
at org.elasticsearch.index.analysis.NumericTokenizer.incrementToken(NumericTokenizer.java:78)  
at org.apache.lucene.index.DefaultIndexingChain$PerField.invert(DefaultIndexingChain.java:618)  
at org.apache.lucene.index.DefaultIndexingChain.processField(DefaultIndexingChain.java:359)  
at org.apache.lucene.index.DefaultIndexingChain.processDocument(DefaultIndexingChain.java:318)  
at org.apache.lucene.index.DocumentsWriterPerThread.updateDocument(DocumentsWriterPerThread.java:241)  
at org.apache.lucene.index.DocumentsWriter.updateDocument(DocumentsWriter.java:465)  
at org.apache.lucene.index.IndexWriter.updateDocument(IndexWriter.java:1526)  
at org.apache.lucene.index.IndexWriter.addDocument(IndexWriter.java:1252)  
at org.elasticsearch.index.engine.InternalEngine.innerCreateNoLock(InternalEngine.java:343)  
at org.elasticsearch.index.engine.InternalEngine.innerCreate(InternalEngine.java:285)  
at org.elasticsearch.index.engine.InternalEngine.create(InternalEngine.java:256)  
... 9 more

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [May 26, 2015, 12:58am UTC](https://discuss.elastic.co/t/get-the-warning-received-shard-failed-for-certain-replicas/1245/2 "2015-05-26T00:58:51Z")

</div>

What version are you on?

Can you provide the mapping?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 12:11am UTC](https://discuss.elastic.co/t/get-the-warning-received-shard-failed-for-certain-replicas/1245/3 "2017-07-06T00:11:59Z")

</div>


