# Getting 1 of 19 shards failed on kibana dashboard

**URL:** <https://discuss.elastic.co/t/getting-1-of-19-shards-failed-on-kibana-dashboard/337703>\
**Category:** Elastic Agent\
**Tags:** elastic-stack-monitoring\
**Created:** [July 5, 2023, 5:20pm UTC](https://discuss.elastic.co/t/getting-1-of-19-shards-failed-on-kibana-dashboard/337703 "2023-07-05T17:20:31Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Nishant\_Chauhan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nishant_chauhan/32/122587_2.png) [@Nishant\_Chauhan](https://discuss.elastic.co/u/Nishant_Chauhan)\
**Post date:** [July 5, 2023, 5:20pm UTC](https://discuss.elastic.co/t/getting-1-of-19-shards-failed-on-kibana-dashboard/337703/1 "2023-07-05T17:20:31Z")

</div>

Hi,

I have installed elastic agent version 7.17, on fleet page it shows healthy.

However when i go to its dashboard, it is showing below error on all dashboards.

```auto
## illegal_argument_exception at `shard` 0`index` metrics-elastic_agent.elastic_agent-default`node` SgGSGXafRfysRAH9urACuw

Type
illegal_argument_exception
Reason
Text fields are not optimised for operations that require per-document field data like aggregations and sorting, so these operations are disabled by default. Please use a keyword field instead. Alternatively, set fielddata=true on [elastic_agent.process] in order to load field data by uninverting the inverted index. Note that this can use significant memory.

```

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/3/8/38438dba9b06b01d1e8d6cb197108e4d76bdd50d.png)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 2, 2023, 5:20pm UTC](https://discuss.elastic.co/t/getting-1-of-19-shards-failed-on-kibana-dashboard/337703/2 "2023-08-02T17:20:57Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
