# Getting 403 denied to elastic.co (for anything: apt refresh, wget, etc)

**URL:** <https://discuss.elastic.co/t/getting-403-denied-to-elastic-co-for-anything-apt-refresh-wget-etc/301150>\
**Category:** Meta Elastic\
**Created:** [March 31, 2022, 12:18am UTC](https://discuss.elastic.co/t/getting-403-denied-to-elastic-co-for-anything-apt-refresh-wget-etc/301150 "2022-03-31T00:18:33Z")\
**Posts on this page:** 15\
**Page:** 1

<div class="post-metadata">

**Author:** ![total-dor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/total-dor/32/103743_2.png) [@total-dor](https://discuss.elastic.co/u/total-dor)\
**Post date:** [March 31, 2022, 12:18am UTC](https://discuss.elastic.co/t/getting-403-denied-to-elastic-co-for-anything-apt-refresh-wget-etc/301150/1 "2022-03-31T00:18:33Z")

</div>

Our company runs out of several datacenters and we just provisioned a new one in a new region (within USA) and I cannot pull from [elastic.co](http://elastic.co) from this site.

The below commands work perfectly fine for any other site within my organization....

```auto
ubuntu@host.site121:~$ sudo apt update

Err:1 https://artifacts.elastic.co/packages/7.x/apt stable InRelease
  403 Forbidden [IP: 34.120.127.130 443]
Get:2 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB]
Hit:3 http://mirrors.namecheap.com/ubuntu focal InRelease
Hit:4 http://mirrors.namecheap.com/ubuntu focal-updates InRelease
Hit:5 http://mirrors.namecheap.com/ubuntu focal-backports InRelease
Reading package lists... Done
E: Failed to fetch https://artifacts.elastic.co/packages/7.x/apt/dists/stable/InRelease 403 Forbidden [IP: 34.120.127.130 443]
E: The repository 'https://artifacts.elastic.co/packages/7.x/apt stable InRelease' is no longer signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

```

```auto
ubuntu@host.site121:~$ wget https://artifacts.elastic.co/packages/7.x/apt/dists/stable/InRelease

--2022-03-31 00:01:02-- https://artifacts.elastic.co/packages/7.x/apt/dists/stable/InRelease
Resolving artifacts.elastic.co (artifacts.elastic.co)... 34.120.127.130, 2600:1901:0:1d7::
Connecting to artifacts.elastic.co (artifacts.elastic.co)|34.120.127.130|:443... connected.
HTTP request sent, awaiting response... 403 Forbidden
2022-03-31 00:01:02 ERROR 403: Forbidden.

```

```auto
ubuntu@host.site121:~$ wget https://artifacts.elastic.co

--2022-03-31 00:05:47-- https://artifacts.elastic.co/
Resolving artifacts.elastic.co (artifacts.elastic.co)... 34.120.127.130, 2600:1901:0:1d7::
Connecting to artifacts.elastic.co (artifacts.elastic.co)|34.120.127.130|:443... connected.
HTTP request sent, awaiting response... 403 Forbidden
2022-03-31 00:05:47 ERROR 403: Forbidden.

```

**When I run the above commands from any other site it works fine.**

Could it be this external IP is banned? This is a new site for my company and the external IP was just recently provisioned.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [March 31, 2022, 12:25am UTC](https://discuss.elastic.co/t/getting-403-denied-to-elastic-co-for-anything-apt-refresh-wget-etc/301150/2 "2022-03-31T00:25:10Z")

</div>

It could be, what is the IP range you are coming from?

---

<div class="post-metadata">

**Author:** ![total-dor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/total-dor/32/103743_2.png) [@total-dor](https://discuss.elastic.co/u/total-dor)\
**Post date:** [March 31, 2022, 12:36am UTC](https://discuss.elastic.co/t/getting-403-denied-to-elastic-co-for-anything-apt-refresh-wget-etc/301150/3 "2022-03-31T00:36:37Z")

</div>

I can't post that publicly. Is there a way I can share it with a team member directly?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [March 31, 2022, 12:37am UTC](https://discuss.elastic.co/t/getting-403-denied-to-elastic-co-for-anything-apt-refresh-wget-etc/301150/4 "2022-03-31T00:37:49Z")

</div>

DM it to me if you want.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [March 31, 2022, 1:14am UTC](https://discuss.elastic.co/t/getting-403-denied-to-elastic-co-for-anything-apt-refresh-wget-etc/301150/5 "2022-03-31T01:14:26Z")

</div>

Unsure to be honest as it looks like it's geolocated in the US, which we aren't blocking.

[Problem accessing charts and artifacts from hetzner.de servers - #4 by spinscale](https://discuss.elastic.co/t/problem-accessing-charts-and-artifacts-from-hetzner-de-servers/300840/5) seems related. We'll see what we can figure out.

---

<div class="post-metadata">

**Author:** ![total-dor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/total-dor/32/103743_2.png) [@total-dor](https://discuss.elastic.co/u/total-dor)\
**Post date:** [March 31, 2022, 3:29pm UTC](https://discuss.elastic.co/t/getting-403-denied-to-elastic-co-for-anything-apt-refresh-wget-etc/301150/6 "2022-03-31T15:29:34Z")

</div>

Thanks. If there is anything I can do to help troubleshoot on my side, please let me know. I think I'm stuck for now unless I get fancy with some sort of proxy.

Pretty sure this exact same site was able to do an "apt update" (including elastic repo) last week.

---

<div class="post-metadata">

**Author:** ![total-dor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/total-dor/32/103743_2.png) [@total-dor](https://discuss.elastic.co/u/total-dor)\
**Post date:** [April 1, 2022, 5:23pm UTC](https://discuss.elastic.co/t/getting-403-denied-to-elastic-co-for-anything-apt-refresh-wget-etc/301150/7 "2022-04-01T17:23:33Z")

</div>

I just tried again this morning and it's working now. Nothing changed on my side 🤷

Appreciate the attentiveness and thanks if any fixes were made

---

<div class="post-metadata">

**Author:** ![baberullah](https://avatars.discourse-cdn.com/v4/letter/b/bbe5ce/32.png) [@baberullah](https://discuss.elastic.co/u/baberullah)\
**Post date:** [April 8, 2022, 9:53pm UTC](https://discuss.elastic.co/t/getting-403-denied-to-elastic-co-for-anything-apt-refresh-wget-etc/301150/8 "2022-04-08T21:53:05Z")

</div>

I am getting the same error while trying to install Elasticsearch. Is there any workaround for this?

```auto

Err:4 https://artifacts.elastic.co/packages/oss-7.x/apt stable InRelease                            
  403 Forbidden [IP: 2600:1901:0:1d7:: 443]
Reading package lists... Done
E: Failed to fetch https://artifacts.elastic.co/packages/oss-7.x/apt/dists/stable/InRelease 403 Forbidden [IP: 2600:1901:0:1d7:: 443]
E: The repository 'https://artifacts.elastic.co/packages/oss-7.x/apt stable InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.

```

---

<div class="post-metadata">

**Author:** ![total-dor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/total-dor/32/103743_2.png) [@total-dor](https://discuss.elastic.co/u/total-dor)\
**Post date:** [April 11, 2022, 9:49pm UTC](https://discuss.elastic.co/t/getting-403-denied-to-elastic-co-for-anything-apt-refresh-wget-etc/301150/9 "2022-04-11T21:49:59Z")

</div>

This is happening again. Totally random. Same site, same IP ☹

@warkolm FYI ^ ... Not sure if you took any action last time. We have Ansible run `apt update` several times a week, but nothing crazy. We have dozens of other sites that do the same, the issue is just this one site.

---

<div class="post-metadata">

**Author:** ![vlad.belogrudov](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/vlad.belogrudov/32/104884_2.png) [@vlad.belogrudov](https://discuss.elastic.co/u/vlad.belogrudov)\
**Post date:** [April 27, 2022, 7:52am UTC](https://discuss.elastic.co/t/getting-403-denied-to-elastic-co-for-anything-apt-refresh-wget-etc/301150/10 "2022-04-27T07:52:14Z")

</div>

the same here, cannot download, cannot build openstack packages (kolla). Also cannot download elastic on any devices like smart phones.

Are Russian IPs banned now?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [April 27, 2022, 10:11am UTC](https://discuss.elastic.co/t/getting-403-denied-to-elastic-co-for-anything-apt-refresh-wget-etc/301150/11 "2022-04-27T10:11:32Z")

</div>

Correct, we are banning Russian IPs from accessing our software.

---

<div class="post-metadata">

**Author:** ![Michael\_Jacobsen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/michael_jacobsen/32/105035_2.png) [@Michael\_Jacobsen](https://discuss.elastic.co/u/Michael_Jacobsen)\
**Post date:** [April 29, 2022, 11:42am UTC](https://discuss.elastic.co/t/getting-403-denied-to-elastic-co-for-anything-apt-refresh-wget-etc/301150/12 "2022-04-29T11:42:41Z")

</div>

We are Norwegian company, and it works on and off at times, with error 403. We're not in Russia, it means you have some problems with your GeoIP database. Please fix it, we wanted to upgrade existing ELK cluster but now we're forced to wait. We want to trust Elastic, but if this continues we'll probably go for Splunk.

Show us that you're trustworthy and able to provide good quality for community. Like RIPE or ICANN did and stayed away from politics, being professional. In any case, western countries should not be blocked, fix this screw up please.

---

<div class="post-metadata">

**Author:** ![rusya.khalmatov](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rusya.khalmatov/32/105389_2.png) [@rusya.khalmatov](https://discuss.elastic.co/u/rusya.khalmatov)\
**Post date:** [May 8, 2022, 9:29am UTC](https://discuss.elastic.co/t/getting-403-denied-to-elastic-co-for-anything-apt-refresh-wget-etc/301150/13 "2022-05-08T09:29:32Z")

</div>

Hello! I'm a developer from Uzbekistan. Trying to install elk on my server (ip: 82.148.4.79). Unfortunately I receive the same error: Connecting to [artifacts.elastic.co](http://artifacts.elastic.co) ([artifacts.elastic.co](http://artifacts.elastic.co))|34.120.127.130|:443... connected.

HTTP request sent, awaiting response... 403 Forbidden.  
Is it a bug?

---

<div class="post-metadata">

**Author:** ![Igors](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/igors/32/105421_2.png) [@Igors](https://discuss.elastic.co/u/Igors)\
**Post date:** [May 9, 2022, 8:46am UTC](https://discuss.elastic.co/t/getting-403-denied-to-elastic-co-for-anything-apt-refresh-wget-etc/301150/14 "2022-05-09T08:46:26Z")

</div>

What the hell have you blocked? Production servers cannot access the repository!  
City: Schwerzenbach  
Region: Zurich  
Country: Switzerland  
External IP 194.11.129.X

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 6, 2022, 8:47am UTC](https://discuss.elastic.co/t/getting-403-denied-to-elastic-co-for-anything-apt-refresh-wget-etc/301150/15 "2022-06-06T08:47:23Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
