# Getting 500 error on documents API

**URL:** <https://discuss.elastic.co/t/getting-500-error-on-documents-api/229901>\
**Category:** Elastic Search\
**Tags:** elastic-app-search\
**Created:** [April 27, 2020, 5:50am UTC](https://discuss.elastic.co/t/getting-500-error-on-documents-api/229901 "2020-04-27T05:50:39Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![varunharidas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/varunharidas/32/63704_2.png) [@varunharidas](https://discuss.elastic.co/u/varunharidas)\
**Post date:** [April 27, 2020, 5:50am UTC](https://discuss.elastic.co/t/getting-500-error-on-documents-api/229901/1 "2020-04-27T05:50:39Z")

</div>

This error started randomly, when we strated updating docs via api

`{"errors":["The service is in read-only mode. Actions that create, update, or delete information are temporarily disabled."]}`

Search is working fine though. Also, the dashboard is displaying 500 error message.

---

<div class="post-metadata">

**Author:** ![JasonStoltz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasonstoltz/32/49893_2.png) [@JasonStoltz](https://discuss.elastic.co/u/JasonStoltz)\
**Post date:** [April 27, 2020, 12:29pm UTC](https://discuss.elastic.co/t/getting-500-error-on-documents-api/229901/2 "2020-04-27T12:29:19Z")

</div>

Woah, that's odd. Sounds like read-only mode is enabled, but you typically have to enable that explicitly. For instructions on disabling read-only mode, see these instructions: [https://swiftype.com/documentation/app-search/self-managed/read-only-mode](https://swiftype.com/documentation/app-search/self-managed/read-only-mode)

---

<div class="post-metadata">

**Author:** ![varunharidas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/varunharidas/32/63704_2.png) [@varunharidas](https://discuss.elastic.co/u/varunharidas)\
**Post date:** [April 27, 2020, 2:04pm UTC](https://discuss.elastic.co/t/getting-500-error-on-documents-api/229901/3 "2020-04-27T14:04:12Z")

</div>

@JasonStoltz Hey, Thanks for the quick reply. I tried the read-only status it's already disabled.

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/f/0/f06655eb9cd5fa57022e7807602ede8572b2f4f5.png)

---

<div class="post-metadata">

**Author:** ![JasonStoltz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasonstoltz/32/49893_2.png) [@JasonStoltz](https://discuss.elastic.co/u/JasonStoltz)\
**Post date:** [April 27, 2020, 2:55pm UTC](https://discuss.elastic.co/t/getting-500-error-on-documents-api/229901/4 "2020-04-27T14:55:21Z")

</div>

And you're still seeing that read-only error message?

---

<div class="post-metadata">

**Author:** ![varunharidas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/varunharidas/32/63704_2.png) [@varunharidas](https://discuss.elastic.co/u/varunharidas)\
**Post date:** [April 27, 2020, 3:54pm UTC](https://discuss.elastic.co/t/getting-500-error-on-documents-api/229901/5 "2020-04-27T15:54:31Z")

</div>

yes, here is what i get from logs:

```auto
    [2020-04-27T15:51:18.538+00:00][1642][2302][app-server][ERROR]: [a744d900-8483-408b-bedf-8e19a6c18e63] ["The service is in read-only mode. Actions that create, update, or delete information are temporarily disabled."]

    [2020-04-27T15:51:18.548+00:00][1642][2302][action_controller][INFO]: [a744d900-8483-408b-bedf-8e19a6c18e63] Completed 503 Service Unavailable in 96ms (Views: 0.7ms)

after i run api call to get status on readonly mode 

][1642][2272][app-server][INFO]: Done running task: KeepFilebeatAlive
[2020-04-27T15:56:05.288+00:00][1642][2332][app-server][INFO]: [71dcf9e6-6440-4225-9abe-e325dd4abf2b] Started GET "/api/as/v1/internal/read_only_mode" for 49.37.201.236
 at 2020-04-27 15:56:05 +0000
[2020-04-27T15:56:05.295+00:00][1642][2332][action_controller][INFO]: [71dcf9e6-6440-4225-9abe-e325dd4abf2b] Processing by LocoTogo::Api::LocoMoco::V1::Internal::ReadOn
lyModeController#show as */*
[2020-04-27T15:56:05.348+00:00][1642][2332][action_controller][INFO]: [71dcf9e6-6440-4225-9abe-e325dd4abf2b] Completed 200 OK in 52ms (Views: 0.9ms)

```

---

<div class="post-metadata">

**Author:** ![JasonStoltz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasonstoltz/32/49893_2.png) [@JasonStoltz](https://discuss.elastic.co/u/JasonStoltz)\
**Post date:** [April 28, 2020, 12:28pm UTC](https://discuss.elastic.co/t/getting-500-error-on-documents-api/229901/6 "2020-04-28T12:28:23Z")

</div>

Is this your version? 7.6.2? [Help setting up App-search using Docker with xpack enabled - Error can't connect to elastic backend](https://discuss.elastic.co/t/help-setting-up-app-search-using-docker-with-xpack-enabled-error-cant-connect-to-elastic-backend/229035)

---

<div class="post-metadata">

**Author:** ![JasonStoltz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasonstoltz/32/49893_2.png) [@JasonStoltz](https://discuss.elastic.co/u/JasonStoltz)\
**Post date:** [April 28, 2020, 12:32pm UTC](https://discuss.elastic.co/t/getting-500-error-on-documents-api/229901/7 "2020-04-28T12:32:26Z")

</div>

See if you can run the PUT to explicitly disable read-only mode and see if that gets things back in order: [https://swiftype.com/documentation/app-search/self-managed/read-only-mode](https://swiftype.com/documentation/app-search/self-managed/read-only-mode)

---

<div class="post-metadata">

**Author:** ![varunharidas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/varunharidas/32/63704_2.png) [@varunharidas](https://discuss.elastic.co/u/varunharidas)\
**Post date:** [April 28, 2020, 1:55pm UTC](https://discuss.elastic.co/t/getting-500-error-on-documents-api/229901/8 "2020-04-28T13:55:57Z")

</div>

Not working i tired , its 7.6.0

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/d/5/d5b4b19ca535478f0b40fd0b94fbc9b7719aba32.png)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 26, 2020, 1:56pm UTC](https://discuss.elastic.co/t/getting-500-error-on-documents-api/229901/9 "2020-05-26T13:56:01Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
