# Getting 502, when TSVB is disabled

**URL:** https://discuss.elastic.co/t/getting-502-when-tsvb-is-disabled/255501
**Category:** Kibana
**Created:** [November 16, 2020, 10:56am UTC](https://discuss.elastic.co/t/getting-502-when-tsvb-is-disabled/255501 "2020-11-16T10:56:15Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![rwgron](https://avatars.discourse-cdn.com/v4/letter/r/6bbea6/32.png) [@rwgron](https://discuss.elastic.co/u/rwgron)
#### Post date: [November 16, 2020, 10:56am UTC](https://discuss.elastic.co/t/getting-502-when-tsvb-is-disabled/255501/1 "2020-11-16T10:56:15Z")

</div>

Does Kibana version 5.6.15 support disabling TSVB? To cover our vulnerability which described in CVE-2020-7013, we should disable TSVB.

for that, I set **metrics.enabled: false** in kibana.yml, but after applying I'm getting 502 error.

---

<div class="post-metadata">

### Author: ![markov00](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/markov00/32/33316_2.png) [@markov00](https://discuss.elastic.co/u/markov00)
#### Post date: [November 26, 2020, 5:59pm UTC](https://discuss.elastic.co/t/getting-502-when-tsvb-is-disabled/255501/2 "2020-11-26T17:59:14Z")

</div>

Hi @rwgron  
I've tested that on a clean Kibana/ES 5.6.12 version and adding `metrics.enabled: false` in the `kibana.yml` file and restarting kibana everything started correctly and works fine.  
Could you please share, if exist, the Kibana log error on the server and on the browser?  
Thanks

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [December 24, 2020, 5:59pm UTC](https://discuss.elastic.co/t/getting-502-when-tsvb-is-disabled/255501/3 "2020-12-24T17:59:38Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
