# Getting 503 error

**URL:** <https://discuss.elastic.co/t/getting-503-error/73939>\
**Category:** Elasticsearch\
**Created:** [February 4, 2017, 12:04pm UTC](https://discuss.elastic.co/t/getting-503-error/73939 "2017-02-04T12:04:16Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![mywish1](https://avatars.discourse-cdn.com/v4/letter/m/3be4f8/32.png) [@mywish1](https://discuss.elastic.co/u/mywish1)\
**Post date:** [February 4, 2017, 12:04pm UTC](https://discuss.elastic.co/t/getting-503-error/73939/1 "2017-02-04T12:04:16Z")

</div>

hi  
i m running elasticsearch and getting this error  
when i try to run that getting this error

[root@rr4 ~]# curl -X GET '[http://localhost:9200](http://localhost:9200)'  
{  
"status" : 503,  
"name" : "es-master",  
"cluster\_name" : "es-tuxfixer-cluster",  
"version" : {  
"number" : "1.7.3",  
"build\_hash" : "05d4530971ef0ea46d0f4fa6ee64dbc8df659682",  
"build\_timestamp" : "2015-10-15T09:14:17Z",  
"build\_snapshot" : false,  
"lucene\_version" : "4.10.4"  
},  
"tagline" : "You Know, for Search"  
}  
please also help me may be some issue in my config file so what is proper config settings waiting thanks.

i m using centos 7 dedicated server.

---

<div class="post-metadata">

**Author:** ![mywish1](https://avatars.discourse-cdn.com/v4/letter/m/3be4f8/32.png) [@mywish1](https://discuss.elastic.co/u/mywish1)\
**Post date:** [February 4, 2017, 2:25pm UTC](https://discuss.elastic.co/t/getting-503-error/73939/2 "2017-02-04T14:25:26Z")

</div>

still waiting for that also i m getting error of that  
some  
[root@rr4 ~]# curl -X GET '[http://localhost:9200](http://localhost:9200)'  
{  
"name" : "node-1",  
"cluster\_name" : "my-application",  
"version" : {  
"number" : "2.1.1",  
"build\_hash" : "40e2c53a6b6c2972b3d13846e450e66f4375bd71",  
"build\_timestamp" : "2015-12-15T13:05:55Z",  
"build\_snapshot" : false,  
"lucene\_version" : "5.3.1"  
},  
"tagline" : "You Know, for Search"  
}  
is that working ?

---

<div class="post-metadata">

**Author:** ![mywish1](https://avatars.discourse-cdn.com/v4/letter/m/3be4f8/32.png) [@mywish1](https://discuss.elastic.co/u/mywish1)\
**Post date:** [February 4, 2017, 3:30pm UTC](https://discuss.elastic.co/t/getting-503-error/73939/3 "2017-02-04T15:30:17Z")

</div>

curl: (7) Failed connect to localhost:9200; Connection refused now getting this issue

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [February 4, 2017, 8:59pm UTC](https://discuss.elastic.co/t/getting-503-error/73939/4 "2017-02-04T20:59:43Z")

</div>

You appear to have multiple versions installed on the same host?

---

<div class="post-metadata">

**Author:** ![mywish1](https://avatars.discourse-cdn.com/v4/letter/m/3be4f8/32.png) [@mywish1](https://discuss.elastic.co/u/mywish1)\
**Post date:** [February 5, 2017, 2:28am UTC](https://discuss.elastic.co/t/getting-503-error/73939/5 "2017-02-05T02:28:41Z")

</div>

yes i think i have installed 2 versions 1 is 1.7 and 2nd is 2.1 something so which one is ok and how i can remove which version and plz tel me how to fix that issue which i explain above thanks.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [February 5, 2017, 3:10am UTC](https://discuss.elastic.co/t/getting-503-error/73939/6 "2017-02-05T03:10:20Z")

</div>

How did you install them?

---

<div class="post-metadata">

**Author:** ![mywish1](https://avatars.discourse-cdn.com/v4/letter/m/3be4f8/32.png) [@mywish1](https://discuss.elastic.co/u/mywish1)\
**Post date:** [February 5, 2017, 5:00am UTC](https://discuss.elastic.co/t/getting-503-error/73939/7 "2017-02-05T05:00:57Z")

</div>

one of install them to follow this website

> **[Install Elasticsearch on CentOS 6.7 - GNU Linux - Sysadmins of the North](https://www.saotn.org/install-elasticsearch-on-centos-6-7/)**
>
> How to install Elasticsearch on CentOS 6.7. Elasticsearch is a highly scalable open-source full-text search and analytics engine. It allows you to store, s

  
and one of install to follow this website  

> **[How To Install and Configure Elasticsearch on CentOS 7 | DigitalOcean](https://www.digitalocean.com/community/tutorials/how-to-install-and-configure-elasticsearch-on-centos-7)**
>
> is a platform for distributed search and analysis of data in real time. Its popularity is due to its ease of use, powerful features, and scalability. Elasticsearch supports RESTful operations. This means that you can use HTTP methods (GET, POST, PUT,

  
but i have running centos 7 dedicated server and now how to fix this issue plz

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [February 5, 2017, 9:52am UTC](https://discuss.elastic.co/t/getting-503-error/73939/8 "2017-02-05T09:52:17Z")

</div>

You would be best off following [https://www.elastic.co/guide/en/elasticsearch/reference/5.2/setup.html](https://www.elastic.co/guide/en/elasticsearch/reference/5.2/setup.html)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 5, 2017, 9:52am UTC](https://discuss.elastic.co/t/getting-503-error/73939/9 "2017-03-05T09:52:17Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
