# Getting below error after X-Pack installation

**URL:** https://discuss.elastic.co/t/getting-below-error-after-x-pack-installation/80652
**Category:** Elasticsearch
**Created:** [March 30, 2017, 10:22am UTC](https://discuss.elastic.co/t/getting-below-error-after-x-pack-installation/80652 "2017-03-30T10:22:25Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![gayathri](https://avatars.discourse-cdn.com/v4/letter/g/838e76/32.png) [@gayathri](https://discuss.elastic.co/u/gayathri)
#### Post date: [March 30, 2017, 10:22am UTC](https://discuss.elastic.co/t/getting-below-error-after-x-pack-installation/80652/1 "2017-03-30T10:22:25Z")

</div>

Hi Team,

We are getting below error on restarting the elasticsearch:

[2017-03-30T03:15:25,300][INFO][o.e.x.m.e.Exporters] [Node\_1] skipping exporter [default\_local] as it isn't ready yet  
[2017-03-30T03:15:25,301][ERROR][o.e.x.m.AgentService] [Node\_1 exception when exporting documents  
org.elasticsearch.xpack.monitoring.exporter.ExportException: exporters are either not ready or faulty  
at org.elasticsearch.xpack.monitoring.exporter.Exporters.export(Exporters.java:188) ~[x-pack-5.0.2.jar:5.0.2]  
at org.elasticsearch.xpack.monitoring.AgentService$ExportingWorker.run(AgentService.java:208) [x-pack-5.0.2.jar:5.0.2]  
at java.lang.Thread.run(Thread.java:745) [?:1.8.0\_121]

PFB, the setting on elasticsearch.yml for X-pack:

xpack.security.enabled: false  
xpack.graph.enabled: false

PFB, the setting on kibana.yml for X-pack:

xpack.security.enabled: false  
xpack.graph.enabled: false  
xpack.reporting.enabled: false

---

<div class="post-metadata">

### Author: ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)
#### Post date: [March 31, 2017, 7:03am UTC](https://discuss.elastic.co/t/getting-below-error-after-x-pack-installation/80652/2 "2017-03-31T07:03:20Z")

</div>

I have moved your post to the X-Pack forum.

---

<div class="post-metadata">

### Author: ![gayathri](https://avatars.discourse-cdn.com/v4/letter/g/838e76/32.png) [@gayathri](https://discuss.elastic.co/u/gayathri)
#### Post date: [April 4, 2017, 5:31am UTC](https://discuss.elastic.co/t/getting-below-error-after-x-pack-installation/80652/3 "2017-04-04T05:31:51Z")

</div>

Thanks Tim

Hi Team,  
Please help me to solve the above error...

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [May 2, 2017, 5:32am UTC](https://discuss.elastic.co/t/getting-below-error-after-x-pack-installation/80652/4 "2017-05-02T05:32:03Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.

---

<div class="post-metadata">

### Author: ![pickypg](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pickypg/32/62409_2.png) [@pickypg](https://discuss.elastic.co/u/pickypg)
#### Post date: [September 11, 2017, 5:50pm UTC](https://discuss.elastic.co/t/getting-below-error-after-x-pack-installation/80652/5 "2017-09-11T17:50:44Z")

</div>

Hi @gayathri,

I realize that this response is a bit late, but better late than never? And hopefully for anyone else that sees this issue. The only reason this error happens is:

1. The local exporter tried to start before the ES node was actually ready for it to start. (It will retry in 10 seconds)
  - This can usually happen because Kibana 5.x will forward monitoring data to the node to be indexed before the node is ready; it will just be ignored for the next pass.
  - Under normal circumstances, this can just be ignored if it happens once or twice.

2. The exporters are explicitly disabled and something forwards data.
  - If this is the case, then it will continue to happen and monitoring should be disabled on the sending end (Kibana or Logstash).

Hope that helps someone in the future.

Thanks,  
Chris
