# Getting Error when i start metric beat service

**URL:** https://discuss.elastic.co/t/getting-error-when-i-start-metric-beat-service/186393
**Category:** Beats
**Tags:** metricbeat
**Created:** [June 19, 2019, 7:12am UTC](https://discuss.elastic.co/t/getting-error-when-i-start-metric-beat-service/186393 "2019-06-19T07:12:32Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![stalinbritto](https://avatars.discourse-cdn.com/v4/letter/s/dfb087/32.png) [@stalinbritto](https://discuss.elastic.co/u/stalinbritto)
#### Post date: [June 19, 2019, 7:12am UTC](https://discuss.elastic.co/t/getting-error-when-i-start-metric-beat-service/186393/1 "2019-06-19T07:12:32Z")

</div>

```
//
metricbeat.service - Metricbeat is a lightweight shipper for metrics.
       Loaded: loaded (/lib/systemd/system/metricbeat.service; enabled; vendor preset: enabled)
   Active: active (running) since Wed 2019-06-19 06:58:12 UTC; 8min ago
     Docs: https://www.elastic.co/products/beats/metricbeat
 Main PID: 80006 (metricbeat)
    Tasks: 17
   Memory: 29.0M
      CPU: 6.367s
   CGroup: /system.slice/metricbeat.service
           └─80006 /usr/share/metricbeat/bin/metricbeat -e -c /etc/metricbeat/metricbeat.yml -path.home /usr/share/metricbeat -path.confi

Jun 19 07:05:22 elktest2 metricbeat[80006]: 2019-06-19T07:05:22.461Z ERROR cfgfile/reload.go:223 Error loading config: invalid config: yaml: line 40: did not find expected key
Jun 19 07:05:32 elktest2 metricbeat[80006]: 2019-06-19T07:05:32.463Z ERROR cfgfile/reload.go:223 Error loading config: invalid config: yaml: line 40: did not find expected key
Jun 19 07:05:42 elktest2 metricbeat[80006]: 2019-06-19T07:05:42.413Z INFO [monitoring] log/log.go:144 Non-zer
Jun 19 07:05:42 elktest2 metricbeat[80006]: 2019-06-19T07:05:42.464Z ERROR cfgfile/reload.go:223 Error loading config: invalid config: yaml: line 40: did not find expected key
Jun 19 07:05:52 elktest2 metricbeat[80006]: 2019-06-19T07:05:52.465Z ERROR cfgfile/reload.go:223 Error loading config: invalid config: yaml: line 40: did not find expected key
Jun 19 07:06:02 elktest2 metricbeat[80006]: 2019-06-19T07:06:02.467Z ERROR cfgfile/reload.go:223 Error loading config: invalid config: yaml: line 40: did not find expected key
Jun 19 07:06:12 elktest2 metricbeat[80006]: 2019-06-19T07:06:12.413Z INFO [monitoring] log/log.go:144 Non-zer metrics in the last 30s {"monitoring": {"metrics": {"beat":{"cpu":{"system":{"ticks":2820,"time":{"ms":186}},"total":{"ticks":5
Jun 19 07:06:12 elktest2 metricbeat[80006]: 2019-06-19T07:06:12.468Z ERROR cfgfile/reload.go:223 Error loading config: invalid config: yaml: line 40: did not find expected key
Jun 19 07:06:22 elktest2 metricbeat[80006]: 2019-06-19T07:06:22.469Z ERROR cfgfile/reload.go:223 Error loading config: invalid config: yaml: line 40: did not find expected key
        ERROR cfgfile/reload.go:223 Error loading config: invalid config: yaml: line 40: did not find expected key

![1|690x216](upload://sK6xSLvyCPz1aSgYtTKX0iBHInL.jpeg)
```

---

<div class="post-metadata">

### Author: ![stalinbritto](https://avatars.discourse-cdn.com/v4/letter/s/dfb087/32.png) [@stalinbritto](https://discuss.elastic.co/u/stalinbritto)
#### Post date: [June 19, 2019, 7:18am UTC](https://discuss.elastic.co/t/getting-error-when-i-start-metric-beat-service/186393/2 "2019-06-19T07:18:50Z")

</div>

```
And there is no error log from metricbeat log path

root@elktest2:/var/log/metricbeat# cat metricbeat
2019-06-19T06:44:14.603Z INFO instance/beat.go:571 Home path: [/usr/share/metricbeat] Config path: [/etc/metricbeat] Data path: [/var/lib/metricbeat] Logs path: [/var/log/metricbeat]
2019-06-19T06:44:14.604Z INFO instance/beat.go:579 Beat ID: 34c0f38b-858b-4c94-a880-bd125f03e795
2019-06-19T06:44:14.604Z INFO [index-management.ilm] ilm/ilm.go:129 Policy name: metricbeat-7.1.0
```

---

<div class="post-metadata">

### Author: ![Mario\_Castro](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mario_castro/32/35107_2.png) [@Mario\_Castro](https://discuss.elastic.co/u/Mario_Castro)
#### Post date: [June 19, 2019, 7:46am UTC](https://discuss.elastic.co/t/getting-error-when-i-start-metric-beat-service/186393/3 "2019-06-19T07:46:45Z")

</div>

Hi @stalinbritto 🙂

I highly recommend you to check your YAML

```
        ERROR cfgfile/reload.go:223 Error loading config: invalid config: yaml: line 40: did not find expected key

```

Or paste it here.

Regards!

---

<div class="post-metadata">

### Author: ![stalinbritto](https://avatars.discourse-cdn.com/v4/letter/s/dfb087/32.png) [@stalinbritto](https://discuss.elastic.co/u/stalinbritto)
#### Post date: [June 19, 2019, 9:19am UTC](https://discuss.elastic.co/t/getting-error-when-i-start-metric-beat-service/186393/4 "2019-06-19T09:19:27Z")

</div>

```
metricbeat.config.modules:
  path: ${path.config}/modules.d/*.yml
  reload.enabled: true
setup.template.settings:
  index.number_of_shards: 1
  index.codec: best_compression
setup.kibana:
  host: "localhost:5601"
output.elasticsearch:
  hosts: ["localhost:9200"]
  username: "elastic"
  password: "password"
processors:
  - add_host_metadata: ~
  - add_cloud_metadata: ~
```

---

<div class="post-metadata">

### Author: ![Mario\_Castro](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mario_castro/32/35107_2.png) [@Mario\_Castro](https://discuss.elastic.co/u/Mario_Castro)
#### Post date: [June 19, 2019, 11:16am UTC](https://discuss.elastic.co/t/getting-error-when-i-start-metric-beat-service/186393/5 "2019-06-19T11:16:14Z")

</div>

Please, paste the entire YAML or check yourself line 40 to check if you are forgetting something 😉

---

<div class="post-metadata">

### Author: ![stalinbritto](https://avatars.discourse-cdn.com/v4/letter/s/dfb087/32.png) [@stalinbritto](https://discuss.elastic.co/u/stalinbritto)
#### Post date: [June 19, 2019, 12:30pm UTC](https://discuss.elastic.co/t/getting-error-when-i-start-metric-beat-service/186393/6 "2019-06-19T12:30:03Z")

</div>

This is my metricbeat YML file.

```
cat /etc/metricbeat/metricbeat.yml
###################### Metricbeat Configuration Example #######################

# This file is an example configuration file highlighting only the most common
# options. The metricbeat.reference.yml file from the same directory contains all the
# supported options with more comments. You can use it as a reference.
#
# You can find the full configuration reference here:
# https://www.elastic.co/guide/en/beats/metricbeat/index.html

#========================== Modules configuration ============================

metricbeat.config.modules:
  # Glob pattern for configuration loading
  path: ${path.config}/modules.d/*.yml

  # Set to true to enable config reloading
  reload.enabled: true

  # Period on which files under path should be checked for changes
  reload.period: 10s

#==================== Elasticsearch template setting ==========================

setup.template.settings:
  index.number_of_shards: 1
  index.codec: best_compression
  #_source.enabled: false

#================================ General =====================================

# The name of the shipper that publishes the network data. It can be used to group
# all the transactions sent by a single shipper in the web interface.
#name:

# The tags of the shipper are included in their own field with each
# transaction published.
#tags: ["service-X", "web-tier"]

# Optional fields that you can specify to add additional information to the
# output.
#fields:
# env: staging

#============================== Dashboards =====================================
# These settings control loading the sample dashboards to the Kibana index. Loading
# the dashboards is disabled by default and can be enabled either by setting the
# options here or by using the `setup` command.
#setup.dashboards.enabled: false

# The URL from where to download the dashboards archive. By default this URL
# has a value which is computed based on the Beat name and version. For released
# versions, this URL points to the dashboard archive on the artifacts.elastic.co
# website.
#setup.dashboards.url:

#============================== Kibana =====================================

# Starting with Beats version 6.0.0, the dashboards are loaded via the Kibana API.
# This requires a Kibana endpoint configuration.
setup.kibana:

  # Kibana Host
  # Scheme and port can be left out and will be set to the default (http and 5601)
  # In case you specify and additional path, the scheme is required: http://localhost:5601/path
  # IPv6 addresses should always be defined as: https://[2001:db8::1]:5601
  host: "localhost:5601"

  # Kibana Space ID
  # ID of the Kibana Space into which the dashboards should be loaded. By default,
  # the Default Space will be used.
  #space.id:

#============================= Elastic Cloud ==================================

# These settings simplify using metricbeat with the Elastic Cloud (https://cloud.elastic.co/).

# The cloud.id setting overwrites the `output.elasticsearch.hosts` and
# `setup.kibana.host` options.
# You can find the `cloud.id` in the Elastic Cloud web UI.
#cloud.id:

# The cloud.auth setting overwrites the `output.elasticsearch.username` and
# `output.elasticsearch.password` settings. The format is `<user>:<pass>`.
#cloud.auth:

#================================ Outputs =====================================

# Configure what output to use when sending the data collected by the beat.

#-------------------------- Elasticsearch output ------------------------------
output.elasticsearch:
  # Array of hosts to connect to.
  hosts: ["localhost:9200"]

  # Optional protocol and basic auth credentials.
  #protocol: "https"
  username: "elastic"
  password: "password"

#----------------------------- Logstash output --------------------------------
#output.logstash:
  # The Logstash hosts
# hosts: ["localhost:5044"]

  # Optional SSL. By default is off.
  # List of root certificates for HTTPS server verifications
  #ssl.certificate_authorities: ["/etc/pki/root/ca.pem"]

  # Certificate for SSL client authentication
  #ssl.certificate: "/etc/pki/client/cert.pem"

  # Client Certificate Key
  #ssl.key: "/etc/pki/client/cert.key"

#================================ Processors =====================================

# Configure processors to enhance or manipulate events generated by the beat.

processors:
  - add_host_metadata: ~
  - add_cloud_metadata: ~

#================================ Logging =====================================

# Sets log level. The default log level is info.
# Available log levels are: error, warning, info, debug
#logging.level: debug

# At debug level, you can selectively enable logging only for some components.
# To enable all selectors use ["*"]. Examples of other selectors are "beat",
# "publish", "service".
#logging.selectors: ["*"]

#============================== Xpack Monitoring ===============================
# metricbeat can export internal metrics to a central Elasticsearch monitoring
# cluster. This requires xpack monitoring to be enabled in Elasticsearch. The
# reporting is disabled by default.

# Set to true to enable the monitoring reporter.
#xpack.monitoring.enabled: false

# Uncomment to send the metrics to Elasticsearch. Most settings from the
# Elasticsearch output are accepted here as well. Any setting that is not set is
# automatically inherited from the Elasticsearch output configuration, so if you
# have the Elasticsearch output configured, you can simply uncomment the
# following line.
#xpack.monitoring.elasticsearch:

#================================= Migration ==================================

# This allows to enable 6.7 migration aliases
#migration.6_to_7.enabled: true
```

---

<div class="post-metadata">

### Author: ![Mario\_Castro](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mario_castro/32/35107_2.png) [@Mario\_Castro](https://discuss.elastic.co/u/Mario_Castro)
#### Post date: [June 24, 2019, 9:44am UTC](https://discuss.elastic.co/t/getting-error-when-i-start-metric-beat-service/186393/7 "2019-06-24T09:44:14Z")

</div>

I think you are missing some ILM related configuration on your Metricbeat file. Check [https://www.elastic.co/guide/en/beats/metricbeat/current/ilm.html](https://www.elastic.co/guide/en/beats/metricbeat/current/ilm.html)

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 22, 2019, 9:44am UTC](https://discuss.elastic.co/t/getting-error-when-i-start-metric-beat-service/186393/8 "2019-07-22T09:44:16Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
