# Getting error while starting logstash - Failed to execute action {:id=\>:main, :action\_type=\>LogStash::ConvergeResult::FailedAction, :message=\>"Could not execute action: PipelineAct ion::Create\<main\>, action\_result: false", :backtrace=\>nil

**URL:** <https://discuss.elastic.co/t/getting-error-while-starting-logstash-failed-to-execute-action-id-main-action-type-logstash-failedaction-message-could-not-execute-action-pipelineact-ion-create-main-action-result-false-backtrace-nil/252044>\
**Category:** Logstash\
**Created:** [October 14, 2020, 12:47pm UTC](https://discuss.elastic.co/t/getting-error-while-starting-logstash-failed-to-execute-action-id-main-action-type-logstash-failedaction-message-could-not-execute-action-pipelineact-ion-create-main-action-result-false-backtrace-nil/252044 "2020-10-14T12:47:48Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![kanhaiyak424](https://avatars.discourse-cdn.com/v4/letter/k/7bcc69/32.png) [@kanhaiyak424](https://discuss.elastic.co/u/kanhaiyak424)\
**Post date:** [October 14, 2020, 12:47pm UTC](https://discuss.elastic.co/t/getting-error-while-starting-logstash-failed-to-execute-action-id-main-action-type-logstash-failedaction-message-could-not-execute-action-pipelineact-ion-create-main-action-result-false-backtrace-nil/252044/1 "2020-10-14T12:47:48Z")

</div>

E:\ELK\Software\logstash-7.9.1\bin\>logstash -f logstash-simple-jms.conf  
Java HotSpot(TM) 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.  
WARNING: An illegal reflective access operation has occurred  
WARNING: Illegal reflective access by org.jruby.ext.openssl.SecurityHelper (file:/C:/Users/Kanhaiya/AppData/Local/Temp/jruby-6340/jruby17660347423598609572jopenssl.jar) to field java.security.MessageD  
igest.provider  
WARNING: Please consider reporting this to the maintainers of org.jruby.ext.openssl.SecurityHelper  
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations  
WARNING: All illegal access operations will be denied in a future release  
Sending Logstash logs to E:/ELK/Software/logstash-7.9.1/logs which is now configured via log4j2.properties  
[2020-10-14T15:40:49,855][INFO][logstash.runner] Starting Logstash {"logstash.version"=\>"7.9.1", "jruby.version"=\>"jruby 9.2.13.0 (2.5.7) 2020-08-03 9a89c94bcc Java HotSpot(TM) 64-Bit Serve  
r VM 11.0.8+10-LTS on 11.0.8+10-LTS +indy +jit [mswin32-x86\_64]"}  
[2020-10-14T15:40:50,457][WARN][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified  
[2020-10-14T15:40:53,523][INFO][org.reflections.Reflections] Reflections took 81 ms to scan 1 urls, producing 22 keys and 45 values  
[2020-10-14T15:40:54,335][WARN][logstash.outputs.elasticsearch] You are using a deprecated config setting "document\_type" set in elasticsearch. Deprecated settings will continue to work, but are sche  
duled for removal from logstash in the future. Document types are being deprecated in Elasticsearch 6.0, and removed entirely in 7.0. You should avoid this feature If you have any questions about this  
, please visit the #logstash channel on freenode irc. {:name=\>"document\_type", :plugin=\>\<LogStash::Outputs::ElasticSearch index=\>"OSBGenericTracing", manage\_template=\>false, id=\>"f503502ac5f459b09ca7d  
7b5a6851b24a2d2bd92a5302cc8d149145d137b1f40", hosts=\>[[http://localhost:9200](http://localhost:9200)], document\_type=\>"JMSQueueDoc", enable\_metric=\>true, codec=\>\<LogStash::Codecs::Plain id=\>"plain\_f93fdf1e-6520-49fc-aef7-32d7  
ad811958", enable\_metric=\>true, charset=\>"UTF-8"\>, workers=\>1, template\_overwrite=\>false, doc\_as\_upsert=\>false, script\_type=\>"inline", script\_lang=\>"painless", script\_var\_name=\>"event", scripted\_upser  
t=\>false, retry\_initial\_interval=\>2, retry\_max\_interval=\>64, retry\_on\_conflict=\>1, ilm\_enabled=\>"auto", ilm\_pattern=\>"{now/d}-000001", ilm\_policy=\>"logstash-policy", ecs\_compatibility=\>:disabled, acti  
on=\>"index", ssl\_certificate\_verification=\>true, sniffing=\>false, sniffing\_delay=\>5, timeout=\>60, pool\_max=\>1000, pool\_max\_per\_route=\>100, resurrect\_delay=\>5, validate\_after\_inactivity=\>10000, http\_co  
mpression=\>false\>}  
[2020-10-14T15:40:55,126][INFO][logstash.outputs.elasticsearch][main] Elasticsearch pool URLs updated {:changes=\>{:removed=\>, :added=\>[[http://localhost:9200/](http://localhost:9200/)]}}  
[2020-10-14T15:40:55,470][WARN][logstash.outputs.elasticsearch][main] Restored connection to ES instance {:url=\>"[http://localhost:9200/](http://localhost:9200/)"}  
[2020-10-14T15:40:55,558][INFO][logstash.outputs.elasticsearch][main] ES Output version determined {:es\_version=\>7}  
[2020-10-14T15:40:55,566][WARN][logstash.outputs.elasticsearch][main] Detected a 6.x and above cluster: the `type` event field won't be used to determine the document _type {:es\_version=\>7}  
[2020-10-14T15:40:55,677][INFO][logstash.outputs.elasticsearch][main] New Elasticsearch output {:class=\>"LogStash::Outputs::ElasticSearch", :hosts=\>["[http://localhost:9200](http://localhost:9200)"]}  
[2020-10-14T15:40:55,838][INFO][logstash.javapipeline][main] Starting pipeline {:pipeline\_id=\>"main", "pipeline.workers"=\>4, "pipeline.batch.size"=\>125, "pipeline.batch.delay"=\>50, "pipeline.max_  
inflight"=\>500, "pipeline.sources"=\>["E:/ELK/Software/logstash-7.9.1/bin/logstash-simple-jms.conf"], :thread=\>"#\<Thread:0x78632ee5 run\>"}  
[2020-10-14T15:40:57,394][INFO][logstash.javapipeline][main] Pipeline Java execution initialization time {"seconds"=\>1.54}  
[2020-10-14T15:40:58,726][ERROR][logstash.agent] Failed to execute action {:id=\>:main, :action\_type=\>LogStash::ConvergeResult::FailedAction, :message=\>"Could not execute action: PipelineAct  
ion::Create, action\_result: false", :backtrace=\>nil}  
[2020-10-14T15:40:59,185][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}  
[2020-10-14T15:41:04,087][INFO][logstash.runner] Logstash shut down.  
[2020-10-14T15:41:04,233][ERROR][org.logstash.Logstash] java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 11, 2020, 12:48pm UTC](https://discuss.elastic.co/t/getting-error-while-starting-logstash-failed-to-execute-action-id-main-action-type-logstash-failedaction-message-could-not-execute-action-pipelineact-ion-create-main-action-result-false-backtrace-nil/252044/2 "2020-11-11T12:48:06Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
