# Getting errors after Logstash upgrade from 7.6.2 to 7.9.2

**URL:** <https://discuss.elastic.co/t/getting-errors-after-logstash-upgrade-from-7-6-2-to-7-9-2/251370>\
**Category:** Logstash\
**Created:** [October 8, 2020, 4:46am UTC](https://discuss.elastic.co/t/getting-errors-after-logstash-upgrade-from-7-6-2-to-7-9-2/251370 "2020-10-08T04:46:15Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![yummycake](https://avatars.discourse-cdn.com/v4/letter/y/2acd7d/32.png) [@yummycake](https://discuss.elastic.co/u/yummycake)\
**Post date:** [October 8, 2020, 4:46am UTC](https://discuss.elastic.co/t/getting-errors-after-logstash-upgrade-from-7-6-2-to-7-9-2/251370/1 "2020-10-08T04:46:15Z")

</div>

I recently upgraded my Logstash from 7.6.2 to the latest version 7.9.2. When I tested my configuration file, I received the output below. I did not get the error below output when I tested with version 7.6.2

May I know if I can just ignore the ERROR and warning message? Is there anything wrong with my plugin in the logstash.conf file?

Thank you.

````auto
2020-10-08 11:13:54,560 main ERROR Script contains an invalid element or attribute "value"
2020-10-08 11:13:54,560 main ERROR No 'scriptText' attribute provided for Script plugin 'filter_no_pipelined'
2020-10-08 11:13:54,575 main ERROR A Script, ScriptFile or ScriptRef element must be provided for this ScriptFilter
2020-10-08 11:13:54,575 main ERROR Script contains an invalid element or attribute "value"
2020-10-08 11:13:54,575 main ERROR No 'scriptText' attribute provided for Script plugin 'routing_script'
2020-10-08 11:13:54,575 main ERROR Script contains an invalid element or attribute "value"
2020-10-08 11:13:54,590 main ERROR No 'scriptText' attribute provided for Script plugin 'filter_no_pipelined'
2020-10-08 11:13:54,590 main ERROR A Script, ScriptFile or ScriptRef element must be provided for this ScriptFilter
[2020-10-08T11:13:54,590][INFO][logstash.runner] Starting Logstash {"logstash.version"=>"7.9.2", "jruby.version"=>"jruby 9.2.13.0 (2.5.7) 2020-08-03 9a89c94bcc Java HotSpot(TM) Client VM 25.251-b08 on 1.8.0_251-b08 +indy +jit [mswin32-i386]"}
[2020-10-08T11:13:54,621][INFO][logstash.setting.writabledirectory] Creating directory {:setting=>"path.queue", :path=>"C:\\ProgramData\\Elastic\\logstash-7.9.2\\data/queue"}
[2020-10-08T11:13:54,637][INFO][logstash.setting.writabledirectory] Creating directory {:setting=>"path.dead_letter_queue", :path=>"C:\\ProgramData\\Elastic\\logstash-7.9.2\\data/dead_letter_queue"}
[2020-10-08T11:13:54,731][WARN][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified
[2020-10-08T11:13:56,760][INFO][org.reflections.Reflections] Reflections took 16 ms to scan 1 urls, producing 22 keys and 45 values
Configuration OK
[2020-10-08T11:14:00,277][INFO][logstash.runner] Using config.test_and_exit mode. Config Validation Result: OK. Exiting Logstash```
````

---

<div class="post-metadata">

**Author:** ![Wolfram\_Haussig](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/wolfram_haussig/32/70528_2.png) [@Wolfram\_Haussig](https://discuss.elastic.co/u/Wolfram_Haussig)\
**Post date:** [October 8, 2020, 5:28am UTC](https://discuss.elastic.co/t/getting-errors-after-logstash-upgrade-from-7-6-2-to-7-9-2/251370/2 "2020-10-08T05:28:21Z")

</div>

Hi,

Did you copy the `log4j2.properties` from your old installation? There was a change in one of this versions from:  
`appender.rolling.avoid_pipelined_filter.script.value`  
to:  
`appender.rolling.avoid_pipelined_filter.script.scriptText`

Best regards  
Wolfram

---

<div class="post-metadata">

**Author:** ![yummycake](https://avatars.discourse-cdn.com/v4/letter/y/2acd7d/32.png) [@yummycake](https://discuss.elastic.co/u/yummycake)\
**Post date:** [October 8, 2020, 7:33am UTC](https://discuss.elastic.co/t/getting-errors-after-logstash-upgrade-from-7-6-2-to-7-9-2/251370/3 "2020-10-08T07:33:11Z")

</div>

> [@Wolfram\_Haussig](#):
>
> log4j2.properties

Thank you Wolfram! I accidentally overwrite the log4j2.properties file in 7.6.2 version into the 7.9.2 one.

It works now!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 5, 2020, 7:33am UTC](https://discuss.elastic.co/t/getting-errors-after-logstash-upgrade-from-7-6-2-to-7-9-2/251370/4 "2020-11-05T07:33:15Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
