# Getting exception preparing index using Rabbitmq river?

**URL:** <https://discuss.elastic.co/t/getting-exception-preparing-index-using-rabbitmq-river/5275>\
**Category:** Elasticsearch\
**Created:** [August 30, 2011, 5:50am UTC](https://discuss.elastic.co/t/getting-exception-preparing-index-using-rabbitmq-river/5275 "2011-08-30T05:50:40Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Sam\_4](https://avatars.discourse-cdn.com/v4/letter/s/db5fbb/32.png) [@Sam\_4](https://discuss.elastic.co/u/Sam_4)\
**Post date:** [August 30, 2011, 5:50am UTC](https://discuss.elastic.co/t/getting-exception-preparing-index-using-rabbitmq-river/5275/1 "2011-08-30T05:50:40Z")

</div>

Hi

I'm using elastic search server 0.16.2.for preparing index i used  
Rabbitmq river.before consuming message first i check cluster-heath  
status if i found it GREEN start to listen message from elastic  
queue.but it takes too much time to consume and prepare index.first  
time it run successfully after second time i got the following  
exception:

WARN - [Living Eraser] [114799][3] failed to start shard  
org.elasticsearch.index.shard.recovery.RecoveryFailedException: Index  
Shard [114799][3]: Recovery failed from [Flag-Smasher]  
[toyHuyn0RBiG66TVscpQ4g][inet[/192.168.1.200:9300]] into [Living  
Eraser][vxBNlG6aRMu5p\_qJcIYpXw][inet[/192.168.1.200:9303]]  
at  
org.elasticsearch.index.shard.recovery.RecoveryTarget.doRecovery(RecoveryTarget.java:  
243)  
at org.elasticsearch.index.shard.recovery.RecoveryTarget.access  
$100(RecoveryTarget.java:61)  
at org.elasticsearch.index.shard.recovery.RecoveryTarget  
$2.run(RecoveryTarget.java:146)  
at java.util.concurrent.ThreadPoolExecutor  
$Worker.runTask(ThreadPoolExecutor.java:886)  
at java.util.concurrent.ThreadPoolExecutor  
$Worker.run(ThreadPoolExecutor.java:908)  
at java.lang.Thread.run(Thread.java:662)  
Caused by: org.elasticsearch.transport.RemoteTransportException: [Flag-  
Smasher][inet[/192.168.1.200:9300]][index/shard/recovery/  
startRecovery]  
Caused by: org.elasticsearch.index.engine.RecoveryEngineException:  
[114799][3] Phase[1] Execution failed  
at  
org.elasticsearch.index.engine.robin.RobinEngine.recover(RobinEngine.java:  
847)  
at  
org.elasticsearch.index.shard.service.InternalIndexShard.recover(InternalIndexShard.java:  
439)  
at  
org.elasticsearch.index.shard.recovery.RecoverySource.recover(RecoverySource.java:  
110)  
at org.elasticsearch.index.shard.recovery.RecoverySource.access  
$1600(RecoverySource.java:60)  
at org.elasticsearch.index.shard.recovery.RecoverySource  
$StartRecoveryTransportRequestHandler.messageReceived(RecoverySource.java:  
296)  
at org.elasticsearch.index.shard.recovery.RecoverySource  
$StartRecoveryTransportRequestHandler.messageReceived(RecoverySource.java:  
285)  
at org.elasticsearch.transport.netty.MessageChannelHandler  
$RequestHandler.run(MessageChannelHandler.java:236)  
at java.util.concurrent.ThreadPoolExecutor  
$Worker.runTask(ThreadPoolExecutor.java:886)  
at java.util.concurrent.ThreadPoolExecutor  
$Worker.run(ThreadPoolExecutor.java:908)  
at java.lang.Thread.run(Thread.java:662)  
Caused by:  
org.elasticsearch.index.shard.recovery.RecoverFilesRecoveryException:  
[114799][3] Failed to transfer [1] files with total size of [32b]  
at org.elasticsearch.index.shard.recovery.RecoverySource  
$1.phase1(RecoverySource.java:207)  
at  
org.elasticsearch.index.engine.robin.RobinEngine.recover(RobinEngine.java:  
843)  
... 9 more  
Caused by: org.elasticsearch.transport.RemoteTransportException:  
[Living Eraser][inet[/192.168.1.200:9303]][index/shard/recovery/  
fileChunk]  
Caused by: java.io.FileNotFoundException: H:\12-Aug  
\ElasticIndexManagementService\data\elasticsearch\nodes\0\indices  
\114799\3\index\segments\_1 (Access is denied)  
at java.io.RandomAccessFile.open(Native Method)  
at java.io.RandomAccessFile.(RandomAccessFile.java:212)  
at org.apache.lucene.store.FSDirectory  
$FSIndexOutput.(FSDirectory.java:462)  
at org.apache.lucene.store.FSDirectory.createOutput(FSDirectory.java:  
314)  
at org.elasticsearch.index.store.support.AbstractStore  
$StoreDirectory.createOutput(AbstractStore.java:318)  
at  
org.elasticsearch.index.store.support.AbstractStore.createOutputWithNoChecksum(AbstractStore.java:  
192)  
at org.elasticsearch.index.shard.recovery.RecoveryTarget  
$FileChunkTransportRequestHandler.messageReceived(RecoveryTarget.java:  
438)  
at org.elasticsearch.index.shard.recovery.RecoveryTarget  
$FileChunkTransportRequestHandler.messageReceived(RecoveryTarget.java:  
407)  
at org.elasticsearch.transport.netty.MessageChannelHandler  
$RequestHandler.run(MessageChannelHandler.java:236)  
at java.util.concurrent.ThreadPoolExecutor  
$Worker.runTask(ThreadPoolExecutor.java:886)  
at java.util.concurrent.ThreadPoolExecutor  
$Worker.run(ThreadPoolExecutor.java:908)  
at java.lang.Thread.run(Thread.java:662)  
WARN - [Living Eraser] sending failed shard for [114799][3],  
node[vxBNlG6aRMu5p\_qJcIYpXw], [R], s[INITIALIZING], reason [Failed to  
start shard, message [RecoveryFailedException[Index Shard [114799][3]:  
Recovery failed from [Flag-Smasher][toyHuyn0RBiG66TVscpQ4g][inet[/  
192.168.1.200:9300]] into [Living Eraser][vxBNlG6aRMu5p\_qJcIYpXw]  
[inet[/192.168.1.200:9303]]]; nested: RemoteTransportException[[Flag-  
Smasher][inet[/192.168.1.200:9300]][index/shard/recovery/  
startRecovery]]; nested: RecoveryEngineException[[114799][3] Phase[1]  
Execution failed]; nested: RecoverFilesRecoveryException[[114799][3]  
Failed to transfer [1] files with total size of [32b]]; nested:  
RemoteTransportException[[Living Eraser][inet[/192.168.1.200:9303]]  
[index/shard/recovery/fileChunk]]; nested: FileNotFoundException[H:\12-  
Aug\ElasticIndexManagementService\data\elasticsearch\nodes\0\indices  
\114799\3\index\segments\_1 (Access is denied)]; ]]

i'm unable to resolve this exception,please help me for resolve this  
exception.

Thanks

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 3:55am UTC](https://discuss.elastic.co/t/getting-exception-preparing-index-using-rabbitmq-river/5275/2 "2017-07-06T03:55:38Z")

</div>


