# Getting issue during running a api command

**URL:** <https://discuss.elastic.co/t/getting-issue-during-running-a-api-command/290142>\
**Category:** Elasticsearch\
**Created:** [November 25, 2021, 8:49am UTC](https://discuss.elastic.co/t/getting-issue-during-running-a-api-command/290142 "2021-11-25T08:49:12Z")\
**Posts on this page:** 1\
**Showing post:** 5

<div class="post-metadata">

**Author:** ![DineshNaik](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dineshnaik/32/89308_2.png) [@DineshNaik](https://discuss.elastic.co/u/DineshNaik)\
**Post date:** [December 2, 2021, 7:45am UTC](https://discuss.elastic.co/t/getting-issue-during-running-a-api-command/290142/5 "2021-12-02T07:45:42Z")

</div>

Ok , fixing the cluster status would be the first step.

Check the cluster status and try to make it green first.  
you can use these commands to get an idea of what's going in the cluster.

curl -XGET "[http://localhost:9200/\_cluster/stats](http://localhost:9200/_cluster/stats)"  
curl -XGET "[http://localhost:9200/\_cat/shards](http://localhost:9200/_cat/shards)"  
curl -XGET "[http://localhost:9200/\_nodes/hot\_threads](http://localhost:9200/_nodes/hot_threads)"  
curl -XGET "[http://localhost:9200/\_cat/nodes](http://localhost:9200/_cat/nodes)"  
curl -XGET "[http://localhost:9200/\_cluster/health](http://localhost:9200/_cluster/health)"

please read the below post to know more about this issue:

> [@What does this error mean - Data too large, data for \[\<transport\_request\>\]](https://discuss.elastic.co/t/what-does-this-error-mean-data-too-large-data-for-transport-request/209345/3):
>
> Hello @HenningAndersen, thank you for reply, but unfortunately setting: InitiatingHeapOccupancyPercent=30 ReservePercent=25 didn't help. I've also increased heap from 30G to 50G, but it doesn't help too: Caused by: org.elasticsearch.common.breaker.CircuitBreakingException: [parent] Data too large, data for [\<transport\_request\>] would be [53028227584/49.3gb], which is larger than the limit of [51002736640/47.5gb], real usage: [53028224688/49.3gb], new bytes reserved: [2896/2.8kb] And I sti…

And this page to diagnose further:  
: [Fix common cluster issues | Elasticsearch Guide [7.14] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/7.14/fix-common-cluster-issues.html#circuit-breaker-errors)

---

_[View the full topic](https://discuss.elastic.co/t/getting-issue-during-running-a-api-command/290142)._
