# Getting issue while configuring elasticsearch in clustered mode

**URL:** <https://discuss.elastic.co/t/getting-issue-while-configuring-elasticsearch-in-clustered-mode/76143>\
**Category:** Elasticsearch\
**Created:** [February 23, 2017, 4:03am UTC](https://discuss.elastic.co/t/getting-issue-while-configuring-elasticsearch-in-clustered-mode/76143 "2017-02-23T04:03:28Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![abhishek\_chordia](https://avatars.discourse-cdn.com/v4/letter/a/7cd45c/32.png) [@abhishek\_chordia](https://discuss.elastic.co/u/abhishek_chordia)\
**Post date:** [February 23, 2017, 4:03am UTC](https://discuss.elastic.co/t/getting-issue-while-configuring-elasticsearch-in-clustered-mode/76143/1 "2017-02-23T04:03:28Z")

</div>

## Getting issue while configuring elasticsearch in clustered mode, single node is working as expected. Below are the configuration and logs

Configuration of elasticsearch.yml :

server 1:

[cluster.name](http://cluster.name): elkstack  
[node.name](http://node.name): 192.168.1.133  
network.host: 192.168.1.133  
discovery.zen.ping.unicast.hosts: ["192.168.1.133","192.168.1.93"]

Server 2:

[cluster.name](http://cluster.name): elkstack  
[node.name](http://node.name): 192.168.1.93  
network.host: 192.168.1.93  
discovery.zen.ping.unicast.hosts: ["192.168.1.133","192.168.1.93"]

* * *

## Logs : [2017-02-23T09:12:43,911][INFO][o.e.n.Node] [192.168.1.133] starting ... [2017-02-23T09:12:55,427][INFO][o.e.t.TransportService] [192.168.1.133] publish\_address {192.168.1.133:9300}, bound\_addresses {192.168.1.133:9300} **[2017-02-23T09:12:55,433][INFO][o.e.b.BootstrapChecks] [192.168.1.133] bound or publishing to a non-loopback or non-link-local address, enforcing bootstrap checks** **[2017-02-23T09:12:55,436][ERROR][o.e.b.Bootstrap] [192.168.1.133] node validation exception**  **bootstrap checks failed**  **system call filters failed to install; check the logs and fix your configuration or disable system call filters at your own risk** [2017-02-23T09:12:55,465][INFO][o.e.n.Node] [192.168.1.133] stopping ... [2017-02-23T09:12:55,482][INFO][o.e.n.Node] [192.168.1.133] stopped [2017-02-23T09:12:55,482][INFO][o.e.n.Node] [192.168.1.133] closing ... [2017-02-23T09:12:55,514][INFO][o.e.n.Node] [192.168.1.133] closed

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [February 23, 2017, 4:34am UTC](https://discuss.elastic.co/t/getting-issue-while-configuring-elasticsearch-in-clustered-mode/76143/2 "2017-02-23T04:34:44Z")

</div>

> [@abhishek\_chordia](#):
>
> [2017-02-23T09:12:55,433][INFO][o.e.b.BootstrapChecks] [192.168.1.133] bound or publishing to a non-loopback or non-link-local address, enforcing bootstrap checks[2017-02-23T09:12:55,436][ERROR][o.e.b.Bootstrap] [192.168.1.133] node validation exceptionbootstrap checks failedsystem call filters failed to install; check the logs and fix your configuration or disable system call filters at your own risk

That's why.

> **[Bootstrap Checks | Elasticsearch Guide \[5.2\] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/5.2/bootstrap-checks.html)**

---

<div class="post-metadata">

**Author:** ![abhishek\_chordia](https://avatars.discourse-cdn.com/v4/letter/a/7cd45c/32.png) [@abhishek\_chordia](https://discuss.elastic.co/u/abhishek_chordia)\
**Post date:** [February 23, 2017, 5:22am UTC](https://discuss.elastic.co/t/getting-issue-while-configuring-elasticsearch-in-clustered-mode/76143/3 "2017-02-23T05:22:02Z")

</div>

Still i am not able to trace the required changes from the link shared, can you please help me out to get this issue resolved.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 23, 2017, 5:22am UTC](https://discuss.elastic.co/t/getting-issue-while-configuring-elasticsearch-in-clustered-mode/76143/4 "2017-03-23T05:22:02Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
