# Getting no error but data not saved in ES

**URL:** <https://discuss.elastic.co/t/getting-no-error-but-data-not-saved-in-es/298905>\
**Category:** Logstash\
**Created:** [March 6, 2022, 7:24am UTC](https://discuss.elastic.co/t/getting-no-error-but-data-not-saved-in-es/298905 "2022-03-06T07:24:46Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![AkAmit](https://avatars.discourse-cdn.com/v4/letter/a/bbe5ce/32.png) [@AkAmit](https://discuss.elastic.co/u/AkAmit)\
**Post date:** [March 6, 2022, 7:24am UTC](https://discuss.elastic.co/t/getting-no-error-but-data-not-saved-in-es/298905/1 "2022-03-06T07:24:46Z")

</div>

Using bundled JDK: /usr/share/logstash/jdk  
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.  
Sending Logstash logs to /var/log/logstash which is now configured via log4j2.properties  
[2022-03-06T12:43:00,881][INFO][logstash.runner] Log4j configuration path used is: /etc/logstash/log4j2.properties  
[2022-03-06T12:43:00,888][INFO][logstash.runner] Starting Logstash {"logstash.version"=\>"7.17.1", "jruby.version"=\>"jruby 9.2.20.1 (2.5.8) 2021-11-30 2a2962fbd1 OpenJDK 64-Bit Server VM 11.0.13+8 on 11.0.13+8 +indy +jit [linux-x86\_64]"}  
[2022-03-06T12:43:00,889][INFO][logstash.runner] JVM bootstrap flags: [-Xms1g, -Xmx1g, -XX:+UseConcMarkSweepGC, -XX:CMSInitiatingOccupancyFraction=75, -XX:+UseCMSInitiatingOccupancyOnly, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djruby.compile.invokedynamic=true, -Djruby.jit.threshold=0, -Djruby.regexp.interruptible=true, -XX:+HeapDumpOnOutOfMemoryError, -Djava.security.egd=file:/dev/urandom, -Dlog4j2.isThreadContextMapInheritable=true]  
[2022-03-06T12:43:01,198][WARN][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified  
[2022-03-06T12:43:02,088][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600, :ssl\_enabled=\>false}  
[2022-03-06T12:43:02,981][INFO][org.reflections.Reflections] Reflections took 54 ms to scan 1 urls, producing 119 keys and 417 values  
[2022-03-06T12:43:03,925][INFO][logstash.outputs.Elasticsearch][main] New Elasticsearch output {:class=\>"LogStash::Outputs::Elasticsearch", :hosts=\>["[http://localhost:9200](http://localhost:9200)"]}  
[2022-03-06T12:43:04,192][INFO][logstash.outputs.Elasticsearch][main] Elasticsearch pool URLs updated {:changes=\>{:removed=\>, :added=\>[[http://localhost:9200/](http://localhost:9200/)]}}  
[2022-03-06T12:43:04,397][WARN][logstash.outputs.Elasticsearch][main] Restored connection to ES instance {:url=\>"[http://localhost:9200/](http://localhost:9200/)"}  
[2022-03-06T12:43:04,410][INFO][logstash.outputs.Elasticsearch][main] Elasticsearch version determined (7.16.1) {:es\_version=\>7}  
[2022-03-06T12:43:04,413][WARN][logstash.outputs.Elasticsearch][main] Detected a 6.x and above cluster: the `type` event field won't be used to determine the document \_type {:es\_version=\>7}  
[2022-03-06T12:43:04,472][INFO][logstash.outputs.Elasticsearch][main] Config is not compliant with data streams. `data_stream => auto` resolved to `false`  
[2022-03-06T12:43:04,474][INFO][logstash.outputs.Elasticsearch][main] Config is not compliant with data streams. `data_stream => auto` resolved to `false`  
[2022-03-06T12:43:04,507][INFO][logstash.outputs.Elasticsearch][main] Using a default mapping template {:es\_version=\>7, :ecs\_compatibility=\>:disabled}  
[2022-03-06T12:43:04,546][INFO][logstash.javapipeline][main] Starting pipeline {:pipeline\_id=\>"main", "pipeline.workers"=\>8, "pipeline.batch.size"=\>125, "pipeline.batch.delay"=\>50, "pipeline.max\_inflight"=\>1000, "pipeline.sources"=\>["/etc/logstash/conf.d/move.conf"], :thread=\>"#\<Thread:0x68fa838d run\>"}  
[2022-03-06T12:43:05,269][INFO][logstash.javapipeline][main] Pipeline Java execution initialization time {"seconds"=\>0.72}  
[2022-03-06T12:43:05,317][INFO][logstash.javapipeline][main] Pipeline started {"pipeline.id"=\>"main"}  
[2022-03-06T12:43:05,355][INFO][filewatch.observingtail][main][99e60a71cedf0040e21abb4a73441b94ba011664a30828fb5b69fc55409c372d] START, creating Discoverer, Watch with file and sincedb collections  
[2022-03-06T12:43:05,363][INFO][logstash.agent] Pipelines running {:count=\>1, :running\_pipelines=\>[:main], :non\_running\_pipelines=\>}

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 3, 2022, 7:25am UTC](https://discuss.elastic.co/t/getting-no-error-but-data-not-saved-in-es/298905/2 "2022-04-03T07:25:23Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
