# Getting Oracle Error while running Logstash on RHEL7.5

**URL:** <https://discuss.elastic.co/t/getting-oracle-error-while-running-logstash-on-rhel7-5/146380>\
**Category:** Logstash\
**Created:** [August 28, 2018, 2:45pm UTC](https://discuss.elastic.co/t/getting-oracle-error-while-running-logstash-on-rhel7-5/146380 "2018-08-28T14:45:52Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![AshwiniSharma](https://avatars.discourse-cdn.com/v4/letter/a/f9ae1b/32.png) [@AshwiniSharma](https://discuss.elastic.co/u/AshwiniSharma)\
**Post date:** [August 28, 2018, 2:45pm UTC](https://discuss.elastic.co/t/getting-oracle-error-while-running-logstash-on-rhel7-5/146380/1 "2018-08-28T14:45:52Z")

</div>

Hi,

I recently started using ELK. My configuration files were working correctly for logstash on windows setup. Now I have moved to RHEL7.5 and running the same setup but getting oracle error mentioned below:

[ERROR][logstash.inputs.jdbc] Unable to connect to database. Tried 1 times {:error\_message=\>"Java::JavaSql::SQLException: ORA-00604: error occurred at recursive SQL level 1\nORA-01882: timezone region not found\n"}

Tried with different DB setups, still same error.

The simplest config file I tried is as below:

input {  
jdbc {  
jdbc\_driver\_library =\> "/data/OJDBC-FULL/ojdbc7.jar"  
jdbc\_driver\_class =\> "Java::oracle.jdbc.driver.OracleDriver"  
jdbc\_connection\_string =\> "jdbc:oracle:thin:@IP:PORT/SERVICE"  
jdbc\_user =\> "xxxx"  
jdbc\_password =\> "xxxx"  
statement =\> "select \* from table\_name"  
schedule =\> "0 \* \* \* \*"  
}  
}  
output {  
elasticsearch {  
hosts =\> "localhost:9200"  
index =\> "callpattern-%{+YYYY.MM.dd}"  
document\_id =\> "%{id}"  
}  
stdout {  
codec =\> rubydebug  
}  
}

Have tried without index and host in output as well.  
The OS user is not root user. Is it necessary that OS user must be root or super user?  
Gone through lots of links but couldn't resolve the issue. Please help.

---

<div class="post-metadata">

**Author:** ![AshwiniSharma](https://avatars.discourse-cdn.com/v4/letter/a/f9ae1b/32.png) [@AshwiniSharma](https://discuss.elastic.co/u/AshwiniSharma)\
**Post date:** [August 29, 2018, 9:20am UTC](https://discuss.elastic.co/t/getting-oracle-error-while-running-logstash-on-rhel7-5/146380/2 "2018-08-29T09:20:32Z")

</div>

Solved.  
TZ variable was not set at Linux level. After setting variable it's working fine.  
To remove dependency on TZ, added "-Doracle.jdbc.timezoneAsRegion=false" in jvm.options file.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 26, 2018, 9:20am UTC](https://discuss.elastic.co/t/getting-oracle-error-while-running-logstash-on-rhel7-5/146380/3 "2018-09-26T09:20:35Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
