# Getting Session error on Kibana UI

**URL:** <https://discuss.elastic.co/t/getting-session-error-on-kibana-ui/385888>\
**Category:** Elasticsearch\
**Created:** [April 15, 2026, 5:21am UTC](https://discuss.elastic.co/t/getting-session-error-on-kibana-ui/385888 "2026-04-15T05:21:22Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![Cache\_Digitech](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cache_digitech/32/141393_2.png) [@Cache\_Digitech](https://discuss.elastic.co/u/Cache_Digitech)\
**Post date:** [April 15, 2026, 5:21am UTC](https://discuss.elastic.co/t/getting-session-error-on-kibana-ui/385888/1 "2026-04-15T05:21:22Z")

</div>

![image](https://us1.discourse-cdn.com/elastic/original/3X/f/1/f1f593602064802ee4993471159e92460029b958.png)

As shown in the screenshot , I’m having this issue . I tried a fresh installation and again after running for few days , I got this error again. I did some research and found that the roles for the kibana\_system user is removed automatically and can’t be assigned manually . I don’t know if this is the exact issue or something else .  
Please help me to resolve this error.

---

<div class="post-metadata">

**Author:** ![Cache\_Digitech](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cache_digitech/32/141393_2.png) [@Cache\_Digitech](https://discuss.elastic.co/u/Cache_Digitech)\
**Post date:** [April 15, 2026, 5:52am UTC](https://discuss.elastic.co/t/getting-session-error-on-kibana-ui/385888/2 "2026-04-15T05:52:11Z")

</div>

Now I got to know that it’s working on some laptops but not working on the others. I tried clearing the cache , changing the browsers and restarting the services . But the issue is persist for all laptops except a few.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [April 15, 2026, 8:46am UTC](https://discuss.elastic.co/t/getting-session-error-on-kibana-ui/385888/3 "2026-04-15T08:46:49Z")

</div>

8.11 is very old. Is there a chance that you can upgrade to at least **8.19.14** or better **9.3.3** version?

---

<div class="post-metadata">

**Author:** ![Cache\_Digitech](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cache_digitech/32/141393_2.png) [@Cache\_Digitech](https://discuss.elastic.co/u/Cache_Digitech)\
**Post date:** [April 15, 2026, 11:21am UTC](https://discuss.elastic.co/t/getting-session-error-on-kibana-ui/385888/4 "2026-04-15T11:21:38Z")

</div>

I upgraded it to latest version but still same issue . Actually I used this version because it is very stable and can be easily integrated with Wazuh.

---

<div class="post-metadata">

**Author:** ![Rios](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rios/32/95745_2.png) [@Rios](https://discuss.elastic.co/u/Rios)\
**Post date:** [April 15, 2026, 11:27am UTC](https://discuss.elastic.co/t/getting-session-error-on-kibana-ui/385888/5 "2026-04-15T11:27:49Z")

</div>

Is your network behind proxy or secure? Might be some CDN sites are blocked, which cause errors during loading/working Kibana.  
Start DevToolbar in your browser,vtrack what is happening with Kibana. Also make sure there is no errors in kibana.log

---

<div class="post-metadata">

**Author:** ![Cache\_Digitech](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cache_digitech/32/141393_2.png) [@Cache\_Digitech](https://discuss.elastic.co/u/Cache_Digitech)\
**Post date:** [April 16, 2026, 6:41am UTC](https://discuss.elastic.co/t/getting-session-error-on-kibana-ui/385888/6 "2026-04-16T06:41:06Z")

</div>

![image](https://us1.discourse-cdn.com/elastic/original/3X/6/e/6efa41bed2a3fae3dbd8f36977a82ed01e76e2e3.png)

No errors in kibana.log and no proxy is being used . And this is the error in Network Tab.  
But why is it working on some systems and not on others.

---

<div class="post-metadata">

**Author:** ![Tortoise](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tortoise/32/147587_2.png) [@Tortoise](https://discuss.elastic.co/u/Tortoise)\
**Post date:** [April 16, 2026, 6:54am UTC](https://discuss.elastic.co/t/getting-session-error-on-kibana-ui/385888/7 "2026-04-16T06:54:25Z")

</div>

Hello @Cache_Digitech

If the URL is accessible from some laptop & not accessible from others , this means the issue is not with Kibana (ELK) but from the host/laptop where the URL is not accessible.

Few options is to try accessing the URL in incognito mode, if issue still persists it needs to be reviewed any common ground with the users who are facing this issue & the users who are able to access it without any problem.

Thanks!!

---

<div class="post-metadata">

**Author:** ![Cache\_Digitech](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cache_digitech/32/141393_2.png) [@Cache\_Digitech](https://discuss.elastic.co/u/Cache_Digitech)\
**Post date:** [April 16, 2026, 7:00am UTC](https://discuss.elastic.co/t/getting-session-error-on-kibana-ui/385888/8 "2026-04-16T07:00:38Z")

</div>

Already tried everything but the issue is still persist. In some laptops it's treating this capabilities request not as api call because of no cookies. But don't know why , cookies issue before login

---

<div class="post-metadata">

**Author:** ![Rios](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rios/32/95745_2.png) [@Rios](https://discuss.elastic.co/u/Rios)\
**Post date:** [April 17, 2026, 3:20pm UTC](https://discuss.elastic.co/t/getting-session-error-on-kibana-ui/385888/9 "2026-04-17T15:20:34Z")

</div>

Why are you using HTTP, have you try to use only HTTP **S**?

Here is response from Google AI:

1. Common Scenarios

- **401 Unauthorized Errors:** Users often see `401 Unauthorized` in browser developer tools despite correct credentials. This happens because the [security level mismatch](https://github.com/istio/istio/discussions/51601) causes the browser to withhold necessary referrer information for authentication callbacks.
- **Integration Failures:** Applications like [Wazuh](https://groups.google.com/g/wazuh/c/IyjQff0N4vc) or JWT-based authentication may hang on "Loading Elastic" or fail to connect if the referrer policy is too strict or causing data loss between origins.

1. Troubleshooting & Fixes

- **Clear Browser Cache/Cookies:** As a first step, delete all stored cookies for the Kibana domain in your browser and reload.
- **Uniform HTTPS:** Ensure the entire communication chain (User -\> Proxy -\> Kibana -\> Elasticsearch) uses HTTPS to avoid protocol downgrades.
- **Kibana Configuration:** Check your `kibana.yml` for [CSP (Content Security Policy) settings](https://www.elastic.co/guide/en/kibana/8.19/settings.html). If you must change the policy, use the Kibana Guide to verify your `csp.strict` or `csp.rules` settings.
- **Reverse Proxy Adjustment:** If using Nginx or Istio, you may need to explicitly set the `Referrer-Policy` header to `strict-origin-when-cross-origin` or another [appropriate value](https://probely.com/vulnerabilities/insecure-referrer-policy/) to ensure headers are preserved while maintaining security.
