# Getting the error: Invalid config file (/usr/share/enterprise-search/config/enterprise-search.yml): The setting '#/ent\_search' contains additional properties \["auth"\] outside of the schema when none are allowed

**URL:** <https://discuss.elastic.co/t/getting-the-error-invalid-config-file-usr-share-enterprise-search-config-enterprise-search-yml-the-setting-ent-search-contains-additional-properties-auth-outside-of-the-schema-when-none-are-allowed/345191>\
**Category:** Elastic Search\
**Tags:** elastic-app-search\
**Created:** [October 17, 2023, 10:26am UTC](https://discuss.elastic.co/t/getting-the-error-invalid-config-file-usr-share-enterprise-search-config-enterprise-search-yml-the-setting-ent-search-contains-additional-properties-auth-outside-of-the-schema-when-none-are-allowed/345191 "2023-10-17T10:26:53Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![shwetha\_L](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shwetha_l/32/126587_2.png) [@shwetha\_L](https://discuss.elastic.co/u/shwetha_L)\
**Post date:** [October 17, 2023, 10:26am UTC](https://discuss.elastic.co/t/getting-the-error-invalid-config-file-usr-share-enterprise-search-config-enterprise-search-yml-the-setting-ent-search-contains-additional-properties-auth-outside-of-the-schema-when-none-are-allowed/345191/1 "2023-10-17T10:26:53Z")

</div>

I am trying to deploy Elastic Enterprise search on Azure Kubernetes, i have followed [Quickstart | Elastic Cloud on Kubernetes [2.9] | Elastic](https://www.elastic.co/guide/en/cloud-on-k8s/current/k8s-enterprise-search-quickstart.html)

But getting the error:  
Invalid config file (/usr/share/enterprise-search/config/enterprise-search.yml):  
The setting '#/ent\_search' contains additional properties ["auth"] outside of the schema when none are allowed

---

<div class="post-metadata">

**Author:** ![carly.richmond](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/carly.richmond/32/104935_2.png) [@carly.richmond](https://discuss.elastic.co/u/carly.richmond)\
**Post date:** [October 19, 2023, 9:04am UTC](https://discuss.elastic.co/t/getting-the-error-invalid-config-file-usr-share-enterprise-search-config-enterprise-search-yml-the-setting-ent-search-contains-additional-properties-auth-outside-of-the-schema-when-none-are-allowed/345191/2 "2023-10-19T09:04:33Z")

</div>

Hi @shwetha_L,

Welcome to the community! It looks like a configuration issue. Can you share your config for us to take a look?

---

<div class="post-metadata">

**Author:** ![shwetha\_L](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shwetha_l/32/126587_2.png) [@shwetha\_L](https://discuss.elastic.co/u/shwetha_L)\
**Post date:** [October 23, 2023, 12:42pm UTC](https://discuss.elastic.co/t/getting-the-error-invalid-config-file-usr-share-enterprise-search-config-enterprise-search-yml-the-setting-ent-search-contains-additional-properties-auth-outside-of-the-schema-when-none-are-allowed/345191/3 "2023-10-23T12:42:38Z")

</div>

hello Carly,

I am using the default YAML mentioned on the elastic config:  
however, I understood the problem is that in 8.10 enterprise search version, the Cnfiguration is deprecated.  
"The setting '#/ent\_search/auth/source' is deprecated and will be removed in version '8.0.0'. Please use the new auth config format ent\_search.auth.\<auth\_name\>.source." but no where what is the new configuration to be provided is documented. kindly help me on this, as I am setting up this in Azure Kuberentes on my own.

## apiVersion: [enterprisesearch.k8s.elastic.co/v1](http://enterprisesearch.k8s.elastic.co/v1) kind: EnterpriseSearch metadata: name: enterprise-search namespace: sb-elastic spec: version: 8.10.3 count: 1 elasticsearchRef: name: elasticsearch namespace: sb-elastic

## apiVersion: [kibana.k8s.elastic.co/v1](http://kibana.k8s.elastic.co/v1) kind: Kibana metadata: name: kibana namespace: sb-elastic spec: version: 8.10.3 count: 1 elasticsearchRef: name: elasticsearch namespace: sb-elastic http: tls: certificate: secretName: elastic-ssl-kib service: spec: type: LoadBalancer config: xpack.monitoring.kibana.collection.enabled: false xpack.monitoring.collection.enabled: true podTemplate: spec: containers: - name: kibana resources: requests: memory: 2Gi cpu: 1 limits: memory: 2Gi cpu: 1

---

<div class="post-metadata">

**Author:** ![carly.richmond](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/carly.richmond/32/104935_2.png) [@carly.richmond](https://discuss.elastic.co/u/carly.richmond)\
**Post date:** [October 24, 2023, 9:55am UTC](https://discuss.elastic.co/t/getting-the-error-invalid-config-file-usr-share-enterprise-search-config-enterprise-search-yml-the-setting-ent-search-contains-additional-properties-auth-outside-of-the-schema-when-none-are-allowed/345191/4 "2023-10-24T09:55:46Z")

</div>

Hi @shwetha_L,

It sounds like your issue hasn't been resolved so I've removed the solution indicator.

I don't see the deprecated settings in your configuration. Can you share where those are, or confirm that you're not setting `ent_search.auth.<auth_name>.source` anywhere?

---

<div class="post-metadata">

**Author:** ![shwetha\_L](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shwetha_l/32/126587_2.png) [@shwetha\_L](https://discuss.elastic.co/u/shwetha_L)\
**Post date:** [October 25, 2023, 5:42am UTC](https://discuss.elastic.co/t/getting-the-error-invalid-config-file-usr-share-enterprise-search-config-enterprise-search-yml-the-setting-ent-search-contains-additional-properties-auth-outside-of-the-schema-when-none-are-allowed/345191/5 "2023-10-25T05:42:40Z")

</div>

hello Carly,

As per the elastic document, yes I am no where setting " ent\_search.auth.\<auth\_name\>.source" in the yaml file

## apiVersion: [enterprisesearch.k8s.elastic.co/v1](http://enterprisesearch.k8s.elastic.co/v1)

kind: EnterpriseSearch  
metadata:  
name: enterprise-search  
namespace: sb-elastic  
spec:  
version: 8.10.3  
count: 1  
elasticsearchRef:  
name: elasticsearch  
namespace: sb-elastic

---

<div class="post-metadata">

**Author:** ![shwetha\_L](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shwetha_l/32/126587_2.png) [@shwetha\_L](https://discuss.elastic.co/u/shwetha_L)\
**Post date:** [November 2, 2023, 6:22am UTC](https://discuss.elastic.co/t/getting-the-error-invalid-config-file-usr-share-enterprise-search-config-enterprise-search-yml-the-setting-ent-search-contains-additional-properties-auth-outside-of-the-schema-when-none-are-allowed/345191/6 "2023-11-02T06:22:16Z")

</div>

Hello Carly,

we havent got any response, please help us on this.

---

<div class="post-metadata">

**Author:** ![PRASHANT\_MEHTA](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/prashant_mehta/32/101764_2.png) [@PRASHANT\_MEHTA](https://discuss.elastic.co/u/PRASHANT_MEHTA)\
**Post date:** [November 2, 2023, 10:17am UTC](https://discuss.elastic.co/t/getting-the-error-invalid-config-file-usr-share-enterprise-search-config-enterprise-search-yml-the-setting-ent-search-contains-additional-properties-auth-outside-of-the-schema-when-none-are-allowed/345191/7 "2023-11-02T10:17:56Z")

</div>

> [@shwetha\_L](#):
>
> ## apiVersion: [enterprisesearch.k8s.elastic.co/v1](http://enterprisesearch.k8s.elastic.co/v1)
> 
> kind: EnterpriseSearch  
> metadata:  
> name: enterprise-search  
> namespace: sb-elastic  
> spec:  
> version: 8.10.3  
> count: 1  
> elasticsearchRef:  
> name: elasticsearch  
> namespace: sb-elastic
> 
> ## apiVersion: [kibana.k8s.elastic.co/v1](http://kibana.k8s.elastic.co/v1)
> 
> kind: Kibana  
> metadata:  
> name: kibana  
> namespace: sb-elastic  
> spec:  
> version: 8.10.3  
> count: 1  
> elasticsearchRef:  
> name: elasticsearch  
> namespace: sb-elastic  
> http:  
> tls:  
> certificate:  
> secretName: elastic-ssl-kib  
> service:  
> spec:  
> type: LoadBalancer  
> config:  
> xpack.monitoring.kibana.collection.enabled: false  
> xpack.monitoring.collection.enabled: true  
> podTemplate:  
> spec:  
> containers:
> 
> - name: kibana  
> resources:  
> requests:  
> memory: 2Gi  
> cpu: 1  
> limits:  
> memory: 2Gi  
> cpu: 1

Small observation if this hepls:

Based on the yaml you've provided, I see that you've defined resources for a Kibana instance, but there is no direct mention of Enterprise Search configuration or authentication settings. The error message indicates that the problem lies in the `enterprise-search.yml` file, which you haven't included here.

To resolve this issue, you should check the `enterprise-search.yml` configuration file, specifically the `auth` setting

It seems like you've tried to configure an authentication setting under "auth" in your YAML file, but the schema doesn't allow for additional properties under "#/ent\_search"

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 30, 2023, 10:18am UTC](https://discuss.elastic.co/t/getting-the-error-invalid-config-file-usr-share-enterprise-search-config-enterprise-search-yml-the-setting-ent-search-contains-additional-properties-auth-outside-of-the-schema-when-none-are-allowed/345191/8 "2023-11-30T10:18:11Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
