# Getting"Timeout" error while making kibana to work with SearchGuard

**URL:** <https://discuss.elastic.co/t/getting-timeout-error-while-making-kibana-to-work-with-searchguard/36844>\
**Category:** Elasticsearch\
**Created:** [December 10, 2015, 8:12am UTC](https://discuss.elastic.co/t/getting-timeout-error-while-making-kibana-to-work-with-searchguard/36844 "2015-12-10T08:12:03Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![balubollam](https://avatars.discourse-cdn.com/v4/letter/b/a587f6/32.png) [@balubollam](https://discuss.elastic.co/u/balubollam)\
**Post date:** [December 10, 2015, 8:12am UTC](https://discuss.elastic.co/t/getting-timeout-error-while-making-kibana-to-work-with-searchguard/36844/1 "2015-12-10T08:12:03Z")

</div>

```
      Hi Everyone

```

I Have Implemented “search-guard” Elasticsearch

--\>

First i have created a “SearchGuard” Index

\*Then I have Installed and Configured it in logging.yml and Elasticsearch.yml

\*In elasticsearch.yml i have given a user name:admin and password:admin

note:I have given all permissions to admin user in “searchguard” index

\*HERE is my index

curl -XPUT '[http://localhost:9200/searchguard/ac/ac](http://localhost:9200/searchguard/ac/ac)' -d '{

```
"acl": [

{

    "Comment": "By default no filters are executed 

```

and no filters a by-passed. In such a case an exception is thrown and  
access will be denied.",

```
    "filters_bypass": [],

    "filters_execute": []

 },

 {

       "Comment": "For role admin all filters are bypassed (so none will be executed). This means unrestricted access.",

       "roles": [

           "admin"

       ],

       "filters_bypass": [],

       "filters_execute": [“actionrequestfilter.kibanaUser”]

 }

 ]

```

}'

\*Here is my elasticsearch.yml

searchguard.enabled: true

searchguard.rewrite\_get\_as\_search: true

searchguard.allow\_all\_from\_loopback: true

searchguard.config\_index\_name: searchguard

searchguard.key\_path: /var/lib/elasticsearch/searchguard\_node.key

##User settings

searchguard.authentication.settingsdb.user.admin: admin

searchguard.actionrequestfilter.names: ["kibanaUser","admincopy"]

searchguard.actionrequestfilter.kibanaUser.allowed\_actions:["indices:admin/get","indices:data/read/", "monitor"]

---\>Here iam getting “timeout” Error.

As i am new to this concept.Not getting.Please someone help me out in this??

Thanks And Regards

Balaji

---

<div class="post-metadata">

**Author:** ![bleskes](https://avatars.discourse-cdn.com/v4/letter/b/71c47a/32.png) [@bleskes](https://discuss.elastic.co/u/bleskes)\
**Post date:** [December 10, 2015, 2:39pm UTC](https://discuss.elastic.co/t/getting-timeout-error-while-making-kibana-to-work-with-searchguard/36844/2 "2015-12-10T14:39:30Z")

</div>

Are you using Shield to secure your cluster or something else?

---

<div class="post-metadata">

**Author:** ![balubollam](https://avatars.discourse-cdn.com/v4/letter/b/a587f6/32.png) [@balubollam](https://discuss.elastic.co/u/balubollam)\
**Post date:** [December 11, 2015, 5:38am UTC](https://discuss.elastic.co/t/getting-timeout-error-while-making-kibana-to-work-with-searchguard/36844/3 "2015-12-11T05:38:18Z")

</div>

No i am using Search-guard elasticsearch. That previous issue is solved by adding the "searchguard.allow\_all\_from\_loopback: true" attribute to the elasticsearch.yml file ....But Now unable to use search-guard with kibana. I have edited the above Issue ...Can u please see that and Help me out

Thanks and Regards  
Balaji

---

<div class="post-metadata">

**Author:** ![bleskes](https://avatars.discourse-cdn.com/v4/letter/b/71c47a/32.png) [@bleskes](https://discuss.elastic.co/u/bleskes)\
**Post date:** [December 11, 2015, 10:46am UTC](https://discuss.elastic.co/t/getting-timeout-error-while-making-kibana-to-work-with-searchguard/36844/4 "2015-12-11T10:46:26Z")

</div>

oh, I see. I don't know Search guard. Sorry.

---

<div class="post-metadata">

**Author:** ![mohan\_pusarla](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mohan_pusarla/32/6585_2.png) [@mohan\_pusarla](https://discuss.elastic.co/u/mohan_pusarla)\
**Post date:** [December 22, 2015, 9:37pm UTC](https://discuss.elastic.co/t/getting-timeout-error-while-making-kibana-to-work-with-searchguard/36844/5 "2015-12-22T21:37:24Z")

</div>

Just want to check did you added the username and password in the kibana settings?

---

<div class="post-metadata">

**Author:** ![balubollam](https://avatars.discourse-cdn.com/v4/letter/b/a587f6/32.png) [@balubollam](https://discuss.elastic.co/u/balubollam)\
**Post date:** [December 24, 2015, 1:10pm UTC](https://discuss.elastic.co/t/getting-timeout-error-while-making-kibana-to-work-with-searchguard/36844/6 "2015-12-24T13:10:33Z")

</div>

yes.Actually i didt map that user to the elasticsearch.yml. now after mapping the issue is solved.

But kibana is not accepting this default configuration  
"filters\_bypass": [],  
"filters\_execute": []

so when i change the above code getting internal server error

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 11:28pm UTC](https://discuss.elastic.co/t/getting-timeout-error-while-making-kibana-to-work-with-searchguard/36844/7 "2017-07-05T23:28:50Z")

</div>


