# Got error 503 in dev tool

**URL:** <https://discuss.elastic.co/t/got-error-503-in-dev-tool/87390>\
**Category:** Kibana\
**Created:** [May 29, 2017, 4:06am UTC](https://discuss.elastic.co/t/got-error-503-in-dev-tool/87390 "2017-05-29T04:06:35Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![tatdat](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tatdat/32/113160_2.png) [@tatdat](https://discuss.elastic.co/u/tatdat)\
**Post date:** [May 29, 2017, 4:06am UTC](https://discuss.elastic.co/t/got-error-503-in-dev-tool/87390/1 "2017-05-29T04:06:35Z")

</div>

Hi, im using ES, kibana, LS version 5.4.0. Im testing with xpack, setup ssl.  
I got error 503 when use DEV\_TOOL in kibana.  
Another function and app in kibana is working well.

 ![](https://us1.discourse-cdn.com/elastic/original/3X/1/d/1d4d9443942f1227dfd6d5ed041eff46a56c5303.png)

Here is my config in ES.

```
http.port: 9200
http.cors.allow-origin: "/.*/"
http.cors.enabled: true
http.cors.allow-headers: X-Requested-With,X-Auth-Token,Content-Type, Content-Length, Authorization
http.cors.allow-credentials: true

xpack.ssl.key: /etc/elasticsearch/x-pack/elastic-01.key
xpack.ssl.certificate: /etc/elasticsearch/x-pack/elastic-01.crt
xpack.ssl.certificate_authorities: ["/etc/elasticsearch/x-pack/ca.crt"]
xpack.security.transport.ssl.enabled: true
xpack.security.http.ssl.enabled: true
```

---

<div class="post-metadata">

**Author:** ![tylersmalley](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tylersmalley/32/8833_2.png) [@tylersmalley](https://discuss.elastic.co/u/tylersmalley)\
**Post date:** [May 30, 2017, 3:55am UTC](https://discuss.elastic.co/t/got-error-503-in-dev-tool/87390/2 "2017-05-30T03:55:40Z")

</div>

What does your configuration look like in Kibana?

There was [this issue](https://github.com/elastic/kibana/issues/8932), but that should have been resolved in 5.3 with [#9823](https://github.com/elastic/kibana/pull/9823).

Are you self-signing the certificates?

---

<div class="post-metadata">

**Author:** ![tatdat](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tatdat/32/113160_2.png) [@tatdat](https://discuss.elastic.co/u/tatdat)\
**Post date:** [May 31, 2017, 3:45am UTC](https://discuss.elastic.co/t/got-error-503-in-dev-tool/87390/3 "2017-05-31T03:45:39Z")

</div>

Hi @tsmalley, here is my kibana config

```
server.port: 443
server.host: "my-ip"

server.name: "my.domain"
elasticsearch.url: "https://my-ip:9200"

kibana.defaultAppId: "dashboard"

elasticsearch.username: "elastic"
elasticsearch.password: "mypassword"

server.ssl.certificate: /etc/ssl/certs/server.crt
server.ssl.key: /etc/ssl/certs/server.key

elasticsearch.ssl.certificate: /etc/elasticsearch/x-pack/elastic-01.crt
elasticsearch.ssl.key: /etc/elasticsearch/x-pack/elastic-01.key

elasticsearch.ssl.certificateAuthorities: ["/etc/elasticsearch/x-pack/ca.crt"]

elasticsearch.ssl.verificationMode: none

xpack.security.encryptionKey: "my-encrykey"
xpack.reporting.encryptionKey: "my-encrykey"
xpack.reporting.queue.timeout: 300000
xpack.reporting.capture.timeout: 300000
tilemap:
  url: "https://tiles.elastic.co/v2/default/{z}/{x}/{y}.png?elastic_tile_service_tos=agree&my_app_name=kibana"
  options:
    minZoom: 1
    maxZoom: 10
    attribution: "© [Elastic Tile Service](https://www.elastic.co/elastic-tile-service)" 

```

> Are you self-signing the certificates?

Sure, i generated certificate follow guide [https://www.elastic.co/guide/en/x-pack/current/ssl-tls.html](https://www.elastic.co/guide/en/x-pack/current/ssl-tls.html)

And ssl for kibana, i bought certificate from geotrust

---

<div class="post-metadata">

**Author:** ![tatdat](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tatdat/32/113160_2.png) [@tatdat](https://discuss.elastic.co/u/tatdat)\
**Post date:** [June 5, 2017, 8:05am UTC](https://discuss.elastic.co/t/got-error-503-in-dev-tool/87390/4 "2017-06-05T08:05:47Z")

</div>

anyone help me ? ☹

---

<div class="post-metadata">

**Author:** ![tylersmalley](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tylersmalley/32/8833_2.png) [@tylersmalley](https://discuss.elastic.co/u/tylersmalley)\
**Post date:** [June 5, 2017, 4:38pm UTC](https://discuss.elastic.co/t/got-error-503-in-dev-tool/87390/5 "2017-06-05T16:38:46Z")

</div>

This was resolved in v5.4.1

---

<div class="post-metadata">

**Author:** ![tylersmalley](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tylersmalley/32/8833_2.png) [@tylersmalley](https://discuss.elastic.co/u/tylersmalley)\
**Post date:** [June 5, 2017, 4:39pm UTC](https://discuss.elastic.co/t/got-error-503-in-dev-tool/87390/6 "2017-06-05T16:39:47Z")

</div>

There is the associated PR: [https://github.com/elastic/kibana/pull/11700](https://github.com/elastic/kibana/pull/11700)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 3, 2017, 4:40pm UTC](https://discuss.elastic.co/t/got-error-503-in-dev-tool/87390/7 "2017-07-03T16:40:03Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
