# Harvester could not be started on new file & registry already stopped

**URL:** <https://discuss.elastic.co/t/harvester-could-not-be-started-on-new-file-registry-already-stopped/281444>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [August 14, 2021, 2:50pm UTC](https://discuss.elastic.co/t/harvester-could-not-be-started-on-new-file-registry-already-stopped/281444 "2021-08-14T14:50:56Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![bhavaniprasad\_reddy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bhavaniprasad_reddy/32/52086_2.png) [@bhavaniprasad\_reddy](https://discuss.elastic.co/u/bhavaniprasad_reddy)\
**Post date:** [August 14, 2021, 2:50pm UTC](https://discuss.elastic.co/t/harvester-could-not-be-started-on-new-file-registry-already-stopped/281444/1 "2021-08-14T14:50:56Z")

</div>

I am using filebeat-oss v7.12.0 in order to collect events from kubernetes pods using autodiscover.

It is expected to collect 5450 events from 5450 pods but fails to harvest for 150 pods and contains the following error in the logs,

```auto
FFAAAP-23-QA-3818 - 2021-08-11T20:48:49.592Z ERROR log/input.go:519 Harvester could not be started on new file: /var/log/containers/1628714791414-ne-ops-ne-backup-1628714791414-4lw6l_task-execution_tes-job-ctr-ffaaap23qa3818-1628714792064-a7080587d041af6298ba0b8da41dd423b964cedc252f5b7fa712de8dccecc528.log, Err: registry already stopped

```

I have gone through filebeat registry documentation but could not be able to find any parameters to avoid the registry from being stopped.

I came across "ignore\_older", "clean\_inactive" and "clean\_removed" to clean files from registry, but not sure if they can minimize this issue.

Please help me in finding the cause for this issue along with a solution/workaround.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 11, 2021, 4:51pm UTC](https://discuss.elastic.co/t/harvester-could-not-be-started-on-new-file-registry-already-stopped/281444/2 "2021-09-11T16:51:17Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
