# Harvester doesnt read file

**URL:** <https://discuss.elastic.co/t/harvester-doesnt-read-file/104783>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [October 21, 2017, 10:25pm UTC](https://discuss.elastic.co/t/harvester-doesnt-read-file/104783 "2017-10-21T22:25:33Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![janko.sarmir](https://avatars.discourse-cdn.com/v4/letter/j/71c47a/32.png) [@janko.sarmir](https://discuss.elastic.co/u/janko.sarmir)\
**Post date:** [October 21, 2017, 10:25pm UTC](https://discuss.elastic.co/t/harvester-doesnt-read-file/104783/1 "2017-10-21T22:25:33Z")

</div>

I have this configuration (v 5.x)

- input\_type: log  
document\_type: nginx.error  
paths:
  - /var/log/nginx/error\*.log\*
  - /var/www/urba/var/logs/nginx\_error.log;  
exclude\_files: [".gz$"]

first rule of paths finds all files and harvests correctly  
second rule doesnt start harvester even file exists and is updated  
i cannot figure out, why its not reading

---

<div class="post-metadata">

**Author:** ![janko.sarmir](https://avatars.discourse-cdn.com/v4/letter/j/71c47a/32.png) [@janko.sarmir](https://discuss.elastic.co/u/janko.sarmir)\
**Post date:** [October 22, 2017, 2:42am UTC](https://discuss.elastic.co/t/harvester-doesnt-read-file/104783/2 "2017-10-22T02:42:06Z")

</div>

solved  
after spending many hours debugging and reading docs, i found a typo ";"  
i can enhance it in this format, cool

/var/www/\*/var/logs/nginx\_error.log

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 19, 2017, 2:42am UTC](https://discuss.elastic.co/t/harvester-doesnt-read-file/104783/3 "2017-11-19T02:42:11Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
