# Has\_child query returns parsing exception

**URL:** <https://discuss.elastic.co/t/has-child-query-returns-parsing-exception/129881>\
**Category:** Elasticsearch\
**Created:** [April 27, 2018, 7:41pm UTC](https://discuss.elastic.co/t/has-child-query-returns-parsing-exception/129881 "2018-04-27T19:41:18Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![maw65](https://avatars.discourse-cdn.com/v4/letter/m/e480ec/32.png) [@maw65](https://discuss.elastic.co/u/maw65)\
**Post date:** [April 27, 2018, 7:41pm UTC](https://discuss.elastic.co/t/has-child-query-returns-parsing-exception/129881/1 "2018-04-27T19:41:18Z")

</div>

Hi, When sending a **has\_child** query to ES5.6.8 I get the following parsing exception

_{"error":{"root\_cause":[{"type":"parsing\_exception","reason":"no [query] registered for [has\_child]","line":4,"col":22}],"type":"parsing\_exception","reason":"no [query] registered for [has\_child]","line":4,"col":22},"status":400}_

This happens when running ES in embedded mode. It seems like only the **has\_child** and **has\_parent** queries are failing.

I'm not seeing anything helpful in the log file either.

---

<div class="post-metadata">

**Author:** ![Glen\_Smith](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/glen_smith/32/111656_2.png) [@Glen\_Smith](https://discuss.elastic.co/u/Glen_Smith)\
**Post date:** [May 5, 2018, 5:36am UTC](https://discuss.elastic.co/t/has-child-query-returns-parsing-exception/129881/2 "2018-05-05T05:36:08Z")

</div>

The best way to determine the cause of this would be to look at the actual query that provoke the error. Can you share that?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 2, 2018, 5:36am UTC](https://discuss.elastic.co/t/has-child-query-returns-parsing-exception/129881/3 "2018-06-02T05:36:12Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
