# Having issues setting up MetricBeat with cloud

**URL:** <https://discuss.elastic.co/t/having-issues-setting-up-metricbeat-with-cloud/132114>\
**Category:** Beats\
**Tags:** metricbeat\
**Created:** [May 16, 2018, 11:56am UTC](https://discuss.elastic.co/t/having-issues-setting-up-metricbeat-with-cloud/132114 "2018-05-16T11:56:10Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![stunthamster](https://avatars.discourse-cdn.com/v4/letter/s/ea666f/32.png) [@stunthamster](https://discuss.elastic.co/u/stunthamster)\
**Post date:** [May 16, 2018, 11:56am UTC](https://discuss.elastic.co/t/having-issues-setting-up-metricbeat-with-cloud/132114/1 "2018-05-16T11:56:11Z")

</div>

Hi Folks;

I'm trying to deploy Metricbeats onto a Windows host - this will then talk to our ElasticCloud account. Right now my elastic.yml looks like this:

```
metricbeat.config.modules:
  path: ${path.config}/modules.d/*.yml
  reload.enabled: false
setup.template.settings:
  index.number_of_shards: 1
  index.codec: best_compression
  #_source.enabled: false

tags: ["development", "windows"]

setup.kibana:
  cloud_id: <snip>"
  cloud_auth: "<snip"

output.elasticsearch:
  hosts: ["localhost:9200"]

```

However, I'm not seeing Metrics arrive on the cloud. When I start in on the command line (Simply with a metricbeat.exe) I get the following error:

```
2018-05-16T12:02:50.883+0100	ERROR	pipeline/output.go:74	Failed to connect: Get http://localhost:9200: dial tcp 127.0.0.1:9200: connectex: No connection could be made because the target machine actively refused it.

```

Any ideas where I'm going wrong? I'd assume that by supplying the cloud credentials in the config it'd override the output, and that's certainly the case on my Linux hosts..

Cheers;

Mike

---

<div class="post-metadata">

**Author:** ![andrewkroh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrewkroh/32/3784_2.png) [@andrewkroh](https://discuss.elastic.co/u/andrewkroh)\
**Post date:** [May 16, 2018, 1:00pm UTC](https://discuss.elastic.co/t/having-issues-setting-up-metricbeat-with-cloud/132114/2 "2018-05-16T13:00:18Z")

</div>

Based on the example show [here](https://www.elastic.co/guide/en/beats/metricbeat/6.2/configure-cloud-id.html#configure-cloud-id) I think your config should look like this:

```auto
metricbeat.config.modules:
  path: ${path.config}/modules.d/*.yml
  reload.enabled: false
setup.template.settings:
  index.number_of_shards: 1
  index.codec: best_compression
  #_source.enabled: false

tags: ["development", "windows"]

cloud.id: "blah"
cloud.auth: "elastic:YOUR_PASSWORD"

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 13, 2018, 1:00pm UTC](https://discuss.elastic.co/t/having-issues-setting-up-metricbeat-with-cloud/132114/3 "2018-06-13T13:00:24Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
