# Having log error while trying to install pega 8.5 on kubernetes cluster

**URL:** <https://discuss.elastic.co/t/having-log-error-while-trying-to-install-pega-8-5-on-kubernetes-cluster/346943>\
**Category:** Elasticsearch\
**Created:** [November 13, 2023, 4:58am UTC](https://discuss.elastic.co/t/having-log-error-while-trying-to-install-pega-8-5-on-kubernetes-cluster/346943 "2023-11-13T04:58:52Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![musheer](https://avatars.discourse-cdn.com/v4/letter/m/90ced4/32.png) [@musheer](https://discuss.elastic.co/u/musheer)\
**Post date:** [November 13, 2023, 4:58am UTC](https://discuss.elastic.co/t/having-log-error-while-trying-to-install-pega-8-5-on-kubernetes-cluster/346943/1 "2023-11-13T04:58:52Z")

</div>

Hi,  
when i installed pega 8.5 on kubernetes cluster ,the pod of pega search was in pending state and i checked the logs and got following error .Need to solve this issue as soon as possible.Please help

ERROR:  
kubectl logs -f pega-search-0 -n newpega

'Defaulted container "search" out of: search, set-max-map-count (init)  
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.  
[2023-11-09T06:21:18,642][INFO][o.e.n.Node] initializing ...  
[2023-11-09T06:21:18,661][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] uncaught exception in thread [main]  
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalStateException: Failed to create node environment  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:136) ~[elasticsearch-5.6.14.jar:5.6.14]  
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:123) ~[elasticsearch-5.6.14.jar:5.6.14]  
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:70) ~[elasticsearch-5.6.14.jar:5.6.14]  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:134) ~[elasticsearch-5.6.14.jar:5.6.14]  
at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-5.6.14.jar:5.6.14]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91) ~[elasticsearch-5.6.14.jar:5.6.14]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84) ~[elasticsearch-5.6.14.jar:5.6.14]  
Caused by: java.lang.IllegalStateException: Failed to create node environment  
at org.elasticsearch.node.Node.(Node.java:268) ~[elasticsearch-5.6.14.jar:5.6.14]  
at org.elasticsearch.node.Node.(Node.java:245) ~[elasticsearch-5.6.14.jar:5.6.14]  
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:233) ~[elasticsearch-5.6.14.jar:5.6.14]  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:233) ~[elasticsearch-5.6.14.jar:5.6.14]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:342) ~[elasticsearch-5.6.14.jar:5.6.14]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:132) ~[elasticsearch-5.6.14.jar:5.6.14]  
... 6 more  
Caused by: java.nio.file.AccessDeniedException: /usr/share/elasticsearch/data/nodes  
at sun.nio.fs.UnixException.translateToIOException(UnixException.java:90) ~[?:?]  
at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:111) ~[?:?]  
at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:116) ~[?:?]  
at sun.nio.fs.UnixFileSystemProvider.createDirectory(UnixFileSystemProvider.java:389) ~[?:?]  
at java.nio.file.Files.createDirectory(Files.java:690) ~[?:?]  
at java.nio.file.Files.createAndCheckIsDirectory(Files.java:797) ~[?:?]  
at java.nio.file.Files.createDirectories(Files.java:783) ~[?:?]  
at org.elasticsearch.env.NodeEnvironment.(NodeEnvironment.java:225) ~[elasticsearch-5.6.14.jar:5.6.14]  
at org.elasticsearch.node.Node.(Node.java:265) ~[elasticsearch-5.6.14.jar:5.6.14]  
at org.elasticsearch.node.Node.(Node.java:245) ~[elasticsearch-5.6.14.jar:5.6.14]  
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:233) ~[elasticsearch-5.6.14.jar:5.6.14]  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:233) ~[elasticsearch-5.6.14.jar:5.6.14]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:342) ~[elasticsearch-5.6.14.jar:5.6.14]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:132) ~[elasticsearch-5.6.14.jar:5.6.14]  
... 6 more'

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [November 13, 2023, 5:12am UTC](https://discuss.elastic.co/t/having-log-error-while-trying-to-install-pega-8-5-on-kubernetes-cluster/346943/2 "2023-11-13T05:12:39Z")

</div>

Welcome!

Please don't post unformatted code, logs, or configuration as it's very hard to read.

Instead, paste the text and format it with \</\> icon or pairs of triple backticks (```), and check the preview window to make sure it's properly formatted before posting it. This makes it more likely that your question will receive a useful answer.

I don't know what Pega is but you should not start a project or use anymore Elasticsearch 5 which is not supported.

The latest version is 8.11.0.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 11, 2023, 5:13am UTC](https://discuss.elastic.co/t/having-log-error-while-trying-to-install-pega-8-5-on-kubernetes-cluster/346943/3 "2023-12-11T05:13:37Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
