# Head & KOPF Plugin

**URL:** <https://discuss.elastic.co/t/head-kopf-plugin/198583>\
**Category:** Elasticsearch\
**Created:** [September 8, 2019, 10:24pm UTC](https://discuss.elastic.co/t/head-kopf-plugin/198583 "2019-09-08T22:24:33Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![tpngx](https://avatars.discourse-cdn.com/v4/letter/t/a6a055/32.png) [@tpngx](https://discuss.elastic.co/u/tpngx)\
**Post date:** [September 8, 2019, 10:24pm UTC](https://discuss.elastic.co/t/head-kopf-plugin/198583/1 "2019-09-08T22:24:33Z")

</div>

I've installed Elasticsearch 7.3 on a Ubuntu box with Kibana. Each time I run elastic I get this error, "[elasticsearch.version] is missing for plugin [head]". I had the same error for KOPF which lead down a rabbit hole of research stating use HEAD. I've been at this for days. I've tried installing plugins, and running command "./elasticsearch-plugin install elasticsearch-head" fails. If I'm to rely on Kibana as new version of elasticsearch don't need KOPF or HEAD, how do I remove the warnings or get past this.

---

<div class="post-metadata">

**Author:** ![tpngx](https://avatars.discourse-cdn.com/v4/letter/t/a6a055/32.png) [@tpngx](https://discuss.elastic.co/u/tpngx)\
**Post date:** [September 8, 2019, 11:29pm UTC](https://discuss.elastic.co/t/head-kopf-plugin/198583/2 "2019-09-08T23:29:34Z")

</div>

[2019-09-08T23:29:00,733][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] [ip-172-31-86-39] uncaught exception in thread [main]  
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalArgumentException: property [elasticsearch.version] is missing for plugin [head]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:163) ~[elasticsearch-7.3.1.jar:7.3.1]  
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:150) ~[elasticsearch-7.3.1.jar:7.3.1]  
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) ~[elasticsearch-7.3.1.jar:7.3.1]  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) ~[elasticsearch-cli-7.3.1.jar:7.3.1]  
at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-7.3.1.jar:7.3.1]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:115) ~[elasticsearch-7.3.1.jar:7.3.1]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) ~[elasticsearch-7.3.1.jar:7.3.1]  
Caused by: java.lang.IllegalArgumentException: property [elasticsearch.version] is missing for plugin [head]  
at org.elasticsearch.plugins.PluginInfo.readFromProperties(PluginInfo.java:180) ~[elasticsearch-7.3.1.jar:7.3.1]  
at org.elasticsearch.plugins.PluginsService.readPluginBundle(PluginsService.java:398) ~[elasticsearch-7.3.1.jar:7.3.1]  
at org.elasticsearch.plugins.PluginsService.findBundles(PluginsService.java:386) ~[elasticsearch-7.3.1.jar:7.3.1]  
at org.elasticsearch.plugins.PluginsService.getPluginBundles(PluginsService.java:379) ~[elasticsearch-7.3.1.jar:7.3.1]  
at org.elasticsearch.plugins.PluginsService.(PluginsService.java:151) ~[elasticsearch-7.3.1.jar:7.3.1]  
at org.elasticsearch.node.Node.(Node.java:314) ~[elasticsearch-7.3.1.jar:7.3.1]  
at org.elasticsearch.node.Node.(Node.java:258) ~[elasticsearch-7.3.1.jar:7.3.1]  
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:221) ~[elasticsearch-7.3.1.jar:7.3.1]  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:221) ~[elasticsearch-7.3.1.jar:7.3.1]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:349) ~[elasticsearch-7.3.1.jar:7.3.1]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) ~[elasticsearch-7.3.1.jar:7.3.1]  
... 6 more

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [September 9, 2019, 5:10am UTC](https://discuss.elastic.co/t/head-kopf-plugin/198583/3 "2019-09-09T05:10:05Z")

</div>

Head and Kopf were site plugins, and [support for that type of plugins were removed in version 5.0](https://www.elastic.co/guide/en/elasticsearch/reference/5.0/breaking_50_plugins.html#_site_plugins_removed). If they have been updated to work with Elasticsearch 7.x, you have to run them as a separate component outside Elasticsearch. Kibana should however contain most functionality they covered if you enable monitoring.

---

<div class="post-metadata">

**Author:** ![tpngx](https://avatars.discourse-cdn.com/v4/letter/t/a6a055/32.png) [@tpngx](https://discuss.elastic.co/u/tpngx)\
**Post date:** [September 13, 2019, 6:07am UTC](https://discuss.elastic.co/t/head-kopf-plugin/198583/4 "2019-09-13T06:07:21Z")

</div>

Ah thanks. I moved both HEAD and KOPF from the plugin folder and it appears that I can start Elastic without that specific error. Now once I navigate to the specified url after authenticating in kibana I have a message where the dashboard should be that states "Kibana server is not ready yet". Thoughts?

---

<div class="post-metadata">

**Author:** ![tpngx](https://avatars.discourse-cdn.com/v4/letter/t/a6a055/32.png) [@tpngx](https://discuss.elastic.co/u/tpngx)\
**Post date:** [September 13, 2019, 6:26am UTC](https://discuss.elastic.co/t/head-kopf-plugin/198583/5 "2019-09-13T06:26:53Z")

</div>

Made a bit more progress after researching the last error. Now I'm presented with the following below.... Thoughts?

Exception in thread "main" 2019-09-13 06:19:14,590 main ERROR No Log4j 2 configuration file found. Using default configuration (logging only errors to the console), or user programmatically provided configurations. Set system property 'log4j2.debug' to show Log4j 2 internal initialization logging. See [https://logging.apache.org/log4j/2.x/manual/configuration.html](https://logging.apache.org/log4j/2.x/manual/configuration.html) for instructions on how to configure Log4j 2  
SettingsException[Failed to load settings from [elasticsearch.yml]]; nested: MarkedYAMLException[while parsing a block mapping  
in 'reader', line 33, column 1:  
path.data: /var/lib/elasticsearch  
^  
expected , but found Scalar  
in 'reader', line 66, column 2:  
The default list of hosts is [17 ...  
^

at [Source: sun.nio.ch.ChannelInputStream@66ea810; line: 59, column: 16]]; nested: ParserException[while parsing a block mapping  
in 'reader', line 33, column 1:  
path.data: /var/lib/elasticsearch  
^  
expected , but found Scalar  
in 'reader', line 66, column 2:  
The default list of hosts is [17 ...  
^  
];  
at org.elasticsearch.common.settings.Settings$Builder.loadFromStream(Settings.java:1097)  
at org.elasticsearch.common.settings.Settings$Builder.loadFromPath(Settings.java:1070)  
at org.elasticsearch.node.InternalSettingsPreparer.prepareEnvironment(InternalSettingsPreparer.java:83)  
at org.elasticsearch.cli.EnvironmentAwareCommand.createEnv(EnvironmentAwareCommand.java:95)  
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86)  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124)  
at org.elasticsearch.cli.Command.main(Command.java:90)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:115)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92)  
Caused by: com.fasterxml.jackson.dataformat.yaml.snakeyaml.error.MarkedYAMLException: while parsing a block mapping  
in 'reader', line 33, column 1:  
path.data: /var/lib/elasticsearch  
^  
expected , but found Scalar  
in 'reader', line 66, column 2:  
The default list of hosts is [17 ...  
^

at [Source: sun.nio.ch.ChannelInputStream@66ea810; line: 59, column: 16]  
at com.fasterxml.jackson.dataformat.yaml.snakeyaml.error.MarkedYAMLException.from(MarkedYAMLException.java:27)  
at com.fasterxml.jackson.dataformat.yaml.YAMLParser.nextToken(YAMLParser.java:343)  
at org.elasticsearch.common.xcontent.json.JsonXContentParser.nextToken(JsonXContentParser.java:52)  
at org.elasticsearch.common.settings.Settings.fromXContent(Settings.java:645)  
at org.elasticsearch.common.settings.Settings.fromXContent(Settings.java:620)  
at org.elasticsearch.common.settings.Settings.access$400(Settings.java:82)  
at org.elasticsearch.common.settings.Settings$Builder.loadFromStream(Settings.java:1093)  
... 8 more  
Caused by: while parsing a block mapping  
in 'reader', line 33, column 1:  
path.data: /var/lib/elasticsearch  
^  
expected , but found Scalar  
in 'reader', line 66, column 2:  
The default list of hosts is [17 ...  
^

```
at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(ParserImpl.java:569)
at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:157)
at org.yaml.snakeyaml.parser.ParserImpl.getEvent(ParserImpl.java:167)
at com.fasterxml.jackson.dataformat.yaml.YAMLParser.nextToken(YAMLParser.java:340)
... 13 more
```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 11, 2019, 6:26am UTC](https://discuss.elastic.co/t/head-kopf-plugin/198583/6 "2019-10-11T06:26:54Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
