# Health check failed

**URL:** <https://discuss.elastic.co/t/health-check-failed/189446>\
**Category:** Elasticsearch\
**Created:** [July 9, 2019, 2:16am UTC](https://discuss.elastic.co/t/health-check-failed/189446 "2019-07-09T02:16:53Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![wenchaodu](https://avatars.discourse-cdn.com/v4/letter/w/73ab20/32.png) [@wenchaodu](https://discuss.elastic.co/u/wenchaodu)\
**Post date:** [July 9, 2019, 2:16am UTC](https://discuss.elastic.co/t/health-check-failed/189446/1 "2019-07-09T02:16:53Z")

</div>

Hi Team

I install elasticsearch 7.2 and only one node, after installed, when I check with curl localhost:9200, it's seem working and return information such version, cluster\_name etc, but when i check the health with localhost:9200/\_cat/health

it's show me the error "{"error":{"root\_cause":[{"type":"master\_not\_discovered\_exception","reason":null}],"type":"master\_not\_discovered\_exception","reason":null},"status":503}"

is there anything configuration incorrect ?

Thanks  
Wayne

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [July 9, 2019, 2:50am UTC](https://discuss.elastic.co/t/health-check-failed/189446/2 "2019-07-09T02:50:43Z")

</div>

> [@wenchaodu](#):
>
> is there anything configuration incorrect ?

Can you share your config?

---

<div class="post-metadata">

**Author:** ![wenchaodu](https://avatars.discourse-cdn.com/v4/letter/w/73ab20/32.png) [@wenchaodu](https://discuss.elastic.co/u/wenchaodu)\
**Post date:** [July 9, 2019, 3:10am UTC](https://discuss.elastic.co/t/health-check-failed/189446/3 "2019-07-09T03:10:19Z")

</div>

```
#
#bootstrap.memory_lock: true
#
# Make sure that the heap size is set to about half the memory available
# on the system and that the owner of the process is allowed to use this
# limit.
#
# Elasticsearch performs poorly when the system is swapping the memory.
#
# ---------------------------------- Network -----------------------------------
#
# Set the bind address to a specific IP (IPv4 or IPv6):
#
network.host: 0.0.0.0
#
# Set a custom port for HTTP:
#
http.port: 9200
#
# For more information, consult the network module documentation.
#
# --------------------------------- Discovery ----------------------------------
#
# Pass an initial list of hosts to perform discovery when this node is started:
# The default list of hosts is ["127.0.0.1", "[::1]"]
#
discovery.seed_hosts: ["127.0.0.1", "[::1]"]
#
# Bootstrap the cluster using an initial set of master-eligible nodes:
#
#cluster.initial_master_nodes: ["node-1", "node-2"]
#
# For more information, consult the discovery and cluster formation module documentation.
#
# ---------------------------------- Gateway -----------------------------------
#
# Block initial recovery after a full cluster restart until N nodes are started:
#
#gateway.recover_after_nodes: 3
#
# For more information, consult the gateway module documentation.
#
# ---------------------------------- Various -----------------------------------
#
# Require explicit names when deleting indices:
#
#action.destructive_requires_name: true
bootstrap.memory_lock: false
bootstrap.system_call_filter: false
#xpack.security.enabled: true
```

---

<div class="post-metadata">

**Author:** ![wenchaodu](https://avatars.discourse-cdn.com/v4/letter/w/73ab20/32.png) [@wenchaodu](https://discuss.elastic.co/u/wenchaodu)\
**Post date:** [July 9, 2019, 3:12am UTC](https://discuss.elastic.co/t/health-check-failed/189446/4 "2019-07-09T03:12:26Z")

</div>

@warkolm Thanks your response, above is the full configuration

Thanks  
Wayne

---

<div class="post-metadata">

**Author:** ![wenchaodu](https://avatars.discourse-cdn.com/v4/letter/w/73ab20/32.png) [@wenchaodu](https://discuss.elastic.co/u/wenchaodu)\
**Post date:** [July 9, 2019, 4:21am UTC](https://discuss.elastic.co/t/health-check-failed/189446/5 "2019-07-09T04:21:48Z")

</div>

this issue fixed, thanks for help

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [July 9, 2019, 4:30am UTC](https://discuss.elastic.co/t/health-check-failed/189446/6 "2019-07-09T04:30:59Z")

</div>

Please share the solution in the thread, it might help someone in future 🙂

---

<div class="post-metadata">

**Author:** ![wenchaodu](https://avatars.discourse-cdn.com/v4/letter/w/73ab20/32.png) [@wenchaodu](https://discuss.elastic.co/u/wenchaodu)\
**Post date:** [July 9, 2019, 6:22am UTC](https://discuss.elastic.co/t/health-check-failed/189446/7 "2019-07-09T06:22:02Z")

</div>

Resolved this issue by enable below setting

node.name: node-1  
discovery.seed\_hosts: ["node-1"]  
cluster.initial\_master\_nodes: ["node-1"]

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 6, 2019, 6:29am UTC](https://discuss.elastic.co/t/health-check-failed/189446/8 "2019-08-06T06:29:21Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
