# Heartbeat (7.16.3) - missing required field accessing 'schedule'

**URL:** <https://discuss.elastic.co/t/heartbeat-7-16-3-missing-required-field-accessing-schedule/294782>\
**Category:** Beats\
**Tags:** heartbeat\
**Created:** [January 19, 2022, 7:55am UTC](https://discuss.elastic.co/t/heartbeat-7-16-3-missing-required-field-accessing-schedule/294782 "2022-01-19T07:55:40Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![jurgenhaas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jurgenhaas/32/100518_2.png) [@jurgenhaas](https://discuss.elastic.co/u/jurgenhaas)\
**Post date:** [January 19, 2022, 7:55am UTC](https://discuss.elastic.co/t/heartbeat-7-16-3-missing-required-field-accessing-schedule/294782/1 "2022-01-19T07:55:40Z")

</div>

My heartbeat monitoring is working just fine, but syslog is flooded with error messages like this:

```auto
Jan 19 08:51:38 bslog1 heartbeat[32480]: 2022-01-19T08:51:38.532+0100	ERROR	[reload]	cfgfile/list.go:99	Error creating runner from config: could not parse cfg for datastream error unpacking monitor plugin config: missing required field accessing 'schedule'

```

The config files have entries like these:

```auto
- type: http
  schedule: '@every 90s'
  tags:
    - 'example'
  name: 'Example'
  urls:
    - 'https://www.example.com'
  check.request:
    method: GET
  check.response.status: 200
  check.response.body: 'Some text'

```

And I mean "flooded" literally, there are dozens every minute. What could be wrong here?

---

<div class="post-metadata">

**Author:** ![abdulz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/abdulz/32/97601_2.png) [@abdulz](https://discuss.elastic.co/u/abdulz)\
**Post date:** [January 19, 2022, 10:30am UTC](https://discuss.elastic.co/t/heartbeat-7-16-3-missing-required-field-accessing-schedule/294782/2 "2022-01-19T10:30:34Z")

</div>

Hi @jurgenhaas,

Thank you for your first post and welcome to the community!

Is this the only monitor in your YAML? And, which version of heartbeat you are on?

---

<div class="post-metadata">

**Author:** ![jurgenhaas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jurgenhaas/32/100518_2.png) [@jurgenhaas](https://discuss.elastic.co/u/jurgenhaas)\
**Post date:** [January 19, 2022, 10:42am UTC](https://discuss.elastic.co/t/heartbeat-7-16-3-missing-required-field-accessing-schedule/294782/3 "2022-01-19T10:42:31Z")

</div>

It's version 7.16.3, see topic title.

I'm having 7 config files in `/etc/heartbeat/monitors.d` and each of them have multiple entries like the one above.

Those config files get created by a template in Ansible, so it is verified, that each of them has a schedule entry.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 19, 2022, 10:42am UTC](https://discuss.elastic.co/t/heartbeat-7-16-3-missing-required-field-accessing-schedule/294782/4 "2022-01-19T10:42:31Z")

</div>

7.1 is [EOL](https://www.elastic.co/support/eol) and no longer supported. Please upgrade ASAP.

(This is an automated response from your friendly Elastic bot. Please report this post if you have any suggestions or concerns :elasticheart: )

---

<div class="post-metadata">

**Author:** ![jurgenhaas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jurgenhaas/32/100518_2.png) [@jurgenhaas](https://discuss.elastic.co/u/jurgenhaas)\
**Post date:** [January 19, 2022, 10:48am UTC](https://discuss.elastic.co/t/heartbeat-7-16-3-missing-required-field-accessing-schedule/294782/5 "2022-01-19T10:48:46Z")

</div>

It's not 7.1, it's `7.16.3`

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 19, 2022, 10:48am UTC](https://discuss.elastic.co/t/heartbeat-7-16-3-missing-required-field-accessing-schedule/294782/6 "2022-01-19T10:48:46Z")

</div>

7.1 is [EOL](https://www.elastic.co/support/eol) and no longer supported. Please upgrade ASAP.

(This is an automated response from your friendly Elastic bot. Please report this post if you have any suggestions or concerns :elasticheart: )

---

<div class="post-metadata">

**Author:** ![abdulz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/abdulz/32/97601_2.png) [@abdulz](https://discuss.elastic.co/u/abdulz)\
**Post date:** [January 19, 2022, 1:15pm UTC](https://discuss.elastic.co/t/heartbeat-7-16-3-missing-required-field-accessing-schedule/294782/7 "2022-01-19T13:15:59Z")

</div>

@jurgenhaas apologies, I didn't notice the version in title. Also, please disregard the automated version warnings.

I tried to reproduce the issue but couldn't. Can you do us a favor and check which particular file is causing the error. Then, you can check yourself if anything is wrong there, or paste the source here if you couldn't.

You can check a particular file by disabling all others. Under your **monitors.d** directory, rename all the files so that they end with `.disabled` e.g. to test the file _sample.http.yml_ your **monitors.d** should have:

- _sample.http.yml_
- _sample.icmp.yml.disabled_
- _sample.tcp.yml.disabled_

Then from hearbeat's root directory, run `./heartbeat -e`. If there's error in config, you'll see the ERROR line in logs. Otherwise, you'll only see INFO lines.

---

<div class="post-metadata">

**Author:** ![jurgenhaas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jurgenhaas/32/100518_2.png) [@jurgenhaas](https://discuss.elastic.co/u/jurgenhaas)\
**Post date:** [January 19, 2022, 1:52pm UTC](https://discuss.elastic.co/t/heartbeat-7-16-3-missing-required-field-accessing-schedule/294782/8 "2022-01-19T13:52:52Z")

</div>

@abdulz thanks a lot for the instructions. That in fact revealed the issue and it was unnoticed in our Ansible template for years ☹

We have http checks from many different sources, each of which have their own section in that template. And one of them really had the missing schedule setting.

Glad we figured that out and thanks for your support.

---

<div class="post-metadata">

**Author:** ![abdulz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/abdulz/32/97601_2.png) [@abdulz](https://discuss.elastic.co/u/abdulz)\
**Post date:** [January 19, 2022, 2:37pm UTC](https://discuss.elastic.co/t/heartbeat-7-16-3-missing-required-field-accessing-schedule/294782/9 "2022-01-19T14:37:34Z")

</div>

@jurgenhaas pleasure that the problem is resolved. 🙂

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [January 19, 2022, 10:33pm UTC](https://discuss.elastic.co/t/heartbeat-7-16-3-missing-required-field-accessing-schedule/294782/10 "2022-01-19T22:33:27Z")

</div>

Yeah it's not a very smart bot is it!. We've disabled it for the time being.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 17, 2022, 12:34am UTC](https://discuss.elastic.co/t/heartbeat-7-16-3-missing-required-field-accessing-schedule/294782/11 "2022-02-17T00:34:16Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
