# Heartbeat failed to start on adding new monitor

**URL:** https://discuss.elastic.co/t/heartbeat-failed-to-start-on-adding-new-monitor/267343
**Category:** Beats
**Tags:** heartbeat
**Created:** [March 16, 2021, 9:35am UTC](https://discuss.elastic.co/t/heartbeat-failed-to-start-on-adding-new-monitor/267343 "2021-03-16T09:35:50Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Unni\_Kuttan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/unni_kuttan/32/85609_2.png) [@Unni\_Kuttan](https://discuss.elastic.co/u/Unni_Kuttan)
#### Post date: [March 16, 2021, 9:35am UTC](https://discuss.elastic.co/t/heartbeat-failed-to-start-on-adding-new-monitor/267343/1 "2021-03-16T09:35:50Z")

</div>

Upon adding a new monitor(of type tcp) to heartbeat.yml, the heartbeat service stopped .  
Tried to start heartbeat from CLI , thrown the error `Exiting: could not create monitor: error unpacking monitor plugin config: missing field(s) accessing 'heartbeat.monitors.24.schedule' (source:'/etc/heartbeat/heartbeat.yml')`

Heartbeat version : 7.7.1

please suggest a solution

Regards  
Unni

---

<div class="post-metadata">

### Author: ![PaulB-Elastic](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/paulb-elastic/32/78691_2.png) [@PaulB-Elastic](https://discuss.elastic.co/u/PaulB-Elastic)
#### Post date: [March 29, 2021, 8:45am UTC](https://discuss.elastic.co/t/heartbeat-failed-to-start-on-adding-new-monitor/267343/2 "2021-03-29T08:45:02Z")

</div>

Hi @Unni_Kuttan can you share your heartbeat config please (redacting anything you don’t want publicly shown), thanks.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [April 26, 2021, 10:45am UTC](https://discuss.elastic.co/t/heartbeat-failed-to-start-on-adding-new-monitor/267343/3 "2021-04-26T10:45:35Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
