# HEARTBEAT: most of HTTP monitors fail from time to time

**URL:** https://discuss.elastic.co/t/heartbeat-most-of-http-monitors-fail-from-time-to-time/192557
**Category:** Beats
**Created:** [July 28, 2019, 10:13am UTC](https://discuss.elastic.co/t/heartbeat-most-of-http-monitors-fail-from-time-to-time/192557 "2019-07-28T10:13:51Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![George\_Wainwright](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/george_wainwright/32/51054_2.png) [@George\_Wainwright](https://discuss.elastic.co/u/George_Wainwright)
#### Post date: [July 28, 2019, 10:13am UTC](https://discuss.elastic.co/t/heartbeat-most-of-http-monitors-fail-from-time-to-time/192557/1 "2019-07-28T10:13:51Z")

</div>

From time to time most of my configured HTTP monitors fail with next errors:  
`read: connection reset by peer`  
or  
`http: request timed out while waiting for response (Client.Timeout exceeded while awaiting headers)`  
or  
`EOF`

I tried to increase schedule interval for them form 1 minute to 2 or 3, it a bit helped since I started less frequently see those errors, however they occur from time to time.

In Heartbeat logs I do not see any errors. Those errors I see in Kibana Uptime section.

All of those monitors have the next pattern:  
- type: http  
schedule: '@every 2m'  
username: someuser  
password: somepassword  
urls: ["[https://someurl](https://someurl):someport/someuri"]

All of those instances are being resolved fine without delays.  
My heartbeat instance is being run in Kubernetes cluster.

What could be the root of issue for these errors?

I use 6.7.2 version of all Elastic stack.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [August 25, 2019, 12:13pm UTC](https://discuss.elastic.co/t/heartbeat-most-of-http-monitors-fail-from-time-to-time/192557/2 "2019-08-25T12:13:51Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
