# Heartbeat startup error

**URL:** https://discuss.elastic.co/t/heartbeat-startup-error/184973
**Category:** Beats
**Tags:** heartbeat
**Created:** [June 10, 2019, 11:04am UTC](https://discuss.elastic.co/t/heartbeat-startup-error/184973 "2019-06-10T11:04:30Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![andre\_b](https://avatars.discourse-cdn.com/v4/letter/a/ecd19e/32.png) [@andre\_b](https://discuss.elastic.co/u/andre_b)
#### Post date: [June 10, 2019, 11:04am UTC](https://discuss.elastic.co/t/heartbeat-startup-error/184973/1 "2019-06-10T11:04:31Z")

</div>

Hi all,  
I'm trying to configure heartbeat-elastic without success. When I try to start the service I get this error:  
● heartbeat-elastic.service - Ping remote services for availability and log results to Elasticsearch or send to Logstash.  
Loaded: loaded (/lib/systemd/system/heartbeat-elastic.service; enabled; vendor preset: enabled)  
Active: failed (Result: start-limit-hit) since Mon 2019-06-10 10:22:37 UTC; 27min ago  
Docs: [https://www.elastic.co/products/beats/heartbeat](https://www.elastic.co/products/beats/heartbeat)  
Process: 12111 ExecStart=/usr/share/heartbeat/bin/heartbeat -c /etc/heartbeat/heartbeat.yml -path.home /usr/share/heartbeat -path.config /etc/heartbeat -path.data /va  
Main PID: 12111 (code=exited, status=1/FAILURE)

Jun 10 10:22:37 host systemd[1]: heartbeat-elastic.service: Unit entered failed state.  
Jun 10 10:22:37 host systemd[1]: heartbeat-elastic.service: Failed with result 'exit-code'.  
Jun 10 10:22:37 host systemd[1]: heartbeat-elastic.service: Service hold-off time over, scheduling restart.  
Jun 10 10:22:37 host systemd[1]: Stopped Ping remote services for availability and log results to Elasticsearch or send to Logstash..  
Jun 10 10:22:37host systemd[1]: heartbeat-elastic.service: Start request repeated too quickly.  
Jun 10 10:22:37 host systemd[1]: Failed to start Ping remote services for availability and log results to Elasticsearch or send to Logstash..  
Jun 10 10:22:37 host systemd[1]: heartbeat-elastic.service: Unit entered failed state.  
Jun 10 10:22:37 host systemd[1]: heartbeat-elastic.service: Failed with result 'start-limit-hit'.

I guess that it has some problem of configuration but checking the heartbeat.yml file all seems correct:  
heartbeat.monitors:

- type: tcp  
hosts: ${EXAMPLE}  
schedule: '@every 10s'  
processors:
- add\_cloud\_metadata: ~
- add\_host\_metadata:  
netinfo.enabled: true
- add\_locale: ~  
fields:  
name: "{EXAMPLE}" owneremail: "{EXAMPLE}"  
projectid: "{EXAMPLE}" orgscope: "{EXAMPLE}"  
functionalscope: "{EXAMPLE}" environment: "{EXAMPLE}"  
tier: "{EXAMPLE}" applicationid: "{EXAMPLE}"  
appversion: "{EXAMPLE}" stage: "{EXAMPLE}"  
network: "{EXAMPLE}" setup.template.settings: index.number\_of\_shards: 1 index.codec: best\_compression output.elasticsearch: hosts: {EXAMPLE}  
protocol: "https"  
username: {EXAMPLE} password: {EXAMPLE}  
ssl.verification\_mode: none  
ssl.supported\_protocols: [TLSv1.2]  
xpack.monitoring.enabled: true

All variables are correctly sets and works with other beats..any clue? thank you

---

<div class="post-metadata">

### Author: ![Andrew\_Cholakian1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrew_cholakian1/32/3612_2.png) [@Andrew\_Cholakian1](https://discuss.elastic.co/u/Andrew_Cholakian1)
#### Post date: [June 11, 2019, 3:13pm UTC](https://discuss.elastic.co/t/heartbeat-startup-error/184973/2 "2019-06-11T15:13:11Z")

</div>

Can you share your heartbeat log output? The output from systemd doesn't contain enough info.

---

<div class="post-metadata">

### Author: ![AndrewMcQ](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrewmcq/32/23131_2.png) [@AndrewMcQ](https://discuss.elastic.co/u/AndrewMcQ)
#### Post date: [July 2, 2019, 10:52pm UTC](https://discuss.elastic.co/t/heartbeat-startup-error/184973/4 "2019-07-02T22:52:01Z")

</div>

andre\_b -- Any update on whether you were able to work past this error?

I'm seeing this as well and would appreciate an update if you have one.

---

<div class="post-metadata">

### Author: ![andre\_b](https://avatars.discourse-cdn.com/v4/letter/a/ecd19e/32.png) [@andre\_b](https://discuss.elastic.co/u/andre_b)
#### Post date: [July 3, 2019, 7:53am UTC](https://discuss.elastic.co/t/heartbeat-startup-error/184973/5 "2019-07-03T07:53:10Z")

</div>

hi Andrew,

the only way to let it work is writing all value, don't now why but defining these value by environment variables it doesn't work. I'm running the 6.7.1 maybe has been fixed with latest updates.  
It's quite strange because other beats are working correctly with that settings

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 31, 2019, 9:53am UTC](https://discuss.elastic.co/t/heartbeat-startup-error/184973/6 "2019-07-31T09:53:15Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
