# Hearthbeat dashboard

**URL:** <https://discuss.elastic.co/t/hearthbeat-dashboard/126721>\
**Category:** Beats\
**Tags:** heartbeat\
**Created:** [April 4, 2018, 10:39am UTC](https://discuss.elastic.co/t/hearthbeat-dashboard/126721 "2018-04-04T10:39:21Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ninoslav](https://avatars.discourse-cdn.com/v4/letter/n/edb3f5/32.png) [@Ninoslav](https://discuss.elastic.co/u/Ninoslav)\
**Post date:** [April 4, 2018, 10:39am UTC](https://discuss.elastic.co/t/hearthbeat-dashboard/126721/1 "2018-04-04T10:39:21Z")

</div>

Hi gys,

In my current setup, i have 2 CPU-s, 8GB RAM, no cluster.

I have installed hearthbeat packet, to monitor the system performance of my Elastic stack, but when i try to load dashboard i get an error:

> The request for this panel failed.  
> rejected execution of org.elasticsearch.action.search.FetchSearchPhase$1@45a37a3a on EsThreadPoolExecutor[search, queue capacity = 1000, org.elasticsearch.common.util.concurrent.EsThreadPoolExecutor@487441d4[Running, pool size = 4, active threads = 4, queued tasks = 1233, completed tasks = 793949]]

Does this error occur, simply cause my machine is under provisioned?  
Is there a way to enlarge queue capacity, or time needed to get all the data?  
Or any other way to fix this problem, without provisioning more hardware?

Thanks in advance.

Ninoslav.

---

<div class="post-metadata">

**Author:** ![kvch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kvch/32/72058_2.png) [@kvch](https://discuss.elastic.co/u/kvch)\
**Post date:** [April 4, 2018, 2:05pm UTC](https://discuss.elastic.co/t/hearthbeat-dashboard/126721/2 "2018-04-04T14:05:43Z")

</div>

How did you import the dashboard?

---

<div class="post-metadata">

**Author:** ![Ninoslav](https://avatars.discourse-cdn.com/v4/letter/n/edb3f5/32.png) [@Ninoslav](https://discuss.elastic.co/u/Ninoslav)\
**Post date:** [April 4, 2018, 2:17pm UTC](https://discuss.elastic.co/t/hearthbeat-dashboard/126721/3 "2018-04-04T14:17:18Z")

</div>

Hi kvch,

The command was heartbeat setup --dashboards + local parameters,

Dashboard it self is working fine, and I get results on it, but when i load a longer time period of data, some of visualizations throws an error mentioned above, if i try to reload it, some other visualizations throws an error.

And the error clearly states that queued tasks = 1233 and queue capacity = 1000, so i think that i need to enlarge my queue, but i don't know how 😕

---

<div class="post-metadata">

**Author:** ![kvch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kvch/32/72058_2.png) [@kvch](https://discuss.elastic.co/u/kvch)\
**Post date:** [April 4, 2018, 2:21pm UTC](https://discuss.elastic.co/t/hearthbeat-dashboard/126721/4 "2018-04-04T14:21:36Z")

</div>

It sounds like it is a Kibana problem. Could you please ask your question in the Kibana forum?

---

<div class="post-metadata">

**Author:** ![Ninoslav](https://avatars.discourse-cdn.com/v4/letter/n/edb3f5/32.png) [@Ninoslav](https://discuss.elastic.co/u/Ninoslav)\
**Post date:** [April 4, 2018, 2:23pm UTC](https://discuss.elastic.co/t/hearthbeat-dashboard/126721/5 "2018-04-04T14:23:23Z")

</div>

Is there a way to revert this post to kibana forum, or do i need to open a new one?

---

<div class="post-metadata">

**Author:** ![kvch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kvch/32/72058_2.png) [@kvch](https://discuss.elastic.co/u/kvch)\
**Post date:** [April 4, 2018, 2:50pm UTC](https://discuss.elastic.co/t/hearthbeat-dashboard/126721/6 "2018-04-04T14:50:33Z")

</div>

Open a new question.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 2, 2018, 2:50pm UTC](https://discuss.elastic.co/t/hearthbeat-dashboard/126721/7 "2018-05-02T14:50:36Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
