# Hello World for ELK Stack with Filebeats in windows 10, Please Help

**URL:** <https://discuss.elastic.co/t/hello-world-for-elk-stack-with-filebeats-in-windows-10-please-help/142677>\
**Category:** Logstash\
**Created:** [August 2, 2018, 5:04am UTC](https://discuss.elastic.co/t/hello-world-for-elk-stack-with-filebeats-in-windows-10-please-help/142677 "2018-08-02T05:04:53Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ab\_A](https://avatars.discourse-cdn.com/v4/letter/a/5fc32e/32.png) [@Ab\_A](https://discuss.elastic.co/u/Ab_A)\
**Post date:** [August 2, 2018, 5:04am UTC](https://discuss.elastic.co/t/hello-world-for-elk-stack-with-filebeats-in-windows-10-please-help/142677/1 "2018-08-02T05:04:54Z")

</div>

I am new to ELK Stack and unable to get basic working. Please help.

## Steps Done:

- Started elasticsearch.bat (Started Fine)

- Open [http://localhost:9200](http://localhost:9200) in Chrome and got:

- Logstash sample.conf file in logstash dir

-sample.conf

```
    input {
  beats {
    type => beats
    port => 5044
	host => "localhost"
  }
}
 
filter {
    grok {
      match => ["message", "%{TIMESTAMP_IS08601:timestamp_string}%{SPACE}%{GREEDYDATA:line}"]
    }
  }
  
  date {
    match => ["timestamp_string" , "IS08601"]
  }
  
  mutate {
    remove_field => [message, timestamp_string]
  }
}
 
output {
   
  stdout {
    codec => rubydebug
  }

}

```

- logstash.yml

- Started logstash using command from logstash directory

- Here is the last line from the command window after starting logstash

- Filebeat sample.log file

- filebeat.yml file

- Running following command to start filebeat through elevated command prompt

I get the following error:(few lines)

```
        2018-08-02T00:25:22.481+0530 INFO registrar/registrar.go:117 Loading registrar data from C:\Program Files\filebeat-6.3.2-windows-x86_64\data\registry
    2018-08-02T00:25:22.490+0530 INFO registrar/registrar.go:124 States Loaded from registrar: 2
    2018-08-02T00:25:22.492+0530 WARN beater/filebeat.go:354 Filebeat is unable to load the Ingest Node pipelines for the configured modules because the Elasticsearch output is not configured/enabled. If you have already loaded the Ingest Node pipelines or are using Logstash pipelines, you can ignore this warning.
    2018-08-02T00:25:22.493+0530 INFO crawler/crawler.go:48 Loading Inputs: 1
    2018-08-02T00:25:22.502+0530 INFO log/input.go:118 Configured paths: [C:\Program Files\filebeat-6.3.2-windows-x86_64\sample.log]
    2018-08-02T00:25:22.503+0530 INFO input/input.go:88 Starting input of type: log; ID: 6142389514979083186
    2018-08-02T00:25:22.510+0530 INFO crawler/crawler.go:82 Loading and starting Inputs completed. Enabled inputs: 1
    2018-08-02T00:25:22.511+0530 INFO log/harvester.go:228 Harvester started for file: C:\Program Files\filebeat-6.3.2-windows-x86_64\sample.log
    2018-08-02T00:25:23.532+0530 ERROR logstash/async.go:235 Failed to publish events caused by: lumberjack protocol error
    2018-08-02T00:25:23.535+0530 ERROR logstash/async.go:235 Failed to publish events caused by: client is not connected
```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 30, 2018, 5:04am UTC](https://discuss.elastic.co/t/hello-world-for-elk-stack-with-filebeats-in-windows-10-please-help/142677/2 "2018-08-30T05:04:59Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
