# HELP! Kibana Error Connecting to ES on Docker - Cannot Revive Connection

**URL:** https://discuss.elastic.co/t/help-kibana-error-connecting-to-es-on-docker-cannot-revive-connection/194347
**Category:** Kibana
**Created:** [August 8, 2019, 3:00am UTC](https://discuss.elastic.co/t/help-kibana-error-connecting-to-es-on-docker-cannot-revive-connection/194347 "2019-08-08T03:00:18Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![iukea](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/iukea/32/49083_2.png) [@iukea](https://discuss.elastic.co/u/iukea)
#### Post date: [August 8, 2019, 3:00am UTC](https://discuss.elastic.co/t/help-kibana-error-connecting-to-es-on-docker-cannot-revive-connection/194347/1 "2019-08-08T03:00:18Z")

</div>

Hello,  
I keep on getting the following error

```auto
{"type":"log","@timestamp":"2019-08-08T02:52:45Z","tags":["warning","elasticsearch","admin"],"pid":1,"message":"No living connections"}
{"type":"log","@timestamp":"2019-08-08T02:52:45Z","tags":["warning","task_manager"],"pid":1,"message":"PollError No Living connections"}
{"type":"log","@timestamp":"2019-08-08T02:52:46Z","tags":["warning","elasticsearch","admin"],"pid":1,"message":"Unable to revive connection: http://192.168.86.2:9200/"}
{"type":"log","@timestamp":"2019-08-08T02:52:46Z","tags":["warning","elasticsearch","admin"],"pid":1,"message":"No living connections"}
{"type":"log","@timestamp":"2019-08-08T02:52:48Z","tags":["warning","elasticsearch","admin"],"pid":1,"message":"Unable to revive connection: http://192.168.86.2:9200/"}
{"type":"log","@timestamp":"2019-08-08T02:52:48Z","tags":["warning","elasticsearch","admin"],"pid":1,"message":"No living connections"}

```

kibana.yml file

```auto
xpack.infra.enabled: true
xpack.logstash.enabled: true
xpack.canvas.enabled: true
xpack.spaces.enabled: true
xpack.apm.enabled: true
xpack.security.enabled: true
xpack.reporting.enabled: true
xpack.ml.enabled: true
server.port: 5601
server.host: "0.0.0.0"
elasticsearch.hosts: ["http://192.168.86.2:9200"]

```

```auto
version: '2.3'
services:
#### ELK
## Elasticsearch service
  elasticsearch:
    container_name: elasticsearch
    restart: always
    environment:
     - bootstrap.memory_lock=true
     - "ES_JAVA_OPTS=-Xms2g -Xmx2g"
     - ES_TMPDIR=/tmp
    cap_add:
     - IPC_LOCK
    ulimits:
      memlock:
        soft: -1
        hard: -1
      nofile:
        soft: 65536
        hard: 65536
    mem_limit: 6g
    ports:
     - "127.0.0.1:64298:9200"
    image: "iukea/develasticsearch:4"
    volumes:
     - /data:/data

## Kibana service
  kibana:
    container_name: kibana
    restart: always
    network_mode: "host"
    ports:
     - "127.0.0.1:64296:5601"
    image: "iukea/devkibana:11"

## Logstash service
  logstash:
    container_name: logstash
    restart: always
    env_file:
     - /opt/ThreatSpy/etc/compose/elk_environment
    image: "iukea/logstash:4019"
    volumes:
     - /data:/data
    ports:
     - "6990:6990"

## Elasticsearch-head service
  head:
    container_name: head
    restart: always
    ports:
     - "127.0.0.1:64302:9100"
    image: "dtagdevsec/head:1811"
    read_only: false

```

any advice?

---

<div class="post-metadata">

### Author: ![iukea](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/iukea/32/49083_2.png) [@iukea](https://discuss.elastic.co/u/iukea)
#### Post date: [August 8, 2019, 3:22am UTC](https://discuss.elastic.co/t/help-kibana-error-connecting-to-es-on-docker-cannot-revive-connection/194347/2 "2019-08-08T03:22:44Z")

</div>

well i am a dummy

elasticsearch.hosts: ["[http://127.0.0.1:64298](http://127.0.0.1:64298)"]

did the trick lol

---

<div class="post-metadata">

### Author: ![tiagocosta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tiagocosta/32/40045_2.png) [@tiagocosta](https://discuss.elastic.co/u/tiagocosta)
#### Post date: [August 9, 2019, 2:41pm UTC](https://discuss.elastic.co/t/help-kibana-error-connecting-to-es-on-docker-cannot-revive-connection/194347/3 "2019-08-09T14:41:55Z")

</div>

@iukea you also have a strange configuration here:

```auto
ports:
     - "127.0.0.1:64298:9200"

```

I'll mark this as solved

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [September 6, 2019, 2:44pm UTC](https://discuss.elastic.co/t/help-kibana-error-connecting-to-es-on-docker-cannot-revive-connection/194347/4 "2019-09-06T14:44:54Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
