# Help please - Elasticsearch not start CentOs 7

**URL:** <https://discuss.elastic.co/t/help-please-elasticsearch-not-start-centos-7/206811>\
**Category:** Logstash\
**Created:** [November 6, 2019, 2:57pm UTC](https://discuss.elastic.co/t/help-please-elasticsearch-not-start-centos-7/206811 "2019-11-06T14:57:14Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Paulo\_Lima](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/paulo_lima/32/57197_2.png) [@Paulo\_Lima](https://discuss.elastic.co/u/Paulo_Lima)\
**Post date:** [November 6, 2019, 2:57pm UTC](https://discuss.elastic.co/t/help-please-elasticsearch-not-start-centos-7/206811/1 "2019-11-06T14:57:14Z")

</div>

Please help me, I have the following error when starting the service

[root@jcnslcapp9005 ~]# service elasticsearch status  
● elasticsearch.service - Elasticsearch  
Loaded: loaded (/etc/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)  
Active: failed (Result: exit-code) since Wed 2019-11-06 11:54:26 -03; 12s ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 2227 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)  
Main PID: 2227 (code=exited, status=1/FAILURE)

Nov 06 11:54:26 jcnslcapp9005 elasticsearch[2227]: at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentA...a:86)  
Nov 06 11:54:26 jcnslcapp9005 elasticsearch[2227]: at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:125)  
Nov 06 11:54:26 jcnslcapp9005 elasticsearch[2227]: at org.elasticsearch.cli.Command.main(Command.java:90)  
Nov 06 11:54:26 jcnslcapp9005 elasticsearch[2227]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:115)  
Nov 06 11:54:26 jcnslcapp9005 elasticsearch[2227]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92)  
Nov 06 11:54:26 jcnslcapp9005 elasticsearch[2227]: Refer to the log for complete error details.  
Nov 06 11:54:26 jcnslcapp9005 systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE  
Nov 06 11:54:26 jcnslcapp9005 systemd[1]: Failed to start Elasticsearch.  
Nov 06 11:54:26 jcnslcapp9005 systemd[1]: Unit elasticsearch.service entered failed state.  
Nov 06 11:54:26 jcnslcapp9005 systemd[1]: elasticsearch.service failed.  
Hint: Some lines were ellipsized, use -l to show in full.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 4, 2019, 2:57pm UTC](https://discuss.elastic.co/t/help-please-elasticsearch-not-start-centos-7/206811/2 "2019-12-04T14:57:15Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
